summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgardenappl2020-01-11 18:34:17 +0200
committergardenappl2020-01-11 18:36:57 +0200
commit84c1f6a574a71d2c06281916f5f23dbc849b0cc4 (patch)
tree582220612e5a6943fc19ddd8ad23a98040d16203
parent7588415cac125b586f5df9abce2406a5aabeb17e (diff)
downloadaur-84c1f6a574a71d2c06281916f5f23dbc849b0cc4.tar.gz
Automatically fetch last release version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 677b0760094b..45e65ed7a490 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = chromium-extension-adnauseam
pkgdesc = An ad-blocker which silently simulates clicks on each blocked ad, confusing trackers
- pkgver = 3.8.401
+ pkgver = 3.9.102
pkgrel = 1
url = https://adnauseam.io
install = chromium-extension-adnauseam.install
arch = any
license = GPL3
makedepends = zip
+ makedepends = grep
+ makedepends = curl
optdepends = chromium: open-source web browser from Google
optdepends = google-chrome: Google's freeware web browser
- source = https://github.com/dhowe/AdNauseam/releases/download/v3.8.401/adnauseam-3.8.401.chromium.zip
- sha256sums = e40d2195be6d42a31d0698952cfb78da62ecad2731c2218868d69f776241308a
+ source = https://github.com/dhowe/AdNauseam/releases/download/v3.9.102/adnauseam-3.9.102.chromium.zip
+ sha256sums = SKIP
pkgname = chromium-extension-adnauseam
diff --git a/PKGBUILD b/PKGBUILD
index b2ef21bf9768..5c837918429e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
# Maintainer: Yurii <yu hrysh at proton mail dot com>
pkgname=chromium-extension-adnauseam
-pkgver=3.8.401
+pkgver=3.9.102
pkgrel=1
pkgdesc='An ad-blocker which silently simulates clicks on each blocked ad, confusing trackers'
arch=('any')
url='https://adnauseam.io'
license=('GPL3')
-makedepends=('zip')
+makedepends=('zip' 'grep' 'curl')
optdepends=("chromium: open-source web browser from Google"
"google-chrome: Google's freeware web browser")
-install="${pkgname}.install"
+install=${pkgname}.install
source=("https://github.com/dhowe/AdNauseam/releases/download/v${pkgver}/adnauseam-${pkgver}.chromium.zip")
+pkgver() {
+ # Automatically get latest release version because I'm too lazy to properly maintain this
+ # This URL redirects you to https://github.com/dhowe/AdNauseam/releases/tag/v%LATEST_VERSION
+ curl https://github.com/dhowe/AdNauseam/releases/latest --silent --location --head --output /dev/null --write-out '%{url_effective}' | grep '\d+(\.\d+)*' --perl-regexp --only-matching
+}
+
package() {
mkdir -p "${pkgdir}/usr/share/${pkgname}"
cp -dr --no-preserve=ownership "${srcdir}/adnauseam.chromium"/* "${pkgdir}/usr/share/${pkgname}/"
}
-sha256sums=('e40d2195be6d42a31d0698952cfb78da62ecad2731c2218868d69f776241308a')
+sha256sums=('SKIP')