summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bourgeois2017-02-12 11:25:05 +0100
committerQuentin Bourgeois2017-02-12 11:25:05 +0100
commit053287e418819108797ef439ec0fa7d61765aab6 (patch)
tree563fe27b5115e65b5fbeaaa2ad549ad70097d003
downloadaur-053287e418819108797ef439ec0fa7d61765aab6.tar.gz
addpkg: chromium-extension-mooltipass 1.1.62-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD31
-rw-r--r--ffemldjbbfhimggdkkckolidemlllklk.json4
5 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e0c4938eb80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = chromium-extension-mooltipass
+ pkgdesc = Retrieve and store Mooltipass credentials easily from websites.
+ pkgver = 1.1.62
+ pkgrel = 1
+ url = https://www.themooltipass.com/setup
+ arch = any
+ license = custom:MIT
+ depends = chromium
+ source = mooltipass.crx::https://clients2.google.com/service/update2/crx?response=redirect&prodversion=49.0&x=id%3Dffemldjbbfhimggdkkckolidemlllklk%26installsource%3Dondemand%26uc
+ source = ffemldjbbfhimggdkkckolidemlllklk.json
+ source = LICENSE
+ sha256sums = 31e119a9b5f88f5081794b8da1152b470d0186085b5b7beffeb37d48fa944fc4
+ sha256sums = 3958de07cee049f6dcaef59983735119dcad4090fa7873191e4de8ed4d535dd5
+ sha256sums = 2af680c39ef493fb82830356d1d3df1acb5a06033cba2dec7a19e21caa77a866
+
+pkgname = chromium-extension-mooltipass
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2a2985e10408
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+chromium-extension-mooltipass-*
+*.crx
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..31ecdfb1dbc5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice shall be included in all
+ copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d48243009478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Quentin Bourgeois <quentin+archlinux@bourgeois.eu>
+
+_extension_name='mooltipass'
+_extension_id='ffemldjbbfhimggdkkckolidemlllklk'
+_store_base_url='https://clients2.google.com/service/update2/crx?response=redirect&prodversion=49.0&x=id%3D'
+pkgname="chromium-extension-${_extension_name}"
+pkgver=1.1.62
+pkgrel=1
+pkgdesc='Retrieve and store Mooltipass credentials easily from websites.'
+license=('custom:MIT')
+arch=('any')
+url='https://www.themooltipass.com/setup'
+depends=('chromium')
+source=("${_extension_name}.crx::${_store_base_url}${_extension_id}%26installsource%3Dondemand%26uc"
+ "${_extension_id}.json"
+ 'LICENSE')
+sha256sums=('31e119a9b5f88f5081794b8da1152b470d0186085b5b7beffeb37d48fa944fc4'
+ '3958de07cee049f6dcaef59983735119dcad4090fa7873191e4de8ed4d535dd5'
+ '2af680c39ef493fb82830356d1d3df1acb5a06033cba2dec7a19e21caa77a866')
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm 644 "${_extension_name}.crx" \
+ "${pkgdir}/usr/lib/${CARCH}-linux-gnu/${_extension_name}-chromium/${_extension_name}.crx"
+
+ install -Dm 644 "${_extension_id}.json" \
+ "${pkgdir}/usr/share/chromium/extensions/${_extension_id}.json"
+
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/ffemldjbbfhimggdkkckolidemlllklk.json b/ffemldjbbfhimggdkkckolidemlllklk.json
new file mode 100644
index 000000000000..f5134da0a1e2
--- /dev/null
+++ b/ffemldjbbfhimggdkkckolidemlllklk.json
@@ -0,0 +1,4 @@
+{
+ "external_crx": "/usr/lib/x86_64-linux-gnu/mooltipass-chromium/mooltipass.crx",
+ "external_version": "1.1.62"
+}