summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2017-09-04 13:38:57 +0200
committerJulian Xhokaxhiu2017-09-04 13:38:57 +0200
commit00f560bd56b6ab63e03fac6cad1ad478cc0c6da6 (patch)
tree17b6fd4cc82d10a488484ad62757b27a4bad65a4
parent8a1cb8c70c01ed4fe40f700450a84bb3164be8db (diff)
downloadaur-00f560bd56b6ab63e03fac6cad1ad478cc0c6da6.tar.gz
Autodetect resolution output
Based on the current one chosen during boot
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--chromium-fullscreen.xinitrc5
3 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cef4a35e98ec..eb6f0608c153 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,7 @@ pkgbase = chromium-fullscreen
depends = xorg-server
depends = xorg-xinit
depends = xorg-xset
+ depends = xorg-xrandr
depends = unclutter
depends = chromium
depends = xlogin-git
@@ -23,7 +24,7 @@ pkgbase = chromium-fullscreen
source = aw-snap-reloader-background.js
source = aw-snap-reloader-manifest.json
md5sums = 9e979fbdd1e4a5a04fd0e91ce6a9a7be
- md5sums = 8b96a42f04183e7f86f6ea644fc72240
+ md5sums = e4d43f727e6948c3f1f6fe868432af36
md5sums = c700c36f4ea3e353c6d49df823561fc4
md5sums = f543ec018edbaf5533e6bddd5068ff54
md5sums = a2e49410d550e79ac9c0037121522387
diff --git a/PKGBUILD b/PKGBUILD
index 169d6f0b108a..4befdefdbde8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="A script in order to run Chromium in fullscreen mode under the chromium
url="https://aur.archlinux.org/packages/chromium-fullscreen/"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('MIT')
-depends=('xorg-server' 'xorg-xinit' 'xorg-xset' 'unclutter' 'chromium' 'xlogin-git')
+depends=('xorg-server' 'xorg-xinit' 'xorg-xset' 'xorg-xrandr' 'unclutter' 'chromium' 'xlogin-git')
install='chromium-fullscreen.install'
source=('chromium-fullscreen.sysuser'
'chromium-fullscreen.xinitrc'
@@ -15,7 +15,7 @@ source=('chromium-fullscreen.sysuser'
'aw-snap-reloader-background.js'
'aw-snap-reloader-manifest.json')
md5sums=('9e979fbdd1e4a5a04fd0e91ce6a9a7be'
- '8b96a42f04183e7f86f6ea644fc72240'
+ 'e4d43f727e6948c3f1f6fe868432af36'
'c700c36f4ea3e353c6d49df823561fc4'
'f543ec018edbaf5533e6bddd5068ff54'
'a2e49410d550e79ac9c0037121522387'
diff --git a/chromium-fullscreen.xinitrc b/chromium-fullscreen.xinitrc
index fb05fb0d6072..d9b6a2e14e4b 100644
--- a/chromium-fullscreen.xinitrc
+++ b/chromium-fullscreen.xinitrc
@@ -1,5 +1,8 @@
#!/bin/bash
+# Get the current resolution
+RESOLUTION=`xrandr | grep \* | awk '{print $1}'`
+
# The URL variuabile where we will store the final address to open
URL=''
@@ -33,5 +36,5 @@ exec /usr/bin/chromium --disable \
--ignore-gpu-blacklist \
--load-extension=.extensions/disable-x-frame-option,.extensions/aw-snap-reloader \
--window-position="0,0" \
- --window-size="1920,1080" \
+ --window-size="$RESOLUTION" \
--kiosk "$URL"