summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2016-09-13 15:18:10 +0200
committerJulian Xhokaxhiu2016-09-13 15:18:10 +0200
commit99960376437e3493e5b86bcb83bf627e4415bbc4 (patch)
tree43d8676f0d178455903539e3f3b1cf8ac6400964
parent062409eea8f1e7c8a1688c0e640c7596674df795 (diff)
downloadaur-99960376437e3493e5b86bcb83bf627e4415bbc4.tar.gz
A more robust solution to boot Chrome fullscreen
Actually hard-coded as 1080p. Next step would be to autodetect it.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--chromium-fullscreen.xinitrc18
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8976b6c5060..d7e5f15edbbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chromium-fullscreen
pkgdesc = A script in order to run Chromium in fullscreen mode under the chromium user
pkgver = 1
- pkgrel = 2
+ pkgrel = 3
install = chromium-fullscreen.install
arch = x86_64
arch = i686
@@ -10,14 +10,14 @@ pkgbase = chromium-fullscreen
arch = armv7h
license = MIT
depends = xorg-server
- depends = xorg-xrandr
depends = xorg-xinit
+ depends = unclutter
depends = chromium
depends = xlogin-git
source = chromium-fullscreen.sysuser
source = chromium-fullscreen.xinitrc
md5sums = 9e979fbdd1e4a5a04fd0e91ce6a9a7be
- md5sums = 9fb3d73709f7461c8381183ac93a4e79
+ md5sums = fb743c05d6c1643b057baf10b2543710
pkgname = chromium-fullscreen
diff --git a/PKGBUILD b/PKGBUILD
index e3eb1e689f70..20d27a2ac1b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Author: Julian Xhokaxhiu <info@julianxhokaxhiu.com>
pkgname=chromium-fullscreen
pkgver=1
-pkgrel=2
+pkgrel=3
pkgdesc="A script in order to run Chromium in fullscreen mode under the chromium user"
url=""
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('MIT')
-depends=('xorg-server' 'xorg-xrandr' 'xorg-xinit' 'chromium' 'xlogin-git')
+depends=('xorg-server' 'xorg-xinit' 'unclutter' 'chromium' 'xlogin-git')
install='chromium-fullscreen.install'
source=('chromium-fullscreen.sysuser'
'chromium-fullscreen.xinitrc')
md5sums=('9e979fbdd1e4a5a04fd0e91ce6a9a7be'
- '9fb3d73709f7461c8381183ac93a4e79')
+ 'fb743c05d6c1643b057baf10b2543710')
package() {
# Copy autorun script
diff --git a/chromium-fullscreen.xinitrc b/chromium-fullscreen.xinitrc
index 05b08a850e68..25e81be9826a 100644
--- a/chromium-fullscreen.xinitrc
+++ b/chromium-fullscreen.xinitrc
@@ -11,6 +11,22 @@ elif [ -f "/home/chromium/chromium-autostart-url.txt" ]; then
URL=`cat /home/chromium/chromium-autostart-url.txt`
fi
+# Disable all energy save features, and leave the monitor always on
+xset s off # don't activate screensaver
+xset -dpms # disable DPMS (Energy Star) features.
+xset s noblank # don't blank the video device
+
+# Hide mouse cursor
+unclutter -display :0.0 -noevents -grab -root -reset &
# Autostart Chromium in Fullscreen mode
-exec /usr/bin/chromium --desktop-window-1080p --kiosk "$URL"
+exec /usr/bin/chromium --disable \
+ --no-first-run \
+ --disable-translate \
+ --disable-infobars \
+ --disable-suggestions-service \
+ --disable-save-password-bubble \
+ --disable-session-crashed-bubble \
+ --window-position="0,0" \
+ --window-size="1920,1080" \
+ --kiosk "$URL"