summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2017-08-03 19:04:43 +0100
committerWorMzy Tykashi2017-08-03 19:06:00 +0100
commit096a35fc90fddb34e16dacce9476117690dca06e (patch)
treedef3b1686307df55a989a473df2d4362f9d2560d
parent1bd42a05ca886d2475da561954fddd6f6115ba0a (diff)
downloadaur-096a35fc90fddb34e16dacce9476117690dca06e.tar.gz
Updated to 60.0.3112.90
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Clip-FreeType-glyph-bitmap-to-mask.patch170
-rw-r--r--PKGBUILD9
3 files changed, 5 insertions, 182 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6290e5770dd9..7675e09906db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chromium-gtk2
pkgdesc = A web browser built for speed, simplicity, and security (GTK2 version)
- pkgver = 60.0.3112.78
+ pkgver = 60.0.3112.90
pkgrel = 1
url = https://www.chromium.org/Home
install = chromium.install
@@ -45,20 +45,18 @@ pkgbase = chromium-gtk2
optdepends = kwallet: for storing passwords in KWallet
provides = chromium
conflicts = chromium
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-60.0.3112.78.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-60.0.3112.90.tar.xz
source = chromium-launcher-5.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v5.tar.gz
source = chromium.desktop
source = chromium-gn-bootstrap-r8.patch
- source = 0001-Clip-FreeType-glyph-bitmap-to-mask.patch
source = chromium-blink-gcc7.patch
source = chromium-v8-gcc7.patch
source = chromium-widevine.patch
source = issue2961473002_1_10001.diff
- sha256sums = a82db2aa1b9348b619c01894db565eba686780de0e6fa9e83a8f406d06ce03ea
+ sha256sums = b42f7965764b4528116622a71a60f52becd4186ff8854f3051bf45c6368739e6
sha256sums = 4dc3428f2c927955d9ae117f2fb24d098cc6dd67adb760ac9c82b522ec8b0587
sha256sums = 028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9
sha256sums = 06345804c00d9618dad98a2dc04f31ef19912cdf6e9d6e577ef7ffb1fa57003f
- sha256sums = e60aa0ff01f8bee67e45fde7bbe932901194984673ec4b10ea82bba1bace0cd7
sha256sums = f94310a7ba9b8b777adfb4442bcc0a8f0a3d549b2cf4a156066f8e2e28e2f323
sha256sums = 46dacc4fa52652b7d99b8996d6a97e5e3bac586f879aefb9fb95020d2c4e5aec
sha256sums = d6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808
diff --git a/0001-Clip-FreeType-glyph-bitmap-to-mask.patch b/0001-Clip-FreeType-glyph-bitmap-to-mask.patch
deleted file mode 100644
index 5a395b53d58e..000000000000
--- a/0001-Clip-FreeType-glyph-bitmap-to-mask.patch
+++ /dev/null
@@ -1,170 +0,0 @@
-From 6cdb5f2ad7684302a8a66217462d2aef4c5f4632 Mon Sep 17 00:00:00 2001
-From: Ben Wagner <bungeman@behemoth.cnc.corp.google.com>
-Date: Thu, 15 Jun 2017 10:43:17 -0400
-Subject: [PATCH] Clip FreeType glyph bitmap to mask.
-
-Skia has for some time assumed that when using FT_Render_Glyph with one
-of the LCD render modes that one extra pixel would be applied to each
-side of the resulting bitmap. FreieType has changed to make this more
-conservative when possible, so the pre-allocated SkMask and the generated
-FT_Bitmap may no longer agree on the size and origin.
-
-This change ensures the SkMask and FT_Bitmap are the same size and their
-origins align. This is not an ideal long term fix, but is both simple and
-localized for easy and quick back-porting, should that become necessary.
-
-BUG=skia:6663
-
-Change-Id: I49ec8f45376be8d867e8aef54eab79537731c310
-Reviewed-on: https://skia-review.googlesource.com/20327
-Reviewed-by: Herb Derby <herb@google.com>
-Commit-Queue: Ben Wagner <bungeman@google.com>
----
- src/ports/SkFontHost_FreeType_common.cpp | 100 +++++++++++++++++++++++++------
- 1 file changed, 83 insertions(+), 17 deletions(-)
-
-diff --git a/src/ports/SkFontHost_FreeType_common.cpp b/src/ports/SkFontHost_FreeType_common.cpp
-index 9df7268bb4..a216fdb29c 100644
---- a/src/ports/SkFontHost_FreeType_common.cpp
-+++ b/src/ports/SkFontHost_FreeType_common.cpp
-@@ -395,8 +395,6 @@ void SkScalerContext_FreeType_Base::generateGlyphImage(
- switch ( face->glyph->format ) {
- case FT_GLYPH_FORMAT_OUTLINE: {
- FT_Outline* outline = &face->glyph->outline;
-- FT_BBox bbox;
-- FT_Bitmap target;
-
- int dx = 0, dy = 0;
- if (fRec.fFlags & SkScalerContext::kSubpixelPositioning_Flag) {
-@@ -405,36 +403,97 @@ void SkScalerContext_FreeType_Base::generateGlyphImage(
- // negate dy since freetype-y-goes-up and skia-y-goes-down
- dy = -dy;
- }
-- FT_Outline_Get_CBox(outline, &bbox);
-- /*
-- what we really want to do for subpixel is
-- offset(dx, dy)
-- compute_bounds
-- offset(bbox & !63)
-- but that is two calls to offset, so we do the following, which
-- achieves the same thing with only one offset call.
-- */
-- FT_Outline_Translate(outline, dx - ((bbox.xMin + dx) & ~63),
-- dy - ((bbox.yMin + dy) & ~63));
-+
-+ memset(glyph.fImage, 0, glyph.rowBytes() * glyph.fHeight);
-
- if (SkMask::kLCD16_Format == glyph.fMaskFormat) {
-+ FT_Outline_Translate(outline, dx, dy);
- FT_Error err = FT_Render_Glyph(face->glyph, doVert ? FT_RENDER_MODE_LCD_V :
- FT_RENDER_MODE_LCD);
- if (err) {
- SK_TRACEFTR(err, "Could not render glyph.");
-- sk_bzero(glyph.fImage, glyph.computeImageSize());
- return;
- }
-+
- SkMask mask;
- glyph.toMask(&mask);
-+#ifdef SK_SHOW_TEXT_BLIT_COVERAGE
-+ memset(mask.fImage, 0x80, mask.fBounds.height() * mask.fRowBytes);
-+#endif
-+ FT_GlyphSlotRec& ftGlyph = *face->glyph;
-+
-+ if (!SkIRect::Intersects(mask.fBounds,
-+ SkIRect::MakeXYWH( ftGlyph.bitmap_left,
-+ -ftGlyph.bitmap_top,
-+ ftGlyph.bitmap.width,
-+ ftGlyph.bitmap.rows)))
-+ {
-+ return;
-+ }
-+
-+ // If the FT_Bitmap extent is larger, discard bits of the bitmap outside the mask.
-+ // If the SkMask extent is larger, shrink mask to fit bitmap (clearing discarded).
-+ unsigned char* origBuffer = ftGlyph.bitmap.buffer;
-+ // First align the top left (origin).
-+ if (-ftGlyph.bitmap_top < mask.fBounds.fTop) {
-+ int32_t topDiff = mask.fBounds.fTop - (-ftGlyph.bitmap_top);
-+ ftGlyph.bitmap.buffer += ftGlyph.bitmap.pitch * topDiff;
-+ ftGlyph.bitmap.rows -= topDiff;
-+ ftGlyph.bitmap_top = -mask.fBounds.fTop;
-+ }
-+ if (ftGlyph.bitmap_left < mask.fBounds.fLeft) {
-+ int32_t leftDiff = mask.fBounds.fLeft - ftGlyph.bitmap_left;
-+ ftGlyph.bitmap.buffer += leftDiff;
-+ ftGlyph.bitmap.width -= leftDiff;
-+ ftGlyph.bitmap_left = mask.fBounds.fLeft;
-+ }
-+ if (mask.fBounds.fTop < -ftGlyph.bitmap_top) {
-+ mask.fImage += mask.fRowBytes * (-ftGlyph.bitmap_top - mask.fBounds.fTop);
-+ mask.fBounds.fTop = -ftGlyph.bitmap_top;
-+ }
-+ if (mask.fBounds.fLeft < ftGlyph.bitmap_left) {
-+ mask.fImage += sizeof(uint16_t) * (ftGlyph.bitmap_left - mask.fBounds.fLeft);
-+ mask.fBounds.fLeft = ftGlyph.bitmap_left;
-+ }
-+ // Origins aligned, clean up the width and height.
-+ int ftVertScale = (doVert ? 3 : 1);
-+ int ftHoriScale = (doVert ? 1 : 3);
-+ if (mask.fBounds.height() * ftVertScale < SkToInt(ftGlyph.bitmap.rows)) {
-+ ftGlyph.bitmap.rows = mask.fBounds.height() * ftVertScale;
-+ }
-+ if (mask.fBounds.width() * ftHoriScale < SkToInt(ftGlyph.bitmap.width)) {
-+ ftGlyph.bitmap.width = mask.fBounds.width() * ftHoriScale;
-+ }
-+ if (SkToInt(ftGlyph.bitmap.rows) < mask.fBounds.height() * ftVertScale) {
-+ mask.fBounds.fBottom = mask.fBounds.fTop + ftGlyph.bitmap.rows / ftVertScale;
-+ }
-+ if (SkToInt(ftGlyph.bitmap.width) < mask.fBounds.width() * ftHoriScale) {
-+ mask.fBounds.fRight = mask.fBounds.fLeft + ftGlyph.bitmap.width / ftHoriScale;
-+ }
- if (fPreBlend.isApplicable()) {
-- copyFT2LCD16<true>(face->glyph->bitmap, mask, doBGR,
-+ copyFT2LCD16<true>(ftGlyph.bitmap, mask, doBGR,
- fPreBlend.fR, fPreBlend.fG, fPreBlend.fB);
- } else {
-- copyFT2LCD16<false>(face->glyph->bitmap, mask, doBGR,
-+ copyFT2LCD16<false>(ftGlyph.bitmap, mask, doBGR,
- fPreBlend.fR, fPreBlend.fG, fPreBlend.fB);
- }
-+ // Restore the buffer pointer so FreeType can properly free it.
-+ ftGlyph.bitmap.buffer = origBuffer;
- } else {
-+ FT_BBox bbox;
-+ FT_Bitmap target;
-+ FT_Outline_Get_CBox(outline, &bbox);
-+ /*
-+ what we really want to do for subpixel is
-+ offset(dx, dy)
-+ compute_bounds
-+ offset(bbox & !63)
-+ but that is two calls to offset, so we do the following, which
-+ achieves the same thing with only one offset call.
-+ */
-+ FT_Outline_Translate(outline, dx - ((bbox.xMin + dx) & ~63),
-+ dy - ((bbox.yMin + dy) & ~63));
-+
- target.width = glyph.fWidth;
- target.rows = glyph.fHeight;
- target.pitch = glyph.rowBytes();
-@@ -442,8 +501,15 @@ void SkScalerContext_FreeType_Base::generateGlyphImage(
- target.pixel_mode = compute_pixel_mode( (SkMask::Format)fRec.fMaskFormat);
- target.num_grays = 256;
-
-- memset(glyph.fImage, 0, glyph.rowBytes() * glyph.fHeight);
- FT_Outline_Get_Bitmap(face->glyph->library, outline, &target);
-+#ifdef SK_SHOW_TEXT_BLIT_COVERAGE
-+ for (int y = 0; y < glyph.fHeight; ++y) {
-+ for (int x = 0; x < glyph.fWidth; ++x) {
-+ uint8_t& a = ((uint8_t*)glyph.fImage)[(glyph.rowBytes() * y) + x];
-+ a = SkTMax<uint8_t>(a, 0x20);
-+ }
-+ }
-+#endif
- }
- } break;
-
---
-2.13.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 7c5b6755e961..8012a8f53963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ declare -rgA _system_libs=(
pkgname=chromium-gtk2
_pkgname=chromium
-pkgver=60.0.3112.78
+pkgver=60.0.3112.90
pkgrel=1
_launcher_ver=5
pkgdesc="A web browser built for speed, simplicity, and security (GTK2 version)"
@@ -50,16 +50,14 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkg
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
chromium-gn-bootstrap-r8.patch
- 0001-Clip-FreeType-glyph-bitmap-to-mask.patch
chromium-blink-gcc7.patch
chromium-v8-gcc7.patch
chromium-widevine.patch
issue2961473002_1_10001.diff)
-sha256sums=('a82db2aa1b9348b619c01894db565eba686780de0e6fa9e83a8f406d06ce03ea'
+sha256sums=('b42f7965764b4528116622a71a60f52becd4186ff8854f3051bf45c6368739e6'
'4dc3428f2c927955d9ae117f2fb24d098cc6dd67adb760ac9c82b522ec8b0587'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'06345804c00d9618dad98a2dc04f31ef19912cdf6e9d6e577ef7ffb1fa57003f'
- 'e60aa0ff01f8bee67e45fde7bbe932901194984673ec4b10ea82bba1bace0cd7'
'f94310a7ba9b8b777adfb4442bcc0a8f0a3d549b2cf4a156066f8e2e28e2f323'
'46dacc4fa52652b7d99b8996d6a97e5e3bac586f879aefb9fb95020d2c4e5aec'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
@@ -81,9 +79,6 @@ prepare() {
sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
patch -Np1
- # https://bugs.chromium.org/p/skia/issues/detail?id=6663
- patch -Np1 -d third_party/skia <../0001-Clip-FreeType-glyph-bitmap-to-mask.patch
-
# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853347
patch -Np1 -i ../chromium-blink-gcc7.patch