summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2020-06-21 15:22:28 -0400
committergraysky2020-06-21 15:22:28 -0400
commit0e0804e881e34a585e2b8e4dbd92f5d7357c9d75 (patch)
tree09f86414b7205bc5d9ff790bdf6b9570fd0e1f4b
parent53d699e62926a66bb558269567a236da2948be89 (diff)
downloadaur-0e0804e881e34a585e2b8e4dbd92f5d7357c9d75.tar.gz
Update to 83.0.4103.106-3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--chromium-fix-vaapi-on-intel.patch40
3 files changed, 49 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8438d8f85b7..7d09656cade7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chromium-no-extras
pkgdesc = Chromium without hangout services, widevine, pipewire, or chromedriver
pkgver = 83.0.4103.106
- pkgrel = 2
+ pkgrel = 3
url = https://www.chromium.org/Home
install = chromium.install
arch = x86_64
@@ -67,6 +67,7 @@ pkgbase = chromium-no-extras
source = make-some-of-blink-custom-iterators-STL-compatible.patch
source = avoid-double-destruction-of-ServiceWorkerObjectHost.patch
source = v8-remove-soon-to-be-removed-getAllFieldPositions.patch
+ source = chromium-fix-vaapi-on-intel.patch
source = chromium-83-gcc-10.patch
source = chromium-skia-harmony.patch
sha256sums = cfd153a2e10b0bb0fb3b7e6be543aef0915181f5fbdbea893d08465afd097e2f
@@ -79,6 +80,7 @@ pkgbase = chromium-no-extras
sha256sums = 3d7f20e1d2ee7d73ed25e708c0d59a0cb215fcce10a379e3d48a856533c4b0b7
sha256sums = d793842e9584bf75e3779918297ba0ffa6dd05394ef5b2bf5fb73aa9c86a7e2f
sha256sums = e042024423027ad3ef729a7e4709bdf9714aea49d64cfbbf46a645a05703abc2
+ sha256sums = e495f2477091557b15bff2c99831e0a3db64ea2ebde7dcb22857a6469c944b9a
sha256sums = 3e5ba8c0a70a4bc673deec0c61eb2b58f05a4c784cbdb7c8118be1eb6580db6d
sha256sums = 771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1
diff --git a/PKGBUILD b/PKGBUILD
index 4be0f4e2f39a..3de091f9da76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=chromium-no-extras
pkgver=83.0.4103.106
-pkgrel=2
+pkgrel=3
_pkgname=chromium
_launcher_ver=6
pkgdesc="Chromium without hangout services, widevine, pipewire, or chromedriver"
@@ -37,6 +37,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkg
make-some-of-blink-custom-iterators-STL-compatible.patch
avoid-double-destruction-of-ServiceWorkerObjectHost.patch
v8-remove-soon-to-be-removed-getAllFieldPositions.patch
+ chromium-fix-vaapi-on-intel.patch
chromium-83-gcc-10.patch
chromium-skia-harmony.patch)
sha256sums=('cfd153a2e10b0bb0fb3b7e6be543aef0915181f5fbdbea893d08465afd097e2f'
@@ -49,6 +50,7 @@ sha256sums=('cfd153a2e10b0bb0fb3b7e6be543aef0915181f5fbdbea893d08465afd097e2f'
'3d7f20e1d2ee7d73ed25e708c0d59a0cb215fcce10a379e3d48a856533c4b0b7'
'd793842e9584bf75e3779918297ba0ffa6dd05394ef5b2bf5fb73aa9c86a7e2f'
'e042024423027ad3ef729a7e4709bdf9714aea49d64cfbbf46a645a05703abc2'
+ 'e495f2477091557b15bff2c99831e0a3db64ea2ebde7dcb22857a6469c944b9a'
'3e5ba8c0a70a4bc673deec0c61eb2b58f05a4c784cbdb7c8118be1eb6580db6d'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
@@ -129,6 +131,9 @@ prepare() {
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
+ # Patch from rpmfusion: chromium-freeworld
+ patch -Np1 -i ../chromium-fix-vaapi-on-intel.patch
+
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
diff --git a/chromium-fix-vaapi-on-intel.patch b/chromium-fix-vaapi-on-intel.patch
new file mode 100644
index 000000000000..73281f44ddbe
--- /dev/null
+++ b/chromium-fix-vaapi-on-intel.patch
@@ -0,0 +1,40 @@
+From 9ff06536caf7ea51aad9fd2bb649c858eaf7ee84 Mon Sep 17 00:00:00 2001
+From: Akarshan Biswas <akarshanbiswas@fedoraproject.org>
+Date: Sat, 26 Oct 2019 10:06:30 +0530
+Subject: [PATCH] Move offending function to chromeos only
+
+--- a/media/gpu/vaapi/vaapi_video_decode_accelerator.cc
++++ b/media/gpu/vaapi/vaapi_video_decode_accelerator.cc
+@@ -66,6 +66,7 @@ void ReportToUMA(VAVDADecoderFailure fai
+ VAVDA_DECODER_FAILURES_MAX + 1);
+ }
+
++#if defined(OS_ANDROID) || defined(OS_CHROMEOS)
+ // Returns true if the CPU is an Intel Gemini Lake or later (including Kaby
+ // Lake) Cpu platform id's are referenced from the following file in kernel
+ // source arch/x86/include/asm/intel-family.h
+@@ -78,6 +79,7 @@ bool IsGeminiLakeOrLater() {
+ cpuid.model() >= kGeminiLakeModelId;
+ return is_geminilake_or_later;
+ }
++#endif
+
+ } // namespace
+
+@@ -1155,6 +1157,8 @@ VaapiVideoDecodeAccelerator::DecideBuffe
+ if (output_mode_ == VideoDecodeAccelerator::Config::OutputMode::IMPORT)
+ return BufferAllocationMode::kNormal;
+
++#if defined(OS_ANDROID) || defined(OS_CHROMEOS)
++ // Move this to chromeOs only as it is causing problem in some intel linux drivers
+ // On Gemini Lake, Kaby Lake and later we can pass to libva the client's
+ // PictureBuffers to decode onto, which skips the use of the Vpp unit and its
+ // associated format reconciliation copy, avoiding all internal buffer
+@@ -1171,6 +1175,7 @@ VaapiVideoDecodeAccelerator::DecideBuffe
+ num_extra_pics_ = 3;
+ return BufferAllocationMode::kNone;
+ }
++#endif
+
+ // If we're here, we have to use the Vpp unit and allocate buffers for
+ // |decoder_|; usually we'd have to allocate the |decoder_|s