summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2022-07-05 06:45:45 -0400
committergraysky2022-07-05 06:45:45 -0400
commit2099c20b97266013b95633af1ca32fa11feb98ed (patch)
treee8e76bc77541aa1bec24d4dd820f442e257c4276
parent30995de1614dd7c91b42322bf920a6d956f16461 (diff)
downloadaur-2099c20b97266013b95633af1ca32fa11feb98ed.tar.gz
Update to 103.0.5060.114-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
-rwxr-xr-xfetch-chromium-release42
3 files changed, 64 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8c2ed88c062..0b76ba82bbb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chromium-no-extras
pkgdesc = Chromium without hangout services, widevine, pipewire, or chromedriver
- pkgver = 103.0.5060.53
+ pkgver = 103.0.5060.114
pkgrel = 1
url = https://www.chromium.org/Home
arch = x86_64
@@ -14,6 +14,9 @@ pkgbase = chromium-no-extras
makedepends = nodejs
makedepends = java-runtime-headless
makedepends = git
+ makedepends = python-httplib2
+ makedepends = python-pyparsing
+ makedepends = python-six
depends = gtk3
depends = nss
depends = alsa-lib
@@ -47,11 +50,11 @@ pkgbase = chromium-no-extras
optdepends = kdialog: support for native dialogs in Plasma
optdepends = org.freedesktop.secrets: password storage backend on GNOME / Xfce
optdepends = kwallet: support for storing passwords in KWallet on Plasma
- provides = chromium=103.0.5060.53
+ provides = chromium=103.0.5060.114
conflicts = chromium
options = debug
options = !lto
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-103.0.5060.53.tar.xz
+ source = fetch-chromium-release
source = https://github.com/foutrelis/chromium-launcher/archive/v8/chromium-launcher-8.tar.gz
source = https://github.com/stha09/chromium-patches/releases/download/chromium-103-patchset-4/chromium-103-patchset-4.tar.xz
source = enable-GlobalMediaControlsCastStartStop.patch
@@ -59,7 +62,7 @@ pkgbase = chromium-no-extras
source = sql-make-VirtualCursor-standard-layout-type.patch
source = remove-no-opaque-pointers-flag.patch
source = use-oauth2-client-switches-as-default.patch
- sha256sums = 0ecbae14670506da90c8bf744f83f52a64a5fff0765c2e2e066b0e68b805b101
+ sha256sums = d359a415eca7beceddd1b06bb5b5b6a09da9c778ca37cfa4efeaeaa8691bfd52
sha256sums = 213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a
sha256sums = fed11a8987d9f9baa04457fb114f8f7fdb800300a3780927020865bcc43e4f52
sha256sums = 779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6
diff --git a/PKGBUILD b/PKGBUILD
index cc7c6c5ac7d9..654e0e0ad6f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,11 @@
pkgname=chromium-no-extras
_pkgname=chromium
-pkgver=103.0.5060.53
+pkgver=103.0.5060.114
pkgrel=1
_launcher_ver=8
_gcc_patchset=4
+_manual_clone=1
pkgdesc="Chromium without hangout services, widevine, pipewire, or chromedriver"
arch=('x86_64')
url="https://www.chromium.org/Home"
@@ -30,7 +31,7 @@ optdepends=(
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: support for storing passwords in KWallet on Plasma')
options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
-source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.xz
+source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
enable-GlobalMediaControlsCastStartStop.patch
@@ -38,7 +39,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkg
sql-make-VirtualCursor-standard-layout-type.patch
remove-no-opaque-pointers-flag.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('0ecbae14670506da90c8bf744f83f52a64a5fff0765c2e2e066b0e68b805b101'
+sha256sums=('d359a415eca7beceddd1b06bb5b5b6a09da9c778ca37cfa4efeaeaa8691bfd52'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'fed11a8987d9f9baa04457fb114f8f7fdb800300a3780927020865bcc43e4f52'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
@@ -47,6 +48,11 @@ sha256sums=('0ecbae14670506da90c8bf744f83f52a64a5fff0765c2e2e066b0e68b805b101'
'00c16ce83ea4ca924a50fa0cfc2b2a4d744c722f363b065323e6ba0fcbac45a5'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
+if (( _manual_clone )); then
+ source[0]=fetch-chromium-release
+ makedepends+=('python-httplib2' 'python-pyparsing' 'python-six')
+fi
+
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
declare -gA _system_libs=(
@@ -82,7 +88,10 @@ depends+=(${_system_libs[@]})
_google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
+ if (( _manual_clone )); then
+ ./fetch-chromium-release $pkgver
+ fi
+ cd "$_pkgname-$pkgver"
# Allow building against system libraries in official builds
sed -i 's/OFFICIAL_BUILD/GOOGLE_CHROME_BUILD/' \
@@ -142,7 +151,7 @@ prepare() {
build() {
make -C chromium-launcher-$_launcher_ver
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$_pkgname-$pkgver"
export CC=clang
export CXX=clang++
@@ -219,7 +228,7 @@ package() {
install -Dm644 LICENSE \
"$pkgdir/usr/share/licenses/chromium/LICENSE.launcher"
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "../$_pkgname-$pkgver"
install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
install -D out/Release/chromedriver.unstripped "$pkgdir/usr/bin/chromedriver"
diff --git a/fetch-chromium-release b/fetch-chromium-release
new file mode 100755
index 000000000000..f9bf0de2fb87
--- /dev/null
+++ b/fetch-chromium-release
@@ -0,0 +1,42 @@
+#!/bin/bash
+
+set -e
+
+readonly VERSION=$1
+if [[ -z $VERSION ]]; then
+ echo >&2 'No version given as an argument'
+ exit 1
+fi
+
+mkdir chromium-checkout
+cd chromium-checkout
+cat >.gclient <<EOF
+solutions = [
+ {
+ "name": "src",
+ "url": "https://chromium.googlesource.com/chromium/src.git",
+ "managed": False,
+ "custom_deps": {},
+ "custom_vars": {},
+ },
+]
+EOF
+
+git clone --depth=1 https://chromium.googlesource.com/chromium/tools/depot_tools
+export PATH+=":$PWD/depot_tools" DEPOT_TOOLS_UPDATE=0
+export VPYTHON_BYPASS='manually managed python not supported by chrome operations'
+
+git clone -b $VERSION --depth=2 https://chromium.googlesource.com/chromium/src
+gclient sync --no-history --nohooks
+src/build/util/lastchange.py -o src/build/util/LASTCHANGE
+src/build/util/lastchange.py -m SKIA_COMMIT_HASH \
+ -s src/third_party/skia --header src/skia/ext/skia_commit_hash.h
+src/build/util/lastchange.py -m GPU_LISTS_VERSION \
+ --revision-id-only --header src/gpu/config/gpu_lists_version.h
+src/tools/update_pgo_profiles.py --target=linux update \
+ --gs-url-base=chromium-optimization-profiles/pgo_profiles
+download_from_google_storage.py --no_resume --extract --no_auth \
+ --bucket chromium-nodejs -s src/third_party/node/node_modules.tar.gz.sha1
+
+find src/third_party/jdk/{current,extras} -type f -delete
+mv src ../chromium-$VERSION