summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2021-06-17 06:18:26 -0400
committergraysky2021-06-17 06:19:31 -0400
commit2f4650dd57432777d78e0304c7d0c6c1e06c2442 (patch)
treeff31847e6d97d68926c4518a966a66d73dae7346
parent00a3259d05f26a303bae1c451fc2dac1adae619f (diff)
downloadaur-2f4650dd57432777d78e0304c7d0c6c1e06c2442.tar.gz
Remove setuptools build dep (FS#71276)
Also replace sed to use python2 with upstream patch.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
-rw-r--r--make-dom-distiller-protoc-plugin-call-py2.7.patch37
3 files changed, 43 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7006d7a82f0..f66b2470ae91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,6 @@ pkgbase = chromium-no-extras
makedepends = nodejs
makedepends = java-runtime-headless
makedepends = python2
- makedepends = python2-setuptools
depends = gtk3
depends = nss
depends = alsa-lib
@@ -55,6 +54,7 @@ pkgbase = chromium-no-extras
source = https://github.com/stha09/chromium-patches/releases/download/chromium-91-patchset-5/chromium-91-patchset-5.tar.xz
source = fix-crash-in-ThemeService.patch
source = unbundle-use-char16_t-as-UCHAR_TYPE.patch
+ source = make-dom-distiller-protoc-plugin-call-py2.7.patch
source = extend-enable-accelerated-video-decode-flag.patch
source = sql-make-VirtualCursor-standard-layout-type.patch
source = chromium-glibc-2.33.patch
@@ -64,6 +64,7 @@ pkgbase = chromium-no-extras
sha256sums = 171525009003a9ed1182cfcb6f407d7169d9a731a474304e263029376719f55a
sha256sums = 3cfe46e181cb9d337c454b5b5adbf5297052f29cd617cdee4380eeb1943825d8
sha256sums = 59a59a60a08b335fe8647fdf0f9d2288d236ebf2cc9626396d0c4d032fd2b25d
+ sha256sums = 76ceebd14c9a6f1ea6a05b1613e64d1e2aca595e0f0b3e9497e3eeee33ed756c
sha256sums = 66db9132d6f5e06aa26e5de0924f814224a76a9bdf4b61afce161fb1d7643b22
sha256sums = dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150
sha256sums = 2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b
diff --git a/PKGBUILD b/PKGBUILD
index d361bd0f7439..0e878b50b60d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs'
- 'java-runtime-headless' 'python2' 'python2-setuptools')
+ 'java-runtime-headless' 'python2')
optdepends=(
'kdialog: support for native dialogs in Plasma'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
@@ -30,6 +30,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkg
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
fix-crash-in-ThemeService.patch
unbundle-use-char16_t-as-UCHAR_TYPE.patch
+ make-dom-distiller-protoc-plugin-call-py2.7.patch
extend-enable-accelerated-video-decode-flag.patch
sql-make-VirtualCursor-standard-layout-type.patch
chromium-glibc-2.33.patch
@@ -39,6 +40,7 @@ sha256sums=('545e38cd7dce0008c16ab5736ac9764655149e65d353630adac601da040dbebb'
'171525009003a9ed1182cfcb6f407d7169d9a731a474304e263029376719f55a'
'3cfe46e181cb9d337c454b5b5adbf5297052f29cd617cdee4380eeb1943825d8'
'59a59a60a08b335fe8647fdf0f9d2288d236ebf2cc9626396d0c4d032fd2b25d'
+ '76ceebd14c9a6f1ea6a05b1613e64d1e2aca595e0f0b3e9497e3eeee33ed756c'
'66db9132d6f5e06aa26e5de0924f814224a76a9bdf4b61afce161fb1d7643b22'
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
@@ -102,6 +104,7 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../fix-crash-in-ThemeService.patch
patch -Np1 -i ../unbundle-use-char16_t-as-UCHAR_TYPE.patch
+ patch -Np1 -i ../make-dom-distiller-protoc-plugin-call-py2.7.patch
patch -Np1 -i ../extend-enable-accelerated-video-decode-flag.patch
# https://chromium-review.googlesource.com/c/chromium/src/+/2862724
@@ -110,9 +113,6 @@ prepare() {
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-90-ruy-include.patch
- # Force script incompatible with Python 3 to use /usr/bin/python2
- sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
-
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin
ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/
diff --git a/make-dom-distiller-protoc-plugin-call-py2.7.patch b/make-dom-distiller-protoc-plugin-call-py2.7.patch
new file mode 100644
index 000000000000..2a6100f92087
--- /dev/null
+++ b/make-dom-distiller-protoc-plugin-call-py2.7.patch
@@ -0,0 +1,37 @@
+From 359b22d3f775afa33cca9e4f8fb57eadd0ec4118 Mon Sep 17 00:00:00 2001
+From: Nico Weber <thakis@chromium.org>
+Date: Fri, 23 Apr 2021 16:22:19 +0000
+Subject: [PATCH] Make dom distiller protoc plugin explicitly call py2.7
+
+With this, chrome builds with when `/usr/bin/env python` is py3.
+
+Bug: 1202134
+Change-Id: Ibbd97a1311ccb34d46f266912c871fd0522f9535
+Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2848445
+Commit-Queue: Nico Weber <thakis@chromium.org>
+Commit-Queue: Yaron Friedman <yfriedman@chromium.org>
+Commit-Queue: Dirk Pranke <dpranke@google.com>
+Auto-Submit: Nico Weber <thakis@chromium.org>
+Reviewed-by: Yaron Friedman <yfriedman@chromium.org>
+Reviewed-by: Dirk Pranke <dpranke@google.com>
+Cr-Commit-Position: refs/heads/master@{#875702}
+---
+ .../dom_distiller_js/protoc_plugins/json_values_converter.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/third_party/dom_distiller_js/protoc_plugins/json_values_converter.py b/third_party/dom_distiller_js/protoc_plugins/json_values_converter.py
+index e86a88c759fcb..cae1a998c4650 100755
+--- a/third_party/dom_distiller_js/protoc_plugins/json_values_converter.py
++++ b/third_party/dom_distiller_js/protoc_plugins/json_values_converter.py
+@@ -1,7 +1,10 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2.7
+ # Copyright 2016 The Chromium Authors. All rights reserved.
+ # Use of this source code is governed by a BSD-style license that can be
+ # found in the LICENSE file.
++#
++# TODO(crbug.com/1202134): Switch run line back to just "python"
++# once things are py3-compatible.
+
+ """protoc plugin to create C++ reader/writer for JSON-encoded protobufs
+