summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2020-05-07 08:47:13 -0400
committergraysky2020-05-07 08:47:13 -0400
commit5638fd609b803f6a89c02da009a42837661feeee (patch)
tree6401995135bcbeb7e22063823bece0fbf2139f14
parente5635b6055fdf2f31099c7e4d515e0e3caea111f (diff)
downloadaur-5638fd609b803f6a89c02da009a42837661feeee.tar.gz
Update to 81.0.4044.138-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--clean-up-a-call-to-set_utf8.patch34
3 files changed, 43 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9933883303fb..280d4dbf347a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chromium-no-extras
pkgdesc = Chromium without hangout services, widevine, pipewire, or chromedriver
pkgver = 81.0.4044.138
- pkgrel = 1
+ pkgrel = 2
url = https://www.chromium.org/Home
install = chromium.install
arch = x86_64
@@ -58,12 +58,14 @@ pkgbase = chromium-no-extras
source = chromium-launcher-6.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v6.tar.gz
source = rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
source = rebuild-Linux-frame-button-cache-when-activation.patch
+ source = clean-up-a-call-to-set_utf8.patch
source = icu67.patch
source = chromium-skia-harmony.patch
sha256sums = f478f28b8111cb70231df4c36e754d812ad7a94b7c844e9d0515345a71fd77a6
sha256sums = 04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1
sha256sums = ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db
sha256sums = 46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014
+ sha256sums = 58c41713eb6fb33b6eef120f4324fa1fb8123b1fbc4ecbe5662f1f9779b9b6af
sha256sums = 5315977307e69d20b3e856d3f8724835b08e02085a4444a5c5cefea83fd7d006
sha256sums = 771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1
diff --git a/PKGBUILD b/PKGBUILD
index 7ab744a7dc08..0b136ae480ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=chromium-no-extras
pkgver=81.0.4044.138
-pkgrel=1
+pkgrel=2
_pkgname=chromium
_launcher_ver=6
pkgdesc="Chromium without hangout services, widevine, pipewire, or chromedriver"
@@ -29,12 +29,14 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkg
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
rebuild-Linux-frame-button-cache-when-activation.patch
+ clean-up-a-call-to-set_utf8.patch
icu67.patch
chromium-skia-harmony.patch)
sha256sums=('f478f28b8111cb70231df4c36e754d812ad7a94b7c844e9d0515345a71fd77a6'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db'
'46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014'
+ '58c41713eb6fb33b6eef120f4324fa1fb8123b1fbc4ecbe5662f1f9779b9b6af'
'5315977307e69d20b3e856d3f8724835b08e02085a4444a5c5cefea83fd7d006'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
@@ -89,6 +91,9 @@ prepare() {
patch -Np1 -i ../rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
patch -Np1 -i ../rebuild-Linux-frame-button-cache-when-activation.patch
+ # https://chromium-review.googlesource.com/c/chromium/src/+/2145261
+ patch -Np1 -i ../clean-up-a-call-to-set_utf8.patch
+
# https://crbug.com/v8/10393
patch -Np3 -d v8 <../icu67.patch
diff --git a/clean-up-a-call-to-set_utf8.patch b/clean-up-a-call-to-set_utf8.patch
new file mode 100644
index 000000000000..01384c039417
--- /dev/null
+++ b/clean-up-a-call-to-set_utf8.patch
@@ -0,0 +1,34 @@
+From ede390a0b18e4565abf8ac1e1ff717e1d43fc320 Mon Sep 17 00:00:00 2001
+From: Paul Wankadia <junyer@chromium.org>
+Date: Tue, 14 Apr 2020 16:54:51 +0000
+Subject: [PATCH] Clean up a call to set_utf8().
+
+This is part of an effort to rewrite calls to utf8() and set_utf8()
+(in RE2::Options) as calls to encoding() and set_encoding(),
+respectively. utf8() and set_utf8() have been marked as the "legacy"
+interface since 2008, so it is long past time that we get rid of them.
+
+R=parastoog@google.com
+
+Change-Id: I62c48cd575a55b519d5264ed857f927c163068b2
+Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2145261
+Reviewed-by: Parastoo Geranmayeh <parastoog@google.com>
+Commit-Queue: Paul Wankadia <junyer@chromium.org>
+Cr-Commit-Position: refs/heads/master@{#758886}
+---
+ components/autofill/core/browser/address_rewriter.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/components/autofill/core/browser/address_rewriter.cc b/components/autofill/core/browser/address_rewriter.cc
+index 1b85a50974c..030a5aba146 100644
+--- a/components/autofill/core/browser/address_rewriter.cc
++++ b/components/autofill/core/browser/address_rewriter.cc
+@@ -57,7 +57,7 @@ void CompileRulesFromData(const std::string& data_string,
+ CompiledRuleVector* compiled_rules) {
+ base::StringPiece data = data_string;
+ re2::RE2::Options options;
+- options.set_utf8(true);
++ options.set_encoding(RE2::Options::EncodingUTF8);
+ options.set_word_boundary(true);
+
+ size_t token_end = 0;