summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2023-12-18 06:02:06 -0500
committergraysky2023-12-18 06:02:06 -0500
commit56fccb0c114eaf914f7821b11ca8c02cf3ca0515 (patch)
treed3b8cc49693c79cdf837e76c17ed3314b17e6240
parent30a8df63dc4538ba96d19595e4b40b5c88b9c742 (diff)
downloadaur-56fccb0c114eaf914f7821b11ca8c02cf3ca0515.tar.gz
Update to 120.0.6099.109-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--icu-74.patch21
3 files changed, 34 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9e72c7cf091..755947194d69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chromium-no-extras
pkgdesc = Chromium without hangout services, widevine, or chromedriver
- pkgver = 120.0.6099.71
+ pkgver = 120.0.6099.109
pkgrel = 1
url = https://www.chromium.org/Home
arch = x86_64
@@ -51,19 +51,21 @@ pkgbase = chromium-no-extras
optdepends = gtk4: for --gtk-version=4 (GTK4 IME might work better on Wayland)
optdepends = org.freedesktop.secrets: password storage backend on GNOME / Xfce
optdepends = kwallet: support for storing passwords in KWallet on Plasma
- provides = chromium=120.0.6099.71
+ provides = chromium=120.0.6099.109
conflicts = chromium
options = !lto
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-120.0.6099.71.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-120.0.6099.109.tar.xz
source = https://github.com/foutrelis/chromium-launcher/archive/v8/chromium-launcher-8.tar.gz
source = https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/120/chromium-patches-120.tar.bz2
source = libxml2-2.12.patch
+ source = icu-74.patch
source = drop-flags-unsupported-by-clang16.patch
source = use-oauth2-client-switches-as-default.patch
- sha256sums = 604755e5838ef0fd1bff4d6c5023cdda2d42ce982dda2c4be44cce487d3dd8d8
+ sha256sums = 87c00c525ee07c2233b78dbece1496b697f686244a67fac2c71e4a30bd96849b
sha256sums = 213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a
sha256sums = ffee1082fbe3d0c9e79dacb8405d5a0e1aa94d6745089a30b093f647354894d2
sha256sums = 1808df5ba4d1e2f9efa07ac6b510bec866fa6d60e44505d82aea3f6072105a71
+ sha256sums = ff9ebd86b0010e1c604d47303ab209b1d76c3e888c423166779cefbc22de297f
sha256sums = 8d1cdf3ddd8ff98f302c90c13953f39cd804b3479b13b69b8ef138ac57c83556
sha256sums = e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711
diff --git a/PKGBUILD b/PKGBUILD
index bf6e371ce20f..e925f4c9b3ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=chromium
pkgname=chromium-no-extras
-pkgver=120.0.6099.71
+pkgver=120.0.6099.109
pkgrel=1
_launcher_ver=8
_manual_clone=0
@@ -32,12 +32,14 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/${pkgver%%.*}/chromium-patches-${pkgver%%.*}.tar.bz2
libxml2-2.12.patch
+ icu-74.patch
drop-flags-unsupported-by-clang16.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('604755e5838ef0fd1bff4d6c5023cdda2d42ce982dda2c4be44cce487d3dd8d8'
+sha256sums=('87c00c525ee07c2233b78dbece1496b697f686244a67fac2c71e4a30bd96849b'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'ffee1082fbe3d0c9e79dacb8405d5a0e1aa94d6745089a30b093f647354894d2'
'1808df5ba4d1e2f9efa07ac6b510bec866fa6d60e44505d82aea3f6072105a71'
+ 'ff9ebd86b0010e1c604d47303ab209b1d76c3e888c423166779cefbc22de297f'
'8d1cdf3ddd8ff98f302c90c13953f39cd804b3479b13b69b8ef138ac57c83556'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
@@ -119,6 +121,9 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../libxml2-2.12.patch
+ # Fix build with ICU 74
+ patch -Np1 -i ../icu-74.patch
+
# Drop compiler flags that need newer clang
patch -Np1 -i ../drop-flags-unsupported-by-clang16.patch
diff --git a/icu-74.patch b/icu-74.patch
new file mode 100644
index 000000000000..efb8fb161c61
--- /dev/null
+++ b/icu-74.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/917645
+(copied patch from qtwebengine:6 - https://bugs.gentoo.org/917633)
+
+Quick fix for a static_assert failure with icu74. Still waiting
+for a proper upstream fix and unknown if entirely right, but is
+an extension of [1] (is now 48 rather than 43).
+
+[1] https://crrev.com/e60b571faa3f14dd9119a6792dccf12f8bf80192
+--- a/third_party/blink/renderer/platform/text/text_break_iterator.cc
++++ b/third_party/blink/renderer/platform/text/text_break_iterator.cc
+@@ -161,7 +161,9 @@ static const unsigned char kAsciiLineBreakTable[][(kAsciiLineBreakTableLastChar
+ };
+ // clang-format on
+
+-#if U_ICU_VERSION_MAJOR_NUM >= 58
++#if U_ICU_VERSION_MAJOR_NUM >= 74
++#define BA_LB_COUNT (U_LB_COUNT - 8)
++#elif U_ICU_VERSION_MAJOR_NUM >= 58
+ #define BA_LB_COUNT (U_LB_COUNT - 3)
+ #else
+ #define BA_LB_COUNT U_LB_COUNT