summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2021-03-31 05:08:46 -0400
committergraysky2021-03-31 05:08:46 -0400
commit9dc56e8444ebf3818a8ddda23118f9030490a1dd (patch)
tree1363e33554887ad1fc79257f30b94919563b9a48
parentc37a74dc13e8f7b91b6898d912349930e0b3789e (diff)
downloadaur-9dc56e8444ebf3818a8ddda23118f9030490a1dd.tar.gz
Update to 89.0.4389.114-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--chromium-fix-libva-redef.patch86
3 files changed, 99 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51e2ffff6496..7730f6c6e166 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chromium-no-extras
pkgdesc = Chromium without hangout services, widevine, pipewire, or chromedriver
- pkgver = 89.0.4389.90
+ pkgver = 89.0.4389.114
pkgrel = 1
url = https://www.chromium.org/Home
arch = x86_64
@@ -48,21 +48,21 @@ pkgbase = chromium-no-extras
optdepends = kdialog: needed for file dialogs in KDE
optdepends = org.freedesktop.secrets: password storage backend on GNOME / Xfce
optdepends = kwallet: for storing passwords in KWallet on KDE desktops
- provides = chromium=89.0.4389.90
+ provides = chromium=89.0.4389.114
conflicts = chromium
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-89.0.4389.90.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-89.0.4389.114.tar.xz
source = https://github.com/foutrelis/chromium-launcher/archive/v7/chromium-launcher-7.tar.gz
source = https://github.com/stha09/chromium-patches/releases/download/chromium-89-patchset-7/chromium-89-patchset-7.tar.xz
source = add-dependency-on-opus-in-webcodecs.patch
- source = x11-ozone-fix-two-edge-cases.patch
source = chromium-glibc-2.33.patch
+ source = chromium-fix-libva-redef.patch
source = use-oauth2-client-switches-as-default.patch
- sha256sums = 11c6089c5fdd921216aa4eb34b52818a9b091cad655a24aed0982d29e65b279a
+ sha256sums = f2f0abe9697a220a8545df74d832c6c8d85a4fb11845e7e398752d746e72ed00
sha256sums = 86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f
sha256sums = f8b1558f6c87b33423da854d42f0f69d47885a96d6bf6ce7f26373e93d47442f
sha256sums = b86b11de8db438c47f0a84c7956740f648d21035f4ee46bfbd50c3348d369121
- sha256sums = 9e4743bdeaf5b668659ad53400e3977006916aac3a7ba045bbc750b7b4cbf274
sha256sums = 2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b
+ sha256sums = de9eb3612d44616a500c2eccdffac814eb90ad9a868cc1030d17fc6783d544e2
sha256sums = e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711
pkgname = chromium-no-extras
diff --git a/PKGBUILD b/PKGBUILD
index 2160297dec11..98e49b736eae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-no-extras
-pkgver=89.0.4389.90
+pkgver=89.0.4389.114
pkgrel=1
_pkgname=chromium
_launcher_ver=7
@@ -29,15 +29,15 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkg
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
add-dependency-on-opus-in-webcodecs.patch
- x11-ozone-fix-two-edge-cases.patch
chromium-glibc-2.33.patch
+ chromium-fix-libva-redef.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('11c6089c5fdd921216aa4eb34b52818a9b091cad655a24aed0982d29e65b279a'
+sha256sums=('f2f0abe9697a220a8545df74d832c6c8d85a4fb11845e7e398752d746e72ed00'
'86859c11cfc8ba106a3826479c0bc759324a62150b271dd35d1a0f96e890f52f'
'f8b1558f6c87b33423da854d42f0f69d47885a96d6bf6ce7f26373e93d47442f'
'b86b11de8db438c47f0a84c7956740f648d21035f4ee46bfbd50c3348d369121'
- '9e4743bdeaf5b668659ad53400e3977006916aac3a7ba045bbc750b7b4cbf274'
'2fccecdcd4509d4c36af873988ca9dbcba7fdb95122894a9fdf502c33a1d7a4b'
+ 'de9eb3612d44616a500c2eccdffac814eb90ad9a868cc1030d17fc6783d544e2'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
@@ -95,9 +95,11 @@ prepare() {
# https://crbug.com/1164975
patch -Np1 -i ../chromium-glibc-2.33.patch
+ # https://github.com/kiss-community/repo-community/issues/246
+ patch -Np1 -i ../chromium-fix-libva-redef.patch
+
# Upstream fixes
patch -Np1 -i ../add-dependency-on-opus-in-webcodecs.patch
- patch -Np1 -i ../x11-ozone-fix-two-edge-cases.patch
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-89-quiche-dcheck.patch
diff --git a/chromium-fix-libva-redef.patch b/chromium-fix-libva-redef.patch
new file mode 100644
index 000000000000..693b493bb6d8
--- /dev/null
+++ b/chromium-fix-libva-redef.patch
@@ -0,0 +1,86 @@
+--- a/third_party/libva_protected_content/va_protected_content.h
++++ b/third_party/libva_protected_content/va_protected_content.h
+@@ -132,19 +132,6 @@
+ #define VA_PC_SAMPLE_TYPE_FULLSAMPLE 0x00000001
+ #define VA_PC_SAMPLE_TYPE_SUBSAMPLE 0x00000002
+
+-/** \brief TeeExec Function Codes. */
+-typedef enum _VA_TEE_EXEC_FUNCTION_ID {
+- VA_TEE_EXEC_TEE_FUNCID_PASS_THROUGH_NONE = 0x0,
+-
+- // 0x40000000~0x400000FFF reserved for TEE Exec GPU function
+- VA_TEE_EXEC_GPU_FUNCID_ENCRYPTION_BLT = 0x40000000,
+- VA_TEE_EXEC_GPU_FUNCID_DECRYPTION_BLT = 0x40000001,
+-
+- // 0x40001000~0x400001FFF reserved for TEE Exec TEE function
+- VA_TEE_EXEC_TEE_FUNCID_PASS_THROUGH = 0x40001000,
+-
+-} VA_TEE_EXEC_FUNCTION_ID;
+-
+ /** \brief values for the encryption return status. */
+ typedef enum {
+ /** \brief Indicate encryption operation is successful.*/
+@@ -159,63 +146,6 @@
+ VA_ENCRYPTION_STATUS_UNSUPPORT
+ } VAEncryptionStatus;
+
+-/** \brief structure for encrypted segment info. */
+-typedef struct _VAEncryptionSegmentInfo {
+- /** \brief The offset relative to the start of the bitstream input in
+- * bytes of the start of the segment*/
+- uint32_t segment_start_offset;
+- /** \brief The length of the segments in bytes*/
+- uint32_t segment_length;
+- /** \brief The length in bytes of the remainder of an incomplete block
+- * from a previous segment*/
+- uint32_t partial_aes_block_size;
+- /** \brief The length in bytes of the initial clear data */
+- uint32_t init_byte_length;
+- /** \brief This will be AES 128 counter for secure decode and secure
+- * encode when numSegments equals 1 */
+- uint8_t aes_cbc_iv_or_ctr[16];
+- /** \brief Reserved bytes for future use, must be zero */
+- uint32_t va_reserved[VA_PADDING_MEDIUM];
+-} VAEncryptionSegmentInfo;
+-
+-/** \brief encryption parameters, corresponding to
+- * #VAEncryptionParameterBufferType*/
+-typedef struct _VAEncryptionParameters {
+- /** \brief Encryption type, attribute values. */
+- uint32_t encryption_type;
+- /** \brief The number of sengments */
+- uint32_t num_segments;
+- /** \brief Pointer of segments */
+- VAEncryptionSegmentInfo* segment_info;
+- /** \brief The status report index for CENC workload.
+- * The value is to indicate CENC workload and needs to be
+- * different for each CENC workload */
+- uint32_t status_report_index;
+- /** \brief CENC counter length */
+- uint32_t size_of_length;
+- /** \brief Wrapped decrypt blob (Snd)kb */
+- uint8_t wrapped_decrypt_blob[16];
+- /** \brief Wrapped Key blob info (Sne)kb */
+- uint8_t wrapped_encrypt_blob[16];
+- /** \brief Indicates the number of 16-byte BLOCKS that are encrypted in any
+- * given encrypted region of segments.
+- * If this value is zero:
+- * 1. All bytes in encrypted region of segments are encrypted, i.e. the
+- * CENC or CBC1 scheme is being used
+- * 2. blocks_stripe_clear must also be zero.
+- * If this value is non-zero, blocks_stripe_clear must also be non-zero. */
+- uint32_t blocks_stripe_encrypted;
+- /** \brief Indicates the number of 16-byte BLOCKS that are clear in any given
+- * encrypted region of segments, as defined by the CENS and CBCS schemes in
+- * the common encryption spec.
+- * If this value is zero, all bytes in encrypted region of segments are
+- * encrypted, i.e. the CENC or CBC1 scheme is being used.
+- */
+- uint32_t blocks_stripe_clear;
+- /** \brief Reserved bytes for future use, must be zero */
+- uint32_t va_reserved[VA_PADDING_MEDIUM];
+-} VAEncryptionParameters;
+-
+ /** \brief structure for VA_TEE_EXEC_GPU_FUNCID_ENCRYPTION_BLT */
+ typedef struct _VA_PROTECTED_BLT_PARAMS {
+ uint8_t* src_resource; // The source resource which contains the clear data.