summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2022-02-14 16:47:53 +0100
committerChristoph Haag2022-02-14 16:49:22 +0100
commitcc2cba7aab0f6547b0b666f491437936bb91c229 (patch)
tree97be9d3f6dc02478d2d0f5034b5ec291b1823679
downloadaur-cc2cba7aab0f6547b0b666f491437936bb91c229.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebd12ab23c2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = chromium-post-build-ninja-summary-git
+ pkgdesc = Summarize the last ninja build, with timings
+ pkgver = 20220214g54e30e704363e80a20bff934c6bf1f9d1f706d1c
+ pkgrel = 1
+ url = https://chromium.googlesource.com/chromium/tools/depot_tools.git/+/refs/heads/main/post_build_ninja_summary.py
+ arch = any
+ license = BSD
+ makedepends = wget
+ makedepends = coreutils
+ depends = python
+
+pkgname = chromium-post-build-ninja-summary-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..111530d61100
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Christoph Haag <christoph.haag@collabora.com>
+pkgname=chromium-post-build-ninja-summary-git
+pkgver=20220214g54e30e704363e80a20bff934c6bf1f9d1f706d1c
+pkgrel=1
+pkgdesc="Summarize the last ninja build, with timings"
+arch=('any')
+url="https://chromium.googlesource.com/chromium/tools/depot_tools.git/+/refs/heads/main/post_build_ninja_summary.py"
+license=('BSD')
+depends=("python")
+makedepends=("wget" "coreutils")
+source=()
+
+pkgver() {
+ rm -f main
+ wget 'https://chromium.googlesource.com/chromium/tools/depot_tools.git/+/refs/heads/main'
+ echo "$(date +%Y%m%d)g$(grep -oP '(?<=commit</th><td>)[0-9a-z]*' main)"
+}
+
+build() {
+ wget 'https://chromium.googlesource.com/chromium/tools/depot_tools.git/+/refs/heads/main/post_build_ninja_summary.py?format=TEXT' -O - | base64 -d > post_build_ninja_summary.py
+}
+
+package() {
+ install -d "$pkgdir"/usr/bin
+ install -m755 post_build_ninja_summary.py "$pkgdir"//usr/bin
+}