summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-11-20 13:30:24 +0000
committerHans-Nikolai Viessmann2018-11-20 13:30:24 +0000
commit115835e626d6cfb0ea111748423da2cd21755c49 (patch)
treea1e9da86b4421d524082ab5c9e5ce6e60b1e2537
downloadaur-115835e626d6cfb0ea111748423da2cd21755c49.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD22
-rw-r--r--chromium-ublock-origin.install8
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7503eeaaf8c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = chromium-ublock-origin
+ pkgdesc = An efficient blocker for Chromium
+ pkgver = 1.17.2
+ pkgrel = 1
+ url = https://github.com/gorhill/uBlock
+ install = chromium-ublock-origin.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = zip
+ optdepends = chromium
+ optdepends = google-chrome
+ source = https://github.com/gorhill/uBlock/releases/download/1.17.2/uBlock0.chromium.zip
+ md5sums = 15a59f69a5aa619e9fc558b62c4ca6db
+
+pkgname = chromium-ublock-origin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dea762f6baf0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+# build/package dirs
+pkg
+src
+
+# downloaded package
+uBlock0.chromium.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..547deddd48f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
+
+# check for new releases at:
+# https://github.com/gorhill/uBlock/releases
+
+pkgname=chromium-ublock-origin
+pkgver=1.17.2
+pkgrel=1
+pkgdesc="An efficient blocker for Chromium"
+arch=('any')
+url="https://github.com/gorhill/uBlock"
+license=('GPL3')
+makedepends=('git' 'zip')
+optdepends=('chromium' 'google-chrome')
+install="${pkgname}.install"
+source=("https://github.com/gorhill/uBlock/releases/download/${pkgver}/uBlock0.chromium.zip")
+md5sums=('15a59f69a5aa619e9fc558b62c4ca6db')
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -dr --no-preserve=ownership "${srcdir}/uBlock0.chromium"/* "${pkgdir}/usr/share/${pkgname}/"
+}
diff --git a/chromium-ublock-origin.install b/chromium-ublock-origin.install
new file mode 100644
index 000000000000..f68bd1f94bfd
--- /dev/null
+++ b/chromium-ublock-origin.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Instructions on how to add uBlock Origin to you Chrome/Chromium browser can"
+ echo "be found at https://github.com/gorhill/uBlock/blob/master/dist/README.md."
+}
+
+post_upgrade() {
+ post_install
+}