summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamantha McVey2016-09-18 22:06:49 -0700
committerSamantha McVey2016-09-18 22:06:49 -0700
commit3436ff67064c2a306f1d813caf1dbc58d7378fdd (patch)
treeb13be89e8ba2e980a0392cd6f4b95905d45cf46e
parent282f90f0d70e644b4657e841e57413bc0742c814 (diff)
downloadaur-3436ff67064c2a306f1d813caf1dbc58d7378fdd.tar.gz
fix chromium-vaapi-other patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--chromium_vaapi-other.patch29
3 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f49731b998ec..2aef9f6d185a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -61,7 +61,7 @@ pkgbase = chromium-vaapi
sha256sums = 3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227
sha256sums = 4700a2d75c5cec59ff4d78c284d20df591c07321565bb25e4bbbd5c671a5d22e
sha256sums = c479910bc405666f8c8c7760e983abc20ab65764ca1d889040bcba34e8b5b4b9
- sha256sums = 1dae940e726d91edd1e54e3afa25932fa4abadca7632652b4a9802df35d124a2
+ sha256sums = b0336dc8542335c900f745571463800e7d97b711a9e8068109f65dafe82f36e7
pkgname = chromium-vaapi
diff --git a/PKGBUILD b/PKGBUILD
index abfa9bb6ac08..6a2e864a0331 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,7 @@ sha256sums=('7a87629504346f64122ca7754574d187a4c1bf5736dea672ff3e247a0af16062'
'3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
'4700a2d75c5cec59ff4d78c284d20df591c07321565bb25e4bbbd5c671a5d22e'
'c479910bc405666f8c8c7760e983abc20ab65764ca1d889040bcba34e8b5b4b9'
- '1dae940e726d91edd1e54e3afa25932fa4abadca7632652b4a9802df35d124a2')
+ 'b0336dc8542335c900f745571463800e7d97b711a9e8068109f65dafe82f36e7')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
diff --git a/chromium_vaapi-other.patch b/chromium_vaapi-other.patch
index eaaa2252d591..4987c5adf3ea 100644
--- a/chromium_vaapi-other.patch
+++ b/chromium_vaapi-other.patch
@@ -3,7 +3,7 @@ Attempt to load these VA-API drivers before sandbox.
diff -aur chromium-53.0.2785.101/content/common/sandbox_linux/bpf_gpu_policy_linux.cc chromium-53.0.2785.101.new/content/common/sandbox_linux/bpf_gpu_policy_linux.cc
--- chromium-53.0.2785.101/content/common/sandbox_linux/bpf_gpu_policy_linux.cc 2016-09-07 18:02:39.000000000 -0700
-+++ chromium-53.0.2785.101.new/content/common/sandbox_linux/bpf_gpu_policy_linux.cc 2016-09-16 11:46:20.339655906 -0700
++++ chromium-53.0.2785.101.new/content/common/sandbox_linux/bpf_gpu_policy_linux.cc 2016-09-17 20:29:48.271901245 -0700
@@ -96,7 +96,7 @@
bool IsAcceleratedVaapiVideoEncodeEnabled() {
@@ -13,7 +13,7 @@ diff -aur chromium-53.0.2785.101/content/common/sandbox_linux/bpf_gpu_policy_lin
const base::CommandLine& command_line =
*base::CommandLine::ForCurrentProcess();
accelerated_encode_enabled =
-@@ -302,19 +302,49 @@
+@@ -302,19 +302,50 @@
// inside the sandbox, so preload them now.
if (IsAcceleratedVaapiVideoEncodeEnabled() ||
IsAcceleratedVideoDecodeEnabled()) {
@@ -24,17 +24,18 @@ diff -aur chromium-53.0.2785.101/content/common/sandbox_linux/bpf_gpu_policy_lin
+ const char* NVIDIA_Drv_Video_Path = NULL;
+ const char* LIB_VA_Path = NULL;
+ const char* LIB_VA_X11_Path = NULL;
-+ const char* R600_Drv_VideoPath = NULL;
-+ const char* RADEONSI_Drv_VideoPath = NULL;
-+ const char* VDPAU_Drv_VideoPath = NULL;
++ const char* R600_Drv_Video_Path = NULL;
++ const char* RADEONSI_Drv_Video_Path = NULL;
++ const char* VDPAU_Drv_Video_Path = NULL;
++ const char* NOUVEAU_Drv_VideoPath = NULL;
+
+ if (IsArchitectureX86_64() || IsArchitectureI386() ) {
+ I965_Drv_Video_Path = "/usr/lib/dri/i965_drv_video.so";
+ I965_Hybrid_Drv_Video_Path = "/usr/lib/dri/hybrid_drv_video.so";
+ NVIDIA_Drv_Video_Path = "/usr/lib/dri/nvidia_drv_video.so";
-+ R600_Drv_VideoPath = "/usr/lib/dri/r600_drv_video.so";
-+ VDPAU_Drv_VideoPath = "/usr/lib/dri/vdpau_drv_video.so";
-+ RADEONSI_Drv_VideoPath = "/usr/lib/dri/radeonsi_drv_video.so";
++ R600_Drv_Video_Path = "/usr/lib/dri/r600_drv_video.so";
++ VDPAU_Drv_Video_Path = "/usr/lib/dri/vdpau_drv_video.so";
++ RADEONSI_Drv_Video_Path = "/usr/lib/dri/radeonsi_drv_video.so";
+ NOUVEAU_Drv_VideoPath = "/usr/lib/dri/nouveau_drv_video.so";
- if (IsArchitectureX86_64()) {
@@ -51,17 +52,17 @@ diff -aur chromium-53.0.2785.101/content/common/sandbox_linux/bpf_gpu_policy_lin
+ if ( access(I965_Hybrid_Drv_Video_Path , X_OK|R_OK ) != -1 ) {
+ dlopen(I965_Hybrid_Drv_Video_Path, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);
+ }
-+ if ( access(VDPAU_Drv_VideoPath , X_OK|R_OK ) != -1 ) {
-+ dlopen(VDPAU_Drv_VideoPath, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);
++ if ( access(VDPAU_Drv_Video_Path , X_OK|R_OK ) != -1 ) {
++ dlopen(VDPAU_Drv_Video_Path, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);
+ }
+ if ( access(NVIDIA_Drv_Video_Path , X_OK|R_OK ) != -1 ) {
+ dlopen(NVIDIA_Drv_Video_Path, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);
+ }
-+ if ( access(R600_Drv_VideoPath , X_OK|R_OK ) != -1 ) {
-+ dlopen(R600_Drv_VideoPath, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);
++ if ( access(R600_Drv_Video_Path , X_OK|R_OK ) != -1 ) {
++ dlopen(R600_Drv_Video_Path, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);
+ }
-+ if ( access(RADEONSI_Drv_VideoPath , X_OK|R_OK ) != -1 ) {
-+ dlopen(RADEONSI_Drv_VideoPath, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);
++ if ( access(RADEONSI_Drv_Video_Path , X_OK|R_OK ) != -1 ) {
++ dlopen(RADEONSI_Drv_Video_Path, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);
+ }
+ if ( access(NOUVEAU_Drv_VideoPath , X_OK|R_OK ) != -1 ) {
+ dlopen(NOUVEAU_Drv_VideoPath, RTLD_NOW|RTLD_GLOBAL|RTLD_NODELETE);