summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamantha McVey2016-07-14 02:45:15 -0700
committerSamantha McVey2016-07-14 02:45:15 -0700
commitf012445d8c075386c30380561da632d6a15d660f (patch)
treec2922a262207978a67a99e2a47070f5a877cc6fd
parent0e99715fd520703599260f4037f520a6d398bf53 (diff)
downloadaur-f012445d8c075386c30380561da632d6a15d660f.tar.gz
Add optdepends for VA-API and VDPAU
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 487f9add9deb..d08610c5fc35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -38,8 +38,10 @@ pkgbase = chromium-vaapi
depends = perl-file-basedir
depends = desktop-file-utils
depends = hicolor-icon-theme
- optdepends = kdebase-kdialog: needed for file dialogs in KDE
- optdepends = gnome-keyring: for storing passwords in GNOME keyring
+ optdepends = libva-intel-driver: Needed to support VA-API for Intel graphics cards
+ optdepends = mesa-vdpau: needed for ATI graphics cards to enable VDPAU
+ optdepends = nvidia-utils: needed for NVIDIA graphics cards to enable VDPAU
+ optdepends = libva-vdpau: needed by NVIDIA/ATI graphics cards to expose VA-API using a VDPAU backend
optdepends = kwallet: for storing passwords in KWallet
provides = chromium
conflicts = chromium
diff --git a/PKGBUILD b/PKGBUILD
index e2adaac643f6..91ba3a608576 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,8 +26,10 @@ provides=('chromium')
conflicts=('chromium')
makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja')
makedepends_x86_64=('lib32-gcc-libs' 'lib32-zlib')
-optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
- 'gnome-keyring: for storing passwords in GNOME keyring'
+optdepends=('libva-intel-driver: Needed to support VA-API for Intel graphics cards'
+ 'mesa-vdpau: needed for ATI graphics cards to enable VDPAU'
+ 'nvidia-utils: needed for NVIDIA graphics cards to enable VDPAU'
+ 'libva-vdpau: needed by NVIDIA/ATI graphics cards to expose VA-API using a VDPAU backend'
'kwallet: for storing passwords in KWallet')
options=('!strip')
install=chromium.install