summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKJ Liew2020-10-22 08:50:39 -0700
committerKJ Liew2020-10-22 08:50:39 -0700
commitf4976dc8b3a702eca6f86541ec13dcf4d1f41922 (patch)
tree1addf11a4abd76440ebeb2a2e37f68b97187550c
parent849b8c2c1cf092c150df47bd87b5aae6ce141265 (diff)
downloadaur-f4976dc8b3a702eca6f86541ec13dcf4d1f41922.tar.gz
chromium-vaapi 86.0.4240.111-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--xproto-fix-underflow-in-Fp1616ToDouble.patch37
3 files changed, 44 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbbb3867e4de..3727d141a582 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chromium-vaapi
pkgdesc = Chromium with VA-API support to enable hardware acceleration
pkgver = 86.0.4240.111
- pkgrel = 1
+ pkgrel = 2
url = https://www.chromium.org/Home
install = chromium.install
arch = x86_64
@@ -65,6 +65,7 @@ pkgbase = chromium-vaapi
source = only-fall-back-to-the-i965-driver-if-we-re-on-iHD.patch
source = remove-dead-reloc-in-nonalloc-LD-flags.patch
source = check-for-enable-accelerated-video-decode-on-Linux.patch
+ source = xproto-fix-underflow-in-Fp1616ToDouble.patch
source = wayland-egl.patch
source = chromium-skia-harmony.patch
sha256sums = f27bdb02ebf3c48abe054c73f1ae57e22a22535ea34f5edf8693ab8432a7c717
@@ -74,6 +75,7 @@ pkgbase = chromium-vaapi
sha256sums = 7514c6c81a64a5457b66494a366fbb39005563eecc48d1a39033dd06aec4e300
sha256sums = 7cace84d7494190e7882d3e637820646ec8d64808f0a2128c515bd44991a3790
sha256sums = 03d03a39b2afa40083eb8ccb9616a51619f71da92348effc8ee289cbda10128b
+ sha256sums = 1ec617b362bf97cce4254debd04d8396f17dec0ae1071b52ec8c1c3d86dbd322
sha256sums = bf86923eaee5529ab9fb6148bd6c33a73c8746ab1b4ade0cd3b761109bc55826
sha256sums = 771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1
diff --git a/PKGBUILD b/PKGBUILD
index 713d541565b4..e5b52fc6cac1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=chromium-vaapi
pkgver=86.0.4240.111
-pkgrel=1
+pkgrel=2
_launcher_ver=6
_gcc_patchset=6
pkgdesc="Chromium with VA-API support to enable hardware acceleration"
@@ -40,6 +40,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
only-fall-back-to-the-i965-driver-if-we-re-on-iHD.patch
remove-dead-reloc-in-nonalloc-LD-flags.patch
check-for-enable-accelerated-video-decode-on-Linux.patch
+ xproto-fix-underflow-in-Fp1616ToDouble.patch
wayland-egl.patch
chromium-skia-harmony.patch)
sha256sums=('f27bdb02ebf3c48abe054c73f1ae57e22a22535ea34f5edf8693ab8432a7c717'
@@ -49,6 +50,7 @@ sha256sums=('f27bdb02ebf3c48abe054c73f1ae57e22a22535ea34f5edf8693ab8432a7c717'
'7514c6c81a64a5457b66494a366fbb39005563eecc48d1a39033dd06aec4e300'
'7cace84d7494190e7882d3e637820646ec8d64808f0a2128c515bd44991a3790'
'03d03a39b2afa40083eb8ccb9616a51619f71da92348effc8ee289cbda10128b'
+ '1ec617b362bf97cce4254debd04d8396f17dec0ae1071b52ec8c1c3d86dbd322'
'bf86923eaee5529ab9fb6148bd6c33a73c8746ab1b4ade0cd3b761109bc55826'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
@@ -103,6 +105,7 @@ prepare() {
patch -Np1 -i ../only-fall-back-to-the-i965-driver-if-we-re-on-iHD.patch
patch -Np1 -i ../remove-dead-reloc-in-nonalloc-LD-flags.patch
patch -Np1 -i ../check-for-enable-accelerated-video-decode-on-Linux.patch
+ patch -Np1 -i ../xproto-fix-underflow-in-Fp1616ToDouble.patch
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-86-nearby-include.patch
diff --git a/xproto-fix-underflow-in-Fp1616ToDouble.patch b/xproto-fix-underflow-in-Fp1616ToDouble.patch
new file mode 100644
index 000000000000..8fcbd7226515
--- /dev/null
+++ b/xproto-fix-underflow-in-Fp1616ToDouble.patch
@@ -0,0 +1,37 @@
+From 5ade494a9966c7a9675af86dc42aca62fb4d806d Mon Sep 17 00:00:00 2001
+From: Tom Anderson <thomasanderson@chromium.org>
+Date: Wed, 21 Oct 2020 22:02:35 +0000
+Subject: [PATCH] [XProto] Fix underflow in Fp1616ToDouble
+
+x11::Input::Fp1616 should be treated as a signed integer, otherwise
+-1 will underflow to 65535. When dragging a scrollbar, this would
+cause the scrollbar to snap to the bottom when the cursor is dragged
+above the window's y=0 coordinate. Verified that the issue is fixed
+after this CL.
+
+BUG=1139623,1136352
+R=sky
+
+Change-Id: Ie318006ceadde9b9ce3e267fb453ddeba0e81da0
+Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2485620
+Auto-Submit: Thomas Anderson <thomasanderson@chromium.org>
+Commit-Queue: Scott Violet <sky@chromium.org>
+Reviewed-by: Scott Violet <sky@chromium.org>
+Cr-Commit-Position: refs/heads/master@{#819538}
+---
+ ui/events/x/events_x_utils.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ui/events/x/events_x_utils.cc b/ui/events/x/events_x_utils.cc
+index 3010db5f40c..856dfb221e7 100644
+--- a/ui/events/x/events_x_utils.cc
++++ b/ui/events/x/events_x_utils.cc
+@@ -376,7 +376,7 @@ base::TimeTicks TimeTicksFromXEvent(const x11::Event& xev) {
+
+ // This is ported from libxi's FP1616toDBL in XExtInt.c
+ double Fp1616ToDouble(x11::Input::Fp1616 x) {
+- auto x32 = static_cast<uint32_t>(x);
++ auto x32 = static_cast<int32_t>(x);
+ return x32 * 1.0 / (1 << 16);
+ }
+