summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKJ Liew2020-10-08 21:50:56 -0700
committerKJ Liew2020-10-08 21:50:56 -0700
commitfaaf9c71384d8090081c739cc94680615a4da3f4 (patch)
tree1d7ff809a6c68712cdf675a8e4fdde829d0519d4
parent6c04081337754992b213455ee72ed50d01b6f38a (diff)
downloadaur-faaf9c71384d8090081c739cc94680615a4da3f4.tar.gz
fix `--use-gl=egl` for Wayland/EGL
-rw-r--r--PKGBUILD2
-rw-r--r--wayland-egl.patch36
2 files changed, 37 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd896308e184..64abd478d29a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,7 +49,7 @@ sha256sums=('dd7a41eda5f984e44474d7e6fb25b5df88c1c924a1a3966189f037f7d325bcb5'
'7514c6c81a64a5457b66494a366fbb39005563eecc48d1a39033dd06aec4e300'
'7cace84d7494190e7882d3e637820646ec8d64808f0a2128c515bd44991a3790'
'03d03a39b2afa40083eb8ccb9616a51619f71da92348effc8ee289cbda10128b'
- '34d08ea93cb4762cb33c7cffe931358008af32265fc720f2762f0179c3973574'
+ 'bf86923eaee5529ab9fb6148bd6c33a73c8746ab1b4ade0cd3b761109bc55826'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
diff --git a/wayland-egl.patch b/wayland-egl.patch
index 58a079862f35..34e274e6c3da 100644
--- a/wayland-egl.patch
+++ b/wayland-egl.patch
@@ -1,3 +1,39 @@
+--- a/media/gpu/vaapi/vaapi_video_decode_accelerator.cc 2020-10-07 09:38:47.000000000 -0700
++++ b/media/gpu/vaapi/vaapi_video_decode_accelerator.cc 2020-10-08 14:09:34.550174093 -0700
+@@ -698,7 +698,6 @@
+ // The X11/ANGLE implementation can use |vaapi_wrapper_| to copy from an
+ // internal libva buffer into an X Pixmap without having to use a processing
+ // wrapper.
+-#if !defined(USE_X11)
+ // If we aren't in BufferAllocationMode::kNone, we have to allocate a
+ // |vpp_vaapi_wrapper_| for VaapiPicture to DownloadFromSurface() the VA's
+ // internal decoded frame.
+@@ -708,6 +707,7 @@
+ VaapiWrapper::kVideoProcess, VAProfileNone,
+ base::Bind(&ReportVaapiErrorToUMA,
+ "Media.VaapiVideoDecodeAccelerator.Vpp.VAAPIError"));
++#if !defined(USE_X11)
+ RETURN_AND_NOTIFY_ON_FAILURE(vpp_vaapi_wrapper_,
+ "Failed to initialize VppVaapiWrapper",
+ PLATFORM_FAILURE, );
+@@ -715,11 +715,15 @@
+ RETURN_AND_NOTIFY_ON_FAILURE(
+ vpp_vaapi_wrapper_->CreateContext(gfx::Size()),
+ "Failed to create Context", PLATFORM_FAILURE, );
++#else
++ if (vpp_vaapi_wrapper_)
++ vpp_vaapi_wrapper_->CreateContext(gfx::Size());
++#endif // !defined(USE_X11)
+ }
+- vaapi_wrapper_for_picture = vpp_vaapi_wrapper_;
++ vaapi_wrapper_for_picture = (vpp_vaapi_wrapper_)?
++ vpp_vaapi_wrapper_:vaapi_wrapper_for_picture;
+ }
+
+-#endif // !defined(USE_X11)
+
+ for (size_t i = 0; i < buffers.size(); ++i) {
+ // TODO(b/139460315): Create with buffers[i] once the AMD driver issue is
--- a/ui/gl/gl_image_native_pixmap.cc 2020-05-18 11:40:06.000000000 -0700
+++ b/ui/gl/gl_image_native_pixmap.cc 2020-05-22 02:07:16.007770442 -0700
@@ -288,6 +288,8 @@