summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2018-12-20 12:44:49 -0600
committerDoug Newgard2018-12-20 12:45:15 -0600
commitcc972af32166f1dbdbb5e65917c394f2bd431101 (patch)
tree5d9957f0d1908ba0070bec789fc87cb32e4d3be1
parent84ab8e0186533cfdc44c451a90674cf5bbfd6b0d (diff)
downloadaur-cc972af32166f1dbdbb5e65917c394f2bd431101.tar.gz
We're dlopening the lib now, deps have to be global
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD3
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d86a1a2717b..f80d23f034ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,11 @@ pkgbase = chromium-widevine
url = https://www.widevine.com/
arch = x86_64
license = custom
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = nspr
+ depends = nss
options = !strip
source = chrome-eula_text-20181101.html::https://www.google.com/intl/en/chrome/privacy/eula_text.html
source = https://dl.google.com/linux/deb/pool/main/g/google-chrome-stable/google-chrome-stable_71.0.3578.98-1_amd64.deb
@@ -15,10 +20,4 @@ pkgbase = chromium-widevine
sha256sums = 3fda44a5b8b222434530f27923568de1fda1eb0caa8621b56a8b2a6a2a2e3d5d
pkgname = chromium-widevine
- depends = chromium
- depends = gcc-libs
- depends = glib2
- depends = glibc
- depends = nspr
- depends = nss
diff --git a/PKGBUILD b/PKGBUILD
index 269148dcd8a5..6409484f8a6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ epoch=1
arch=('x86_64')
url='https://www.widevine.com/'
license=('custom')
+depends=('gcc-libs' 'glib2' 'glibc' 'nspr' 'nss')
options=('!strip')
source=("chrome-eula_text-$_license_date.html::https://www.google.com/intl/en/chrome/privacy/eula_text.html"
"https://dl.google.com/linux/deb/pool/main/g/google-chrome-stable/google-chrome-stable_${_chrome_ver}-1_amd64.deb"
@@ -29,8 +30,6 @@ pkgver() {
}
package() {
- depends=('chromium' 'gcc-libs' 'glib2' 'glibc' 'nspr' 'nss')
-
install -Dm644 libwidevinecdm.so -t "$pkgdir/usr/lib/chromium/"
install -Dm644 chrome-eula_text-$_license_date.html "$pkgdir/usr/share/licenses/$pkgname/eula_text.html"
}