summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlain Kalker2015-07-01 23:49:32 +0200
committerAlain Kalker2015-07-02 20:14:24 +0200
commitbd5a19318b867797c1847c90f86454954529d022 (patch)
tree1b2540fcb7a870a01feba3f4c8098c149f2ce10c
parent123adadd75bfc1d7bdfc51fc3eeb4b90c3842248 (diff)
downloadaur-bd5a19318b867797c1847c90f86454954529d022.tar.gz
Update package
- Cleanup whitespace - Cleanup voice installation
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD116
2 files changed, 49 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceb32a92034e..6a7db803bbc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chromiumos-ui-tts-git
pkgdesc = Chromium OS UI ChromeVox text-to-speech, with accessibility support
- pkgver = 440.2714077
+ pkgver = 491.d01fbdc
pkgrel = 1
url = http://www.chromium.org/chromium-os
arch = arm
diff --git a/PKGBUILD b/PKGBUILD
index e416d5b03837..471e84ae830d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alain Kalker <a.c.kalker@gmail.com>
_pkgbase=chromiumos-ui-tts
pkgname=$_pkgbase-git
-pkgver=440.2714077
+pkgver=491.d01fbdc
pkgrel=1
pkgdesc="Chromium OS UI ChromeVox text-to-speech, with accessibility support"
arch=('arm' 'i686' 'x86_64')
@@ -16,79 +16,59 @@ _gitname=chromeos-assets
source=($_gitname::git+https://chromium.googlesource.com/chromiumos/platform/assets)
md5sums=('SKIP')
+# Voices
+_voices=(de-DE_2
+ en-GB_2
+ en-IN_2
+ en-US_2
+ es-ES_2
+ es-US_2
+ fr-FR_2
+ it-IT_2
+ ko-KR_2
+ nl-NL_2
+ pt-BR_2)
+
pkgver() {
- cd "$srcdir/$_gitname"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "$srcdir/$_gitname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
package() {
- cd "$srcdir/$_gitname"
-
- # Speech synthesis accessibility support
- unzip accessibility/extensions/access_chromevox.zip
- install -d "$pkgdir/usr/share/$_gitname"/accessibility/extensions/access_chromevox
- cp -dr chromevox_deploy/* "$pkgdir/usr/share/$_gitname"/accessibility/extensions/access_chromevox/
-
- #
- # Speech synthesis
- #
+ cd "$srcdir/$_gitname"
- install -d "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts
+ install -d "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts
- # Speech synthesis component extension code
- install -D speech_synthesis/patts/manifest.json \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- install -D speech_synthesis/patts/tts_main.js \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- install -D speech_synthesis/patts/tts_controller.js \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- install -D speech_synthesis/patts/tts_service.nmf \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ # Speech synthesis component extension code
+ install -D speech_synthesis/patts/manifest.json \
+ "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ install -D speech_synthesis/patts/tts_main.js \
+ "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ install -D speech_synthesis/patts/tts_controller.js \
+ "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ install -D speech_synthesis/patts/tts_service.nmf \
+ "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- # Speech synthesis voice data
- install -D speech_synthesis/patts/voice_data_hmm_de-DE.js \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- unzip speech_synthesis/patts/voice_data_hmm_de-DE.zip
- cp -dr voice_data_hmm_de-DE \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- install -D speech_synthesis/patts/voice_data_hmm_en-GB.js \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- unzip speech_synthesis/patts/voice_data_hmm_en-GB.zip
- cp -dr voice_data_hmm_en-GB \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- install -D speech_synthesis/patts/voice_data_hmm_en-US.js \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- unzip speech_synthesis/patts/voice_data_hmm_en-US.zip
- cp -dr voice_data_hmm_en-US \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- install -D speech_synthesis/patts/voice_data_hmm_es-ES.js \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- unzip speech_synthesis/patts/voice_data_hmm_es-ES.zip
- cp -dr voice_data_hmm_es-ES \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- install -D speech_synthesis/patts/voice_data_hmm_fr-FR.js \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- unzip speech_synthesis/patts/voice_data_hmm_fr-FR.zip
- cp -dr voice_data_hmm_fr-FR \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- install -D speech_synthesis/patts/voice_data_hmm_it-IT.js \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- unzip speech_synthesis/patts/voice_data_hmm_it-IT.zip
- cp -dr voice_data_hmm_it-IT \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ # Speech synthesis voice data
+ for _voice in ${_voices[@]}; do
+ install -D speech_synthesis/patts/voice_data_hmm_$_voice.js \
+ "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ unzip speech_synthesis/patts/voice_data_hmm_$_voice.zip \
+ -d "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ done
- # Speech synthesis engine (platform-specific native client module)
- if [ "$CARCH" = "arm" ] ; then
- unzip speech_synthesis/patts/tts_service_pexe_arm.nexe.zip
- install -D tts_service_pexe_arm.nexe \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- elif [ "$CARCH" = "i686" ] ; then
- unzip speech_synthesis/patts/tts_service_x86-32.nexe.zip
- install -D tts_service_x86-32.nexe \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- elif [ "$CARCH" = "x86_64" ] ; then
- unzip speech_synthesis/patts/tts_service_x86-64.nexe.zip
- install -D tts_service_x86-64.nexe \
- "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
- fi
+ # Speech synthesis engine (platform-specific native client module)
+ if [ "$CARCH" = "arm" ] ; then
+ unzip speech_synthesis/patts/tts_service_pexe_arm.nexe.zip
+ install -D tts_service_pexe_arm.nexe \
+ "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ elif [ "$CARCH" = "i686" ] ; then
+ unzip speech_synthesis/patts/tts_service_x86-32.nexe.zip
+ install -D tts_service_x86-32.nexe \
+ "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ elif [ "$CARCH" = "x86_64" ] ; then
+ unzip speech_synthesis/patts/tts_service_x86-64.nexe.zip
+ install -D tts_service_x86-64.nexe \
+ "$pkgdir/usr/share/$_gitname"/speech_synthesis/patts/
+ fi
}