summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorben Günther2020-10-22 13:15:07 +0200
committerThorben Günther2020-10-22 13:15:07 +0200
commitfb253e540ab734c96c2f042499a86097fcf5bc74 (patch)
tree864a84235d1c656b04b1a01da32ce85294a9eb03
parent12a148a6a841c9b3a974dda3f3adeed197ee40d3 (diff)
downloadaur-fb253e540ab734c96c2f042499a86097fcf5bc74.tar.gz
upgpkg: chronic 1.0.11-2
Update goflags and conflict with moreutils.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80fb1b0c48d0..6b9e3bf37057 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = chronic
pkgdesc = Filters out standard output for cron emails.
pkgver = 1.0.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/docwhat/chronic
arch = x86_64
license = MIT
makedepends = go
+ conflicts = moreutils
source = chronic-1.0.11.tar.gz::https://github.com/docwhat/chronic/archive/v1.0.11.tar.gz
sha256sums = 9e0a50086f15d32c68cdafa22919f088813b64bd4890e667a7c08ed7ba7dce1c
diff --git a/PKGBUILD b/PKGBUILD
index 777ad36da5ea..ee0ccb805ad4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chronic
pkgver=1.0.11
-pkgrel=1
+pkgrel=2
pkgdesc='Filters out standard output for cron emails.'
arch=('x86_64')
url='https://github.com/docwhat/chronic'
@@ -10,6 +10,7 @@ license=('MIT')
makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('9e0a50086f15d32c68cdafa22919f088813b64bd4890e667a7c08ed7ba7dce1c')
+conflicts=('moreutils')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -17,7 +18,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -o chronic
}