summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-09-23 13:08:18 +0200
committerbartus2017-09-23 13:08:18 +0200
commitcfdb6068522099f8c3dbfed6f40b9d2555eee200 (patch)
tree2dc93a10e7621ad1e82a1f2da0d99cdd601915a0
parentea10bc6ccac4d698fd087cc98aef62f3663929fd (diff)
downloadaur-cfdb6068522099f8c3dbfed6f40b9d2555eee200.tar.gz
update to version 3.0, add extra modules, move demos to /bin/chronoengine, add demos to PATH
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD58
-rwxr-xr-xchronoengine.sh1
3 files changed, 63 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b31b7c25c713..1e9f41a9e0d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,25 @@
-# Generated by mksrcinfo v8
-# Thu Jan 7 18:53:23 UTC 2016
pkgbase = chronoengine
pkgdesc = C++ library for physics simulation
- pkgver = 2.0.0
+ pkgver = 3.0.0
pkgrel = 1
url = http://projectchrono.org/chronoengine/
arch = i686
arch = x86_64
license = custom
makedepends = cmake
- depends = gcc-libs
- source = git+https://github.com/projectchrono/chrono.git#tag=2.0.0
+ makedepends = git
+ makedepends = glm
+ makedepends = irrlicht
+ makedepends = glut
+ makedepends = openmpi
+ depends = glew
+ depends = glfw
+ optdepends = irrlicht: Runtime visualization with Irrlicht.
+ optdepends = glm: Runtime visualization with OpenGL.
+ source = chronoengine::git+https://github.com/projectchrono/chrono.git
+ source = chronoengine.sh
sha1sums = SKIP
+ sha1sums = 8d8cb3fc9324e50cec8f5bb5dbf8a78817a32b81
pkgname = chronoengine
diff --git a/PKGBUILD b/PKGBUILD
index 4e87feb059c6..db130243a2d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,66 @@
pkgname=chronoengine
-pkgver=2.0.0
+pkgver=3.0.0
+#fragment="#tag=${pkgver}"
pkgrel=1
pkgdesc="C++ library for physics simulation"
license=('custom')
arch=('i686' 'x86_64')
url="http://projectchrono.org/chronoengine/"
-depends=('gcc-libs')
-makedepends=('cmake')
-source=("git+https://github.com/projectchrono/chrono.git#tag=${pkgver}")
-sha1sums=('SKIP')
+depends=(glew glfw)
+makedepends=(cmake git glm irrlicht glut openmpi)
+#makedepends+=(intel-mkl) # -DENABLE_MODULE_MKL=ON requirement
+#makedepends+=(blaze) # -DENABLE_MODULE_PARALLEL=ON requirement
+optdepends=(
+ "irrlicht: Runtime visualization with Irrlicht."
+ "glm: Runtime visualization with OpenGL."
+ )
+#optdepends+=(
+# "blaze: Parallel solver module for Chrono."
+# "intel-mkl: This library is currently used in Chrono for its parallel direct solver (Pardiso)"
+#)
+
+source=("${pkgname}::git+https://github.com/projectchrono/chrono.git${fragment}"
+ "chronoengine.sh")
+sha1sums=('SKIP'
+ '8d8cb3fc9324e50cec8f5bb5dbf8a78817a32b81')
+
+CMAKE_FLAGS=( -DENABLE_MODULE_POSTPROCESS=ON
+ -DENABLE_MODULE_VEHICLE=ON
+ -DENABLE_MODULE_FEA=ON
+ -DENABLE_MODULE_PYTHON=OFF
+ -DENABLE_MODULE_IRRLICHT=ON
+ -DENABLE_MODULE_CASCADE=OFF
+ -DENABLE_MODULE_OPENGL=ON
+ -DENABLE_MODULE_PARALLEL=OFF
+ -DENABLE_MODULE_MKL=OFF
+ -DENABLE_MODULE_COSIMULATION=OFF
+ -DENABLE_MODULE_FSI=ON
+ )
+#COSIMULATION not working because of missing sys/filio.h
+#MKL works but building intel-mkl is such a paint that I skipped this feature
+
+prepare() {
+ cd ${pkgname}
+ files=($(find -name CMakeLists.txt))
+ files+=($(find -name \*.cmake\*))
+ sed -i 's/lib64/lib/' ${files[@]}
+ sed -i 's|share/chrono/bin|bin/chronoengine|' CMakeLists.txt
+}
build() {
- cd chrono/src
- mkdir -p build && pushd build
+ mkdir -p build
+ cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
- ..
+ ${CMAKE_FLAGS[@]} \
+ ../${pkgname}
make
}
package() {
- cd chrono/src/build
+ cd build
make DESTDIR="$pkgdir" install
+ install -D -m644 "../chronoengine/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "../chronoengine.sh" "${pkgdir}/etc/profile.d/chronoengine.sh"
}
diff --git a/chronoengine.sh b/chronoengine.sh
new file mode 100755
index 000000000000..1ae613eec3af
--- /dev/null
+++ b/chronoengine.sh
@@ -0,0 +1 @@
+export PATH=$PATH:/usr/bin/chronoengine