summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2020-04-20 21:31:12 -0400
committerMatthew McGinn2020-04-20 21:31:31 -0400
commit1feedb3d893350feab276af27558dbc5fd360c29 (patch)
tree6d88dec5d2f9dbd4d633b754736ee3006bc94d62
parentad677ac5048e2033fa4bcb262a213657854f02b2 (diff)
downloadaur-1feedb3d893350feab276af27558dbc5fd360c29.tar.gz
remove broken Makefile patch
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile.patch17
-rw-r--r--PKGBUILD5
3 files changed, 2 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc56637fee31..3b84f47accc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,11 +22,9 @@ pkgbase = chronograf
source = git+https://github.com/influxdata/chronograf#tag=1.8.2
source = chronograf.sysusers
source = chronograf.tmpfiles
- source = Makefile.patch
sha256sums = SKIP
sha256sums = 594777c81e3728fe1d5033c61034fb58d26a7c79f00f2a6daa143de521cf5440
sha256sums = c81f81247b99928bd20428f7188c1790fff89c4521f3322a8ff148272b24bab6
- sha256sums = b439f430a7efdcd480f3a76fc67c1d6eb6deb5e4b52c65ff1d4eb3306f608299
pkgname = chronograf
diff --git a/Makefile.patch b/Makefile.patch
deleted file mode 100644
index ac3b31edd0c2..000000000000
--- a/Makefile.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/Makefile b/Makefile
-index a6844a197..6ef98e63d 100644
---- a/Makefile
-+++ b/Makefile
-@@ -13,10 +13,10 @@ SOURCES := $(shell find . -name '*.go' ! -name '*_gen.go' -not -path "./vendor/*
- UISOURCES := $(shell find ui -type f -not \( -path ui/build/\* -o -path ui/node_modules/\* -prune \) )
-
- unexport LDFLAGS
--LDFLAGS=-ldflags "-s -X main.commit=${COMMIT}"
- ifdef VERSION
-- LDFLAGS += -X main.version=$(VERSION)
-+ TMP_BUILD_VERSION = -X main.version=$(VERSION)
- endif
-+LDFLAGS=-ldflags "-s -X main.commit=${COMMIT} ${TMP_BUILD_VERSION}"
-
- BINARY=chronograf
- CTLBINARY=chronoctl
diff --git a/PKGBUILD b/PKGBUILD
index 6866946d88d1..b02aa68318e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,11 +17,11 @@ install="chronograf.install"
source=("git+https://github.com/influxdata/chronograf#tag=${pkgver}"
'chronograf.sysusers'
'chronograf.tmpfiles'
- 'Makefile.patch')
+)
sha256sums=('SKIP'
'594777c81e3728fe1d5033c61034fb58d26a7c79f00f2a6daa143de521cf5440'
'c81f81247b99928bd20428f7188c1790fff89c4521f3322a8ff148272b24bab6'
- 'b439f430a7efdcd480f3a76fc67c1d6eb6deb5e4b52c65ff1d4eb3306f608299')
+)
build() {
export GOPATH="${srcdir}"
@@ -32,7 +32,6 @@ build() {
cd "${GOPATH}/src/github.com/influxdata/chronograf"
- git apply "${srcdir}/Makefile.patch"
make
go install github.com/influxdata/${pkgname}/cmd/${pkgname}
go install github.com/influxdata/${pkgname}/cmd/chronoctl