summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-06 00:12:51 +0300
committerCaleb Maclennan2020-10-06 00:12:51 +0300
commit11e1d90fe24adeb3ffe861bbc30dcd1f8f7d9b07 (patch)
tree6b6070325879a4990bbc847fbc75c182aeae88db
parent25ff9414e9e835f2fca6884fb2c3d8eac08ecf5c (diff)
downloadaur-11e1d90fe24adeb3ffe861bbc30dcd1f8f7d9b07.tar.gz
upgpkg: chrysalis 0.7.9-1
upstream release Adopt, overhaul packaging to build from source
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
2 files changed, 28 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e99f1329f4f6..b75191be14f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = chrysalis
- pkgdesc = A graphical configuration tool for programmable keyboards. Prebuilt AppImage Releases
+ pkgdesc = Graphical configurator for Kaleidoscope-powered keyboards
pkgver = 0.7.9
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/keyboardio/Chrysalis
arch = x86_64
license = GPL3
+ makedepends = yarn
depends = fuse2
- options = !strip
- source = https://github.com/keyboardio/Chrysalis/releases/download/chrysalis-0.7.9/Chrysalis-0.7.9.AppImage
- sha512sums = 62a57c37783151f77a0a4b6ff02b90420df36483e7a1f7a8d761cc0ebdf37bfdf738755b187f8e3f3969f5b981e0fd136dde55e80a850372168d391d9b4b2371
+ depends = uucp
+ source = https://github.com/keyboardio/Chrysalis/archive/chrysalis-0.7.9.tar.gz
+ sha256sums = 224e73ad733ecc03da5caa6fd460ed7d63f65f2d15134397f7eb978bdf174f4e
pkgname = chrysalis
diff --git a/PKGBUILD b/PKGBUILD
index 35c97493c9ad..ecd401a7b810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,30 @@
-# Maintainer: Alfredo Luque <me@aluque.io>
-# Maintainer: Paul Mourer <paul.mourer@gmail.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
-pkgname='chrysalis'
-pkgdesc="A graphical configuration tool for programmable keyboards. Prebuilt AppImage Releases"
+pkgname=chrysalis
+pkgdesc="Graphical configurator for Kaleidoscope-powered keyboards"
pkgver=0.7.9
-pkgrel=0
+pkgrel=1
arch=('x86_64')
url='https://github.com/keyboardio/Chrysalis'
license=('GPL3')
-depends=('fuse2')
-options=('!strip')
-source=("https://github.com/keyboardio/Chrysalis/releases/download/$pkgname-$pkgver/Chrysalis-$pkgver.AppImage")
-sha512sums=('62a57c37783151f77a0a4b6ff02b90420df36483e7a1f7a8d761cc0ebdf37bfdf738755b187f8e3f3969f5b981e0fd136dde55e80a850372168d391d9b4b2371')
+depends=('fuse2' 'uucp')
+makedepends=('yarn')
+source=("$url/archive/$pkgname-$pkgver.tar.gz")
+sha256sums=('224e73ad733ecc03da5caa6fd460ed7d63f65f2d15134397f7eb978bdf174f4e')
+
+prepare() {
+ cd "${pkgname^}-$pkgname-$pkgver"
+ sed -i -e 's,algernon/avr.*",^4.2.4",g' package.json
+ sed -i -e '/prettier/d' .eslintrc.js
+ yarn --cache-folder "$srcdir/node_modules" install --no-lockfile
+}
+
+build() {
+ cd "${pkgname^}-$pkgname-$pkgver"
+ yarn --cache-folder "$srcdir/node_modules" run build:linux
+}
package() {
- mkdir -p "$pkgdir/usr/bin"
- chmod +x "$srcdir/Chrysalis-$pkgver.AppImage"
- cp "$srcdir/Chrysalis-$pkgver.AppImage" "$pkgdir/usr/bin/chrysalis"
+ cd "${pkgname^}-$pkgname-$pkgver/dist"
+ install -Dm755 ${pkgname^}-$pkgver.AppImage "$pkgdir/usr/bin/$pkgname"
}