summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-05 16:42:07 +0300
committerCaleb Maclennan2020-10-05 16:46:53 +0300
commit4be65fbff63dbb49ecff446376ef4c3ccbc69a53 (patch)
treefdacc187c7b460a1b2487614c1dc614a92915a49
parent7497c0a1ba5d23c099f85137be63b842f2b1923e (diff)
downloadaur-4be65fbff63dbb49ecff446376ef4c3ccbc69a53.tar.gz
Rename package as -bin since this is an AppImage
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35c97493c9ad..784ff56e321c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
# Maintainer: Alfredo Luque <me@aluque.io>
# Maintainer: Paul Mourer <paul.mourer@gmail.com>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
-pkgname='chrysalis'
-pkgdesc="A graphical configuration tool for programmable keyboards. Prebuilt AppImage Releases"
+pkgname=chrysalis-bin
+pkgdesc="Graphical configurator for Kaleidoscope-powered keyboards (AppImage)"
pkgver=0.7.9
-pkgrel=0
+pkgrel=1
arch=('x86_64')
url='https://github.com/keyboardio/Chrysalis'
license=('GPL3')
depends=('fuse2')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
options=('!strip')
-source=("https://github.com/keyboardio/Chrysalis/releases/download/$pkgname-$pkgver/Chrysalis-$pkgver.AppImage")
-sha512sums=('62a57c37783151f77a0a4b6ff02b90420df36483e7a1f7a8d761cc0ebdf37bfdf738755b187f8e3f3969f5b981e0fd136dde55e80a850372168d391d9b4b2371')
+source=("$url/releases/download/${pkgname%-bin}-$pkgver/Chrysalis-$pkgver.AppImage")
+sha256sums=('f10f9b69897405bec7370908d9d0aac8fbe341d2cadd89d8edfb3adecede848b')
package() {
mkdir -p "$pkgdir/usr/bin"