summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-04-10 12:08:09 +0300
committerCaleb Maclennan2021-04-10 12:08:09 +0300
commit79df1cb2e9df854612688c65b7e4dfa67a572b33 (patch)
tree66bf914cd5a25ce5367f72a397f776749f4b52ca
parent2f1dab431a2a734d1130b38cd2cb543ec13d888b (diff)
downloadaur-79df1cb2e9df854612688c65b7e4dfa67a572b33.tar.gz
upgpkg: chrysalis 0.8.4-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rwxr-xr-xchrysalis.sh9
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f89e4cad9203..977e4fab359a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chrysalis
pkgdesc = Graphical configurator for Kaleidoscope-powered keyboards
- pkgver = 0.8.2
+ pkgver = 0.8.4
pkgrel = 1
url = https://github.com/keyboardio/Chrysalis
arch = x86_64
@@ -12,10 +12,10 @@ pkgbase = chrysalis
depends = electron
depends = fuse2
depends = uucp
- source = chrysalis-0.8.2.tar.gs::https://github.com/keyboardio/Chrysalis/archive/v0.8.2.tar.gz
+ source = chrysalis-0.8.4.tar.gs::https://github.com/keyboardio/Chrysalis/archive/v0.8.4.tar.gz
source = chrysalis.sh
- sha256sums = b7bdd94badd5f9190fd19db2c9db7a361224ed018290a82cd0fc319d59b1ddfa
- sha256sums = a578aefca029bc10910db0cfd9d6f2711d589525a4a794e056780e67bf4ef02f
+ sha256sums = e7442fe571a49b09f4fa1a18bd4ec1655212e312b481d9f72732943ee113b8d3
+ sha256sums = 9de3ff052ca4600862b8663b93bf2b4223cf2e637995c67e1fe4cb4ed893b39f
pkgname = chrysalis
diff --git a/PKGBUILD b/PKGBUILD
index 6cd5a25864c4..57c8acbe4c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chrysalis
pkgdesc='Graphical configurator for Kaleidoscope-powered keyboards'
-pkgver=0.8.2
+pkgver=0.8.4
pkgrel=1
arch=('x86_64')
url="https://github.com/keyboardio/${pkgname^}"
@@ -11,8 +11,8 @@ depends=('electron' 'fuse2' 'uucp')
makedepends=('jq' 'moreutils' 'node-gyp' 'yarn')
source=("$pkgname-$pkgver.tar.gs::$url/archive/v$pkgver.tar.gz"
"$pkgname.sh")
-sha256sums=('b7bdd94badd5f9190fd19db2c9db7a361224ed018290a82cd0fc319d59b1ddfa'
- 'a578aefca029bc10910db0cfd9d6f2711d589525a4a794e056780e67bf4ef02f')
+sha256sums=('e7442fe571a49b09f4fa1a18bd4ec1655212e312b481d9f72732943ee113b8d3'
+ '9de3ff052ca4600862b8663b93bf2b4223cf2e637995c67e1fe4cb4ed893b39f')
prepare() {
local _electronVersion=$(electron --version | sed -e 's/^v//')
@@ -21,8 +21,6 @@ prepare() {
jq 'del(.devDependencies["electron"])' package.json | sponge package.json
yarn --cache-folder "$srcdir/node_modules" install --frozen-lockfile --ignore-scripts
yarn --cache-folder "$srcdir/node_modules" add -D --no-lockfile --ignore-scripts electron@$_electronVersion
- # Work around outdated node-usb, see https://github.com/tessel/node-usb/pull/394
- sed -i 's/c++0x/c++14/' node_modules/usb/binding.gyp
}
build() {
diff --git a/chrysalis.sh b/chrysalis.sh
index f4117f646922..b0835280ba68 100755
--- a/chrysalis.sh
+++ b/chrysalis.sh
@@ -1,3 +1,12 @@
#!/usr/bin/env sh
+set -e
+
+if [ -n "$WAYLAND_DISPLAY" ]; then
+ set -- --enable-features=UseOzonePlatform --ozone-platform=wayland "$@"
+fi
+
+if ! grep -qFx 1 /proc/sys/kernel/unprivileged_userns_clone; then
+ set -- --no-sandbox "$@"
+fi
exec electron /usr/lib/chrysalis/app.asar "$@"