summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-06-29 17:09:50 +0300
committerCaleb Maclennan2023-06-29 17:09:50 +0300
commitd4cc12ab6586106c084f794b83bfcfcc5ab6659e (patch)
tree10bd206e343419ba4c3c8c0f45e2a681ece24631
parent29e78bf3ae3cf0835c3ee17ef066ade81a583b68 (diff)
downloadaur-d4cc12ab6586106c084f794b83bfcfcc5ab6659e.tar.gz
upgpkg: chrysalis 0.13.2-2
Post finished build (last commit didn't have final edits staged)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3fd5abf722b..0dc0275c1bd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = chrysalis
pkgdesc = Graphical configurator for Kaleidoscope-powered keyboards
pkgver = 0.13.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/keyboardio/Chrysalis
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 1c16e7a4e36a..714fae8cc778 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=chrysalis
pkgdesc='Graphical configurator for Kaleidoscope-powered keyboards'
pkgver=0.13.2
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url="https://github.com/keyboardio/${pkgname^}"
license=(GPL3)
@@ -41,16 +41,16 @@ prepare() {
build() {
cd "$_archive"
- yarn $_yarnargs run make
+ yarn $_yarnargs run package
}
package() {
sed -E "s/electron/$_electron/" "$pkgname.sh" |
install -Dm0755 /dev/stdin "$pkgdir/usr/bin/$pkgname"
cd "$_archive"
- local _dist=dist/linux-unpacked/resources
+ local _dist=out/${pkgname^}-linux-x64/resources
install -Dm0644 -t "$pkgdir/usr/lib/$pkgname/" "$_dist/app.asar"
- cp -a "$_dist/static" "$pkgdir/usr/lib/$pkgname"
+ cp -a "$_dist/app.asar.unpacked" "$_dist/static" "$pkgdir/usr/lib/$pkgname/"
install -Dm0644 -t "$pkgdir/usr/lib/$pkgname/" NEWS.md
mkdir -p "$pkgdir/usr/lib/udev/rules.d/"
ln -s /usr/lib/chrysalis/static/udev/60-kaleidoscope.rules "$pkgdir/usr/lib/udev/rules.d/"