summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortjbp2020-10-05 10:52:23 +0100
committertjbp2020-10-05 10:52:23 +0100
commita4750c79ddc63cdb922004da9f07dbf9a9173968 (patch)
tree0c785073c07f43d2ea4a79b6f687b8c2eabfd1f6
parenta7d0df86c99c18156f371b33bee2d0df9870a5dc (diff)
downloadaur-a4750c79ddc63cdb922004da9f07dbf9a9173968.tar.gz
Updated to 1.4.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--pulse.patch8
3 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 592b089dc304..bb3a646d5a84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Mar 9 18:25:32 UTC 2016
pkgbase = chuck-pulse
pkgdesc = Concurrent, on-the-fly audio programming language
- pkgver = 1.3.5.2
+ pkgver = 1.4.0.1
pkgrel = 1
url = http://chuck.cs.princeton.edu/
arch = x86_64
@@ -12,8 +10,8 @@ pkgbase = chuck-pulse
depends = libsndfile
provides = chuck
conflicts = chuck
- source = http://chuck.cs.princeton.edu/release/files/chuck-1.3.5.2.tgz
- sha256sums = e900b8545ffcb69c6d49354b18c43a9f9b8f789d3ae822f34b408eaee8d3e70b
+ source = http://chuck.cs.princeton.edu/release/files/chuck-1.4.0.1.tgz
+ sha256sums = 11a20c34b385e132bf43d5ae6a562c652f631828cc6b1562a4c029bc9a850ed4
pkgname = chuck-pulse
diff --git a/PKGBUILD b/PKGBUILD
index e641715ceda9..864c82b7fb4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: tardo <tardo@nagi-fanboi.net>
pkgname=chuck-pulse
-pkgver=1.3.5.2
+pkgver=1.4.0.1
pkgrel=1
pkgdesc='Concurrent, on-the-fly audio programming language'
arch=('x86_64' 'i686')
@@ -17,7 +17,7 @@ depends=('gcc-libs' 'libsndfile')
conflicts=('chuck')
provides=('chuck')
source=("http://chuck.cs.princeton.edu/release/files/chuck-$pkgver.tgz")
-sha256sums=('e900b8545ffcb69c6d49354b18c43a9f9b8f789d3ae822f34b408eaee8d3e70b')
+sha256sums=('11a20c34b385e132bf43d5ae6a562c652f631828cc6b1562a4c029bc9a850ed4')
build() {
patch -p0 --binary -i "$startdir/pulse.patch"
diff --git a/pulse.patch b/pulse.patch
index 70ba8bde1483..d2b45e528f52 100644
--- a/pulse.patch
+++ b/pulse.patch
@@ -1,6 +1,6 @@
---- chuck-1.3.5.2/src/RtAudio/RtAudio.cpp
-+++ chuck-1.3.5.2/src/RtAudio/RtAudio.cpp
-@@ -5663,7 +5663,7 @@
+--- chuck-1.4.0.1/src/host/RtAudio/RtAudio.cpp
++++ chuck-1.4.0.1/src/host/RtAudio/RtAudio.cpp
+@@ -5663,7 +5663,7 @@
if ( result < 0 ) break;
if ( subdevice < 0 ) break;
if ( nDevices == device ) {
@@ -9,7 +9,7 @@
snd_ctl_close( chandle );
goto foundDevice;
}
-@@ -5711,6 +5711,7 @@
+@@ -5711,6 +5711,7 @@
snd_pcm_t *phandle;
int openMode = SND_PCM_ASYNC;