summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-23 06:17:07 +1300
committercaltlgin2020-12-23 06:17:07 +1300
commite0df482840efa61c7c0298e8747be4c6e5f2757e (patch)
treefdb1bca5d659f6f2ee932aa42d18818f309ef45f
downloadaur-e0df482840efa61c7c0298e8747be4c6e5f2757e.tar.gz
Add to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8f6fdda06a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = chucknorris
+ pkgdesc = Chuck Norris jokes in your terminal
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/kz6fittycent/Chuck_Norris
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = chucknorris-1.1.tar.gz::https://github.com/kz6fittycent/Chuck_Norris/archive/1.1.tar.gz
+ sha256sums = 0ece25fbee2b899e288c60ab8f7ea57327399ee7029bc9a30b09a821a52696e9
+
+pkgname = chucknorris
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa737e5cab00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='Chuck_Norris'
+pkgname='chucknorris'
+pkgver=1.1
+pkgrel=1
+pkgdesc='Chuck Norris jokes in your terminal'
+arch=('any')
+url='https://github.com/kz6fittycent/Chuck_Norris'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('0ece25fbee2b899e288c60ab8f7ea57327399ee7029bc9a30b09a821a52696e9')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et: