summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPolarian2023-04-13 17:10:17 +0100
committerPolarian2023-04-13 17:10:17 +0100
commit0c8186166ff7af97ed2a8a58f991cf677e4b034a (patch)
tree8676c18fcd81787df3a702c12f1f8757d59b0c21
downloadaur-0c8186166ff7af97ed2a8a58f991cf677e4b034a.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50f981cd8f65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = chuncord
+ pkgdesc = CLI tool that allows for uploading large files to Discord in parts using webhooks
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://git.lemonsh.moe/lemon/chuncord
+ arch = x86_64
+ license = custom:EUPLv1.2
+ makedepends = cargo
+ source = chuncord-0.1.tar.gz::https://git.lemonsh.moe/lemon/chuncord/archive/0.1.tar.gz
+ sha256sums = a6b0806d550a288f4f631b8d22185f343ef7b29e6de53bef675cdf596faa83d6
+
+pkgname = chuncord
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abebff72d943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Polarian <polarian@polarian.dev>
+# Co-maintainer: Lemon <lemon@lemonsh.moe>
+
+pkgname="chuncord"
+pkgver="0.1"
+pkgrel=1
+pkgdesc="CLI tool that allows for uploading large files to Discord in parts using webhooks"
+arch=("x86_64")
+url="https://git.lemonsh.moe/lemon/chuncord"
+license=("custom:EUPLv1.2")
+makedepends=("cargo")
+source=("$pkgname-$pkgver.tar.gz::https://git.lemonsh.moe/lemon/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('a6b0806d550a288f4f631b8d22185f343ef7b29e6de53bef675cdf596faa83d6')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cd "$pkgname-$pkgver"
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" "$pkgname-$pkgver/LICENSE"
+ install -Dm755 "eureka-$pkgver/target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}