summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2019-03-23 20:12:42 +0100
committerÉtienne Deparis2019-03-23 20:12:42 +0100
commit0d0dd493fb36c823e6c0261a832703c86f5c7da3 (patch)
tree0669f4d4fd3aaa8487e075a7bc90073ec8948930
downloadaur-0d0dd493fb36c823e6c0261a832703c86f5c7da3.tar.gz
0.4.1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD19
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a4a32d5e55b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 5.1.3
+# Sat Mar 23 19:12:26 UTC 2019
+pkgbase = chwall
+ pkgdesc = A tiny wallpaper changer, written in python
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://git.deparis.io/chwall/about/
+ arch = any
+ license = WTFPL
+ makedepends = python-setuptools
+ makedepends = imagemagick
+ depends = gtk3
+ depends = python-cssselect
+ depends = python-gobject
+ depends = python-lxml
+ depends = python-requests
+ depends = python-xdg
+ depends = python-yaml
+ source = https://git.deparis.io/chwall/snapshot/chwall-0.4.1.tar.gz
+ sha256sums = 6daeb1e54571284ba5affba5b7d3155b7dfa5f78d0775888a311b28c4c03a9b6
+
+pkgname = chwall
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afe744427fbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+pkgname=chwall
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A tiny wallpaper changer, written in python"
+arch=("any")
+url="https://git.deparis.io/chwall/about/"
+license=("WTFPL")
+depends=("gtk3" "python-cssselect" "python-gobject" "python-lxml"
+ "python-requests" "python-xdg" "python-yaml")
+makedepends=("python-setuptools" "imagemagick")
+source=("https://git.deparis.io/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('6daeb1e54571284ba5affba5b7d3155b7dfa5f78d0775888a311b28c4c03a9b6')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make ROOT="$pkgdir/" dist
+}