summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2024-03-15 14:47:25 +0100
committerÉtienne Deparis2024-03-15 14:47:25 +0100
commit6cd6812593d4ed2756d18a1ee435777c1a532ac9 (patch)
treeb96f578d3ce30b39b4b01115ceca9a979421df45
parent5762a9c9861d001ccb32bebe04be2c60b952d30f (diff)
downloadaur-6cd6812593d4ed2756d18a1ee435777c1a532ac9.tar.gz
0.7.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 33 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbcc1c066e4a..d7e743ec0dc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,15 @@
pkgbase = chwall
pkgdesc = A tiny wallpaper changer, written in python
- pkgver = 0.6.0
- pkgrel = 3
+ pkgver = 0.7.1
+ pkgrel = 1
url = https://git.umaneti.net/chwall/about/
arch = any
- license = custom:WTFPL
+ license = LicenseRef-WTFPL
makedepends = imagemagick
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = gdk-pixbuf2
depends = gobject-introspection-runtime
depends = gtk3
@@ -17,15 +21,16 @@ pkgbase = chwall
depends = python-importlib-metadata
depends = python-lxml
depends = python-pillow
+ depends = python-pyxdg
depends = python-requests
- depends = python-setuptools
- depends = python-xdg
depends = python-yaml
+ optdepends = feh: to apply wallpaper on independant desktop manager
optdepends = imagemagick: to extract wallpaper size when using feh
+ optdepends = libappindicator-gtk3: to display a tray icon
optdepends = libnotify: to send notification when wallpaper change
- optdepends = feh: to apply wallpaper on independant desktop manager
optdepends = xorg-xrandr: to extract screen config when using feh
- source = https://git.umaneti.net/chwall/snapshot/chwall-0.6.0.tar.gz
- sha256sums = 39b6121a30fce6d44bf638910b25de003b6d7b97ed48c6aad068ecdae2802347
+ options = !debug
+ source = https://git.umaneti.net/chwall/snapshot/chwall-0.7.1.tar.gz
+ sha256sums = 61d6c8276a3ff0cc4afafa8fa6d37db2bd33e16259a395f633af2a6ce3a55332
pkgname = chwall
diff --git a/PKGBUILD b/PKGBUILD
index 193d88cf095b..290d656b16a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=chwall
-pkgver=0.6.0
-pkgrel=3
+pkgver=0.7.1
+pkgrel=1
pkgdesc="A tiny wallpaper changer, written in python"
arch=("any")
url="https://git.umaneti.net/chwall/about/"
-license=("custom:WTFPL")
+license=("LicenseRef-WTFPL")
depends=("gdk-pixbuf2" "gobject-introspection-runtime" "gtk3"
"hicolor-icon-theme" "procps-ng" "python" "python-cssselect"
"python-gobject" "python-importlib-metadata" "python-lxml"
- "python-pillow" "python-requests" "python-setuptools" "python-xdg"
- "python-yaml")
-makedepends=("imagemagick")
-optdepends=('imagemagick: to extract wallpaper size when using feh'
- 'libnotify: to send notification when wallpaper change'
- 'feh: to apply wallpaper on independant desktop manager'
- 'xorg-xrandr: to extract screen config when using feh')
+ "python-pillow" "python-pyxdg" "python-requests" "python-yaml")
+makedepends=("imagemagick" "python-build" "python-installer"
+ "python-setuptools" "python-wheel")
+optdepends=("feh: to apply wallpaper on independant desktop manager"
+ "imagemagick: to extract wallpaper size when using feh"
+ "libappindicator-gtk3: to display a tray icon"
+ "libnotify: to send notification when wallpaper change"
+ "xorg-xrandr: to extract screen config when using feh")
source=("https://git.umaneti.net/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('39b6121a30fce6d44bf638910b25de003b6d7b97ed48c6aad068ecdae2802347')
+sha256sums=('61d6c8276a3ff0cc4afafa8fa6d37db2bd33e16259a395f633af2a6ce3a55332')
+options=(!debug)
-package() {
- cd "$pkgname-$pkgver"
+check() {
+ cd "$pkgname-$pkgver"
+ make test
+}
- make dist DESTDIR="$pkgdir"
+package() {
+ cd "$pkgname-$pkgver"
+ make package DESTDIR="$pkgdir" CHWALL_NATIVE_PATH=yes
}