summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2023-04-04 20:18:34 +0200
committerÉtienne Deparis2023-04-04 20:18:34 +0200
commitb518014cc3cbeb6d23d12459d194438aac4f2651 (patch)
treeead84b0d038f30842adb9a648bbb6ee44f1dda8f
parentd37a02e0fd0fd41c2da18c82ae7e32f2323700b8 (diff)
downloadaur-b518014cc3cbeb6d23d12459d194438aac4f2651.tar.gz
0.5.12
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD19
2 files changed, 28 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39a56f946b33..675f75b3e589 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,31 @@
-# Generated by makepkg 6.0.2
-# Sun Jan 1 14:39:29 UTC 2023
pkgbase = chwall
pkgdesc = A tiny wallpaper changer, written in python
- pkgver = 0.5.11
+ pkgver = 0.5.12
pkgrel = 1
url = https://git.umaneti.net/chwall/about/
arch = any
- license = WTFPL
- makedepends = python-setuptools
+ license = custom:WTFPL
makedepends = imagemagick
+ depends = gdk-pixbuf2
+ depends = gobject-introspection-runtime
depends = gtk3
+ depends = hicolor-icon-theme
+ depends = procps-ng
+ depends = python
depends = python-cssselect
depends = python-gobject
+ depends = python-importlib-metadata
depends = python-lxml
depends = python-pillow
depends = python-requests
+ depends = python-setuptools
depends = python-xdg
depends = python-yaml
- source = https://git.umaneti.net/chwall/snapshot/chwall-0.5.11.tar.gz
- sha256sums = bb2a90c40c7832ac834158ffa2b23ed41fc97e889eb6bb71c5473e9c07ccd9f1
+ optdepends = imagemagick: to extract wallpaper size in nitrogen mode
+ optdepends = libnotify: to send notification when wallpaper change
+ optdepends = nitrogen: to apply wallpaper on independant desktop manager
+ optdepends = xorg-xrandr: to extract screen config in nitrogen mode
+ source = https://git.umaneti.net/chwall/snapshot/chwall-0.5.12.tar.gz
+ sha256sums = 2c921aa0749a77f27075efad96a880a8ea15d7a442e9667dfccca6df88b97401
pkgname = chwall
diff --git a/PKGBUILD b/PKGBUILD
index cd86bc5cd567..40cdc8753549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,23 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=chwall
-pkgver=0.5.11
+pkgver=0.5.12
pkgrel=1
pkgdesc="A tiny wallpaper changer, written in python"
arch=("any")
url="https://git.umaneti.net/chwall/about/"
-license=("WTFPL")
-depends=("gtk3" "python-cssselect" "python-gobject" "python-lxml"
- "python-pillow" "python-requests" "python-xdg" "python-yaml")
-makedepends=("python-setuptools" "imagemagick")
+license=("custom:WTFPL")
+depends=("gdk-pixbuf2" "gobject-introspection-runtime" "gtk3"
+ "hicolor-icon-theme" "procps-ng" "python" "python-cssselect"
+ "python-gobject" "python-importlib-metadata" "python-lxml"
+ "python-pillow" "python-requests" "python-setuptools" "python-xdg"
+ "python-yaml")
+makedepends=("imagemagick")
+optdepends=('imagemagick: to extract wallpaper size in nitrogen mode'
+ 'libnotify: to send notification when wallpaper change'
+ 'nitrogen: to apply wallpaper on independant desktop manager'
+ 'xorg-xrandr: to extract screen config in nitrogen mode')
source=("https://git.umaneti.net/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('bb2a90c40c7832ac834158ffa2b23ed41fc97e889eb6bb71c5473e9c07ccd9f1')
+sha256sums=('2c921aa0749a77f27075efad96a880a8ea15d7a442e9667dfccca6df88b97401')
package() {
cd "$pkgname-$pkgver"