summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2019-03-27 20:37:38 +0100
committerÉtienne Deparis2019-03-27 20:37:38 +0100
commit76385749069b98b91c93bc4c10e70d342ceaa2de (patch)
tree003e93784fd1335a5f7c35ce76b9430c3719c56c
downloadaur-76385749069b98b91c93bc4c10e70d342ceaa2de.tar.gz
Publish a git version of chwall
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD27
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4fc06660f7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 5.1.3
+# Wed Mar 27 19:37:19 UTC 2019
+pkgbase = chwall-git
+ pkgdesc = A tiny wallpaper changer, written in python
+ pkgver = 0.4.2r142.152016b
+ pkgrel = 1
+ url = https://git.deparis.io/chwall/about/
+ arch = any
+ license = WTFPL
+ makedepends = python-setuptools
+ makedepends = imagemagick
+ makedepends = git
+ depends = gtk3
+ depends = python-cssselect
+ depends = python-gobject
+ depends = python-lxml
+ depends = python-requests
+ depends = python-xdg
+ depends = python-yaml
+ conflicts = chwall
+ source = git+https://git.deparis.io/chwall
+ md5sums = SKIP
+
+pkgname = chwall-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b8a81e59f18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+pkgname=chwall-git
+_gitname=chwall
+pkgver=0.4.2r142.152016b
+pkgrel=1
+pkgdesc="A tiny wallpaper changer, written in python"
+arch=("any")
+url="https://git.deparis.io/chwall/about/"
+license=("WTFPL")
+depends=("gtk3" "python-cssselect" "python-gobject" "python-lxml"
+ "python-requests" "python-xdg" "python-yaml")
+makedepends=("python-setuptools" "imagemagick" "git")
+conflicts=("chwall")
+source=("git+https://git.deparis.io/${_gitname}")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/${_gitname}"
+ curver=$(python -c "from chwall.utils import VERSION;print(VERSION)")
+ printf "%sr%s.%s" "$curver" "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_gitname}"
+ make ROOT="$pkgdir/" dist
+}