summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRouven2019-08-15 18:41:32 +0200
committerRouven2019-08-15 18:41:32 +0200
commit65c7a07707cbd1991c934b94826e6799429c8539 (patch)
tree6372c29347675ea0c28012baa73eea689c8b1de2
downloadaur-65c7a07707cbd1991c934b94826e6799429c8539.tar.gz
inital commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47bbe674a00c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = chwp-git
+ pkgdesc = Changes the background wallpaper and lockscreen from the command line.
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://gitlab.com/rouvenhimmelstein/chwp
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-base
+ depends = qt5-base
+ provides = chwp
+ conflicts = chwp
+ source = https://gitlab.com/rouvenhimmelstein/chwp/-/archive/0.0.2/chwp-0.0.2.tar.gz
+ sha1sums = SKIP
+
+pkgname = chwp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6ad20ee52da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Rouven Himmelstein <rouvenhimmelstein@gmail.com>
+
+_gitname=chwp
+_cmdname=chwp
+pkgname=${_gitname}-git
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Changes the background wallpaper and lockscreen from the command line."
+arch=('x86_64')
+url="https://gitlab.com/rouvenhimmelstein/chwp"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git' 'cmake' 'qt5-base')
+provides=('chwp')
+conflicts=('chwp')
+source=("https://gitlab.com/rouvenhimmelstein/chwp/-/archive/${pkgver}/${_gitname}-${pkgver}.tar.gz")
+sha1sums=('SKIP')
+
+prepare() {
+ mkdir -p $srcdir/$_gitname-${pkgver}/cmake-build-release
+}
+
+
+build() {
+ cd $srcdir/$_gitname-${pkgver}/cmake-build-release
+ cmake .. -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname-${pkgver}/cmake-build-release
+ make DESTDIR="$pkgdir" install
+
+ cd ${srcdir}/${_gitname}-${pkgver}
+ install -D -m755 ${_cmdname}.1 ${pkgdir}/usr/share/man/man1/${_cmdname}.1
+} \ No newline at end of file