summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXIE Yuheng2015-07-21 22:44:40 +0800
committerXIE Yuheng2015-07-21 22:44:40 +0800
commitb548513a02e46c79a3ac131efcdaa7097122ea59 (patch)
tree79920c37ad3c551bdbe9aa70df61b53febfb402b
downloadaur-b548513a02e46c79a3ac131efcdaa7097122ea59.tar.gz
1st ci
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--cicada-git.install40
-rw-r--r--makefile43
4 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..deb546dea2ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cicada-git
+ pkgdesc = programming language with the following features 1. threaded code based 2. aggressively developed 3. never provide backward compatibility [github git version]
+ pkgver = 2015.06.24
+ pkgrel = 1
+ url = http://cicada-language.github.io/
+ install = cicada-git.install
+ arch = any
+ license = custom
+ makedepends = git
+ depends = fasm-linux-git
+ provides = cicada
+ conflicts = cicada
+ source = git+https://github.com/cicada-language/cicada.git
+ md5sums = SKIP
+
+pkgname = cicada-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e2c535c1db9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: XIE Yuheng <xyheme@gmail.com>
+
+pkgname=cicada-git
+pkgver=2015.06.24
+pkgrel=1
+pkgdesc="programming language with the following features
+1. threaded code based
+2. aggressively developed
+3. never provide backward compatibility
+[github git version]"
+url="http://cicada-language.github.io/"
+makedepends=('git')
+depends=('fasm-linux-git')
+license=('custom')
+arch=('any')
+source=('git+https://github.com/cicada-language/cicada.git')
+provides=('cicada')
+conflicts=('cicada')
+md5sums=('SKIP')
+install=cicada-git.install
+
+build() {
+ cd "$srcdir/cicada"
+ make build
+}
+
+package() {
+ cd "$srcdir/cicada"
+ make PREFIX="$pkgdir/usr" install
+ install -D -m644 LICENSE/LICENSE-of-cicada -t "${pkgdir}/usr/share/licenses/cicada-git"
+} \ No newline at end of file
diff --git a/cicada-git.install b/cicada-git.install
new file mode 100644
index 000000000000..c43ffd51427b
--- /dev/null
+++ b/cicada-git.install
@@ -0,0 +1,40 @@
+## arg 1: the new package version
+pre_upgrade() {
+ echo -e " \e[33;1m"
+ echo "* updating cicada-language"
+ echo " version : " $1
+ echo " the language is still in its primitive stage"
+ echo -e "\e[0m "
+}
+
+## arg 1: the new package version
+pre_install() {
+ echo -e " \e[33;1m"
+ echo "* installing cicada-language"
+ echo " version : " $1
+ echo " the language is still in its primitive stage"
+ echo "* installed programs are as following :"
+ echo " 1. cn"
+ echo " it denotes cicada-nymph"
+ echo " it is cicada-nymph's interpreter"
+ echo " 2. cn32"
+ echo " 32bit version of cn"
+ echo " more programs will coming soon :)"
+ echo -e "\e[0m "
+}
+
+## arg 1: the new package version
+post_install() {
+ echo -e " \e[33;1m"
+ echo "* thank you for installing cicada-language"
+ echo " I wish you have fun playing with it ^-^"
+ echo -e "\e[0m "
+}
+
+## arg 1: the new package version
+post_upgrade() {
+ echo -e " \e[33;1m"
+ echo "* cicada-language is up to date ^-^"
+ echo " I wish you a lovely day { or night :P }"
+ echo -e "\e[0m "
+}
diff --git a/makefile b/makefile
new file mode 100644
index 000000000000..cf7935083067
--- /dev/null
+++ b/makefile
@@ -0,0 +1,43 @@
+.ONESHELL:
+
+DIR=cicada
+PKG=cicada-git
+
+all:
+ @
+ make build &&\
+ make ball
+build:
+ @
+ makepkg -sf
+
+ball:
+ @
+ mkaurball -f
+
+upload:
+ @
+ aurupload $(PKG)-*.src.tar.gz
+
+install:
+ @
+ pacman -U $(PKG)-*.pkg.tar.xz
+
+clean*~:
+ @
+ rm -f *~ */*~ */*/*~ */*/*/*~ */*/*/*/*~ */*/*/*/*/*~
+
+clean*.bin:
+ @
+ rm -f *.bin */*.bin */*/*.bin */*/*/*.bin */*/*/*/*.bin */*/*/*/*/*.bin
+
+clean:
+ @
+ make clean*~
+ make clean*.bin
+ rm $(PKG)-*.pkg.tar.xz
+ rm $(PKG)-*.src.tar.gz
+ rm -rf src
+ rm -rf pkg
+ rm -rf $(DIR)
+ echo -e "\e[33;1m [ok] clean directory \e[0m"