summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCore2023-06-06 02:40:57 +0100
committerCore2023-06-06 02:40:57 +0100
commit4b8917056ccd23dd0fbb6d2551d58de74de8fe89 (patch)
tree9e598c4fa71dd7520ac7176b828ce071f76aefeb
parent9269824691b84c27a2538ced2cd362453dfac09a (diff)
downloadaur-4b8917056ccd23dd0fbb6d2551d58de74de8fe89.tar.gz
Simplified PKGBUILD
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD69
-rw-r--r--cider.desktop10
4 files changed, 33 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2852237d0280..fd16e13f9b62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = cider
- pkgdesc = Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories branch.
+ pkgdesc = Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Build from tar file on GitHub releases.
pkgver = 1.6.1
- pkgrel = 6
- url = https://github.com/CiderApp/Cider
- arch = armv7h
- arch = i686
+ pkgrel = 7
+ url = https://github.com/ciderapp/cider.git
arch = x86_64
- license = GPL
+ license = AGPL3
makedepends = npm
makedepends = nvm
makedepends = fontconfig
makedepends = yarn
+ depends = gtk3
+ depends = nss
+ depends = alsa-lib
+ depends = libxcrypt-compat
optdepends = libnotify: Playback notifications
provides = cider
conflicts = cider
- source = cider::git+https://github.com/CiderApp/Cider.git#branch=main
- source = cider.desktop
- sha256sums = SKIP
- sha256sums = c41e9b1019411019fce8509e32f770edf33c9e864bf707c30ffe2e3f2dcf1571
+ source_x86_64 = https://github.com/ciderapp/cider/archive/refs/tags/v1.6.1.tar.gz
+ sha256sums_x86_64 = 162fed4df8a47aca47e68bd42779204e1f323b322b63ce094989b59b94a2a547
pkgname = cider
diff --git a/.gitignore b/.gitignore
index b501bc845ff7..5ff9f7b92fef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ cider/
pkg/
src/
*.pkg.tar.zst
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 87aadab55e82..d13c69f7058e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,18 @@
pkgname=cider
pkgver=1.6.1
-pkgrel=6
-pkgdesc="Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories ${_pkgbranch} branch."
-arch=("armv7h" "i686" "x86_64")
-
-_repo="Cider"
-_author="CiderApp"
-_branch="main"
-
-url="https://github.com/${_author}/${_repo}"
-license=('GPL')
+pkgrel=7
+pkgdesc="Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Build from tar file on GitHub releases."
+arch=(x86_64)
+url="https://github.com/ciderapp/${pkgname}.git"
+license=(AGPL3)
+depends=(gtk3 nss alsa-lib libxcrypt-compat)
optdepends=('libnotify: Playback notifications')
-makedepends=('npm' 'nvm' 'fontconfig' 'yarn')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=(
- "${pkgname%-git}::git+https://github.com/${_author}/${_repo}.git#branch=${_branch}"
- "${pkgname%-git}.desktop"
-)
-sha256sums=('SKIP'
- 'c41e9b1019411019fce8509e32f770edf33c9e864bf707c30ffe2e3f2dcf1571')
+makedepends=(npm nvm fontconfig yarn)
+provides=(${pkgname})
+conflicts=(${pkgname})
+source_x86_64=("https://github.com/ciderapp/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums_x86_64=('162fed4df8a47aca47e68bd42779204e1f323b322b63ce094989b59b94a2a547')
_ensure_local_nvm() {
# lets be sure we are starting clean
@@ -34,42 +26,25 @@ _ensure_local_nvm() {
source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
}
-pkgver() {
- cd "${srcdir}/${pkgname%-git}"
- printf "%s.r%s.%s" "$(awk -F'"' '/"version": ".+"/{ print $4; exit; }' package.json)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
prepare() {
+ cd "${srcdir}/${pkgname^}-${pkgver}"
_ensure_local_nvm
- cd "${srcdir}/${pkgname%-git}"
nvm install
}
build() {
- _ensure_local_nvm
- cd "${srcdir}/${pkgname%-git}"
- git submodule update --init
- npm run bootstrap
- npm run dist
+ cd "${srcdir}/${pkgname^}-${pkgver}"
+ _ensure_local_nvm
+ npx -y check-engine && yarn install && yarn dist && mv dist/*.deb "${srcdir}/" && cd "${srcdir}"
+ ar x ${pkgname}_${pkgver}_amd64.deb data.tar.xz
}
package() {
- cd "${srcdir}/${pkgname%-git}"
-
- # Desktop File
- install -Dm644 "${srcdir}/${pkgname%-git}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-git}.desktop"
- # Install the icon
- install -Dm644 "${srcdir}/${pkgname%-git}/resources/icons/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname%-git}.png"
- # Install the build files
- install -d "$pkgdir/opt/"
- install -d "$pkgdir/usr/bin/"
-
- cd ${srcdir}/${pkgname%-git}/dist/linux-unpacked/
- mkdir "${pkgdir}/opt/${pkgname%-git}"
- cp -r --preserve=mode * "${pkgdir}/opt/${pkgname%-git}"
- ln -sf "/opt/${pkgname%-git}/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ # Extract package data
+ bsdtar -xf ${srcdir}/data.tar.xz -C ${pkgdir}/
+ mv "${pkgdir}/opt/${_pkgname^}" "${pkgdir}/opt/${pkgname}"
- # License and Readme
- install -d "$pkgdir/usr/share/licenses" "$pkgdir/usr/share/doc"
- install -Dm644 "${srcdir}/${pkgname%-git}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ # Symlink the binary
+ install -d "$pkgdir/usr/bin/"
+ ln -sf "/opt/${pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
}
diff --git a/cider.desktop b/cider.desktop
deleted file mode 100644
index cdd8d7c57594..000000000000
--- a/cider.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Name=Cider
-StartupWMClass=Cider
-Comment=Project Cider. A new look into listening and enjoying music in style and performance.
-GenericName=Music Player
-Exec=/usr/bin/cider %U
-Icon=cider
-Type=Application
-Categories=Audio;Music;Player;AudioVideo;Network;
-MimeType=x-scheme-handler/ame;x-scheme-handler/cider;x-scheme-handler/itms;x-scheme-handler/itmss;x-scheme-handler/musics;x-scheme-handler/music;