summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCore2023-04-03 15:53:35 +0100
committerCore2023-04-03 15:53:35 +0100
commit974609685275887a8580c093fd45d7619215b6df (patch)
treee2ac09e44986e596e80ed7c2002edeeb16efbab7
parentd82b8d3448788261e07a14b5733bb6ff4ab85ead (diff)
downloadaur-974609685275887a8580c093fd45d7619215b6df.tar.gz
Moved to main
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f15557a2531b..c4843aa22a07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = cider
- pkgdesc = Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories stable branch.
+ pkgdesc = Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories main branch.
pkgver = 1.6.0
pkgrel = 5
url = https://github.com/ciderapp/Cider.git
@@ -11,10 +11,11 @@ pkgbase = cider
makedepends = npm
makedepends = pnpm
makedepends = python
+ makedepends = yarn
depends = gtk3
depends = nss
optdepends = libnotify: Playback notifications
- source = git+https://github.com/CiderApp/Cider.git#branch=stable
+ source = git+https://github.com/CiderApp/Cider.git#branch=main
source = cider.desktop
sha256sums = SKIP
sha256sums = c41e9b1019411019fce8509e32f770edf33c9e864bf707c30ffe2e3f2dcf1571
diff --git a/PKGBUILD b/PKGBUILD
index a20e2fa376b5..f4c4d7fa7b23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cider
_pkgname=Cider
-_pkgbranch=stable
+_pkgbranch=main
pkgver=1.6.0
pkgrel=5
pkgdesc="Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories ${_pkgbranch} branch."
@@ -10,7 +10,7 @@ arch=("armv7h" "i686" "x86_64")
url="https://github.com/ciderapp/${_pkgname}.git"
license=("GPL")
depends=('gtk3' 'nss')
-makedepends=('git' 'npm' 'pnpm' 'python')
+makedepends=('git' 'npm' 'pnpm' 'python' 'yarn')
optdepends=('libnotify: Playback notifications')
source=(
"git+https://github.com/CiderApp/${_pkgname}.git#branch=${_pkgbranch}"
@@ -29,10 +29,8 @@ build() {
cd "${srcdir}/${_pkgname}"
git submodule update --init --recursive
- echo "store-dir=.pnpm-store" >>.npmrc
-
echo "Building ${_pkgname} on v${pkgver} : [Install Build Dependencies] | Build | Done"
- pnpm install --frozen-lockfile
+ pnpm install
echo "Building : Install Build Dependencies | [Build] | Done"
pnpm dist --linux dir