summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCore2022-08-24 11:56:19 +0100
committerCore2022-08-24 11:56:19 +0100
commite7b490b7f3a7f14519178593742ba425dcb84df5 (patch)
tree40cc9a726759e1d0db8df43b9c71ddc49ca8ea2c
parent08feca0cae5448700f0163015a49d2320e5a987b (diff)
downloadaur-e7b490b7f3a7f14519178593742ba425dcb84df5.tar.gz
moved to pnpm
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbe524428ea5..e17b76aeda64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = cider
pkgdesc = Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories stable branch.
- pkgver = 1.5.3
- pkgrel = 2
- url = https://github.com/CiderApp/Cider.git
+ pkgver = 1.5.6
+ pkgrel = 3
+ url = https://github.com/ciderapp/Cider.git
arch = armv7h
arch = i686
arch = x86_64
license = GPL
makedepends = git
makedepends = npm
- makedepends = yarn
+ makedepends = pnpm
+ makedepends = python
depends = gtk3
depends = nss
optdepends = libnotify: Playback notifications
diff --git a/PKGBUILD b/PKGBUILD
index 9005d71e38f2..c83a949a38fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
pkgname=cider
_pkgname=Cider
-pkgver=1.5.3
-pkgrel=2
+_pkgbranch=stable
+pkgver=1.5.6
+pkgrel=3
pkgdesc="Project Cider. An open-source Apple Music client built from the ground up with Vue.js and Electron. Compiled from the GitHub repositories stable branch."
arch=("armv7h" "i686" "x86_64")
-url="https://github.com/CiderApp/${_pkgname}.git"
+url="https://github.com/ciderapp/${_pkgname}.git"
license=("GPL")
depends=('gtk3' 'nss')
-makedepends=('git' 'npm' 'yarn')
+makedepends=('git' 'npm' 'pnpm' 'python')
optdepends=('libnotify: Playback notifications')
source=(
- "git+https://github.com/CiderApp/${_pkgname}.git#branch=stable"
+ "git+https://github.com/ciderapp/${_pkgname}.git#branch=${_pkgbranch}"
"cider.desktop"
)
sha256sums=('SKIP'
@@ -26,23 +27,17 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- if [ -f cider.lock ]; then
- mv cider.lock yarn.lock
- fi
-
echo "Building ${_pkgname} on v${pkgver} : [Install Build Dependencies] | Build | Done"
- yarn install --non-interactive --pure-lockfile --cache-folder "${srcdir}/yarn-cache"
+ # yarn install --non-interactive --pure-lockfile --cache-folder "${srcdir}/yarn-cache"
+ pnpm install
echo "Building : Install Build Dependencies | [Build] | Done"
if [[ ${CARCH} == "armv7h" ]]; then
- yarn build
- yarn electron-builder build --armv7l --linux dir
+ pnpm tsc && pnpm compile-less && pnpm electron-builder build --armv7l --linux dir
elif [[ ${CARCH} == "i686" ]]; then
- yarn build
- yarn electron-builder build --ia32 --linux dir
+ pnpm tsc && pnpm compile-less && pnpm electron-builder build --ia32 --linux dir
elif [[ ${CARCH} == "x86_64" ]]; then
- yarn build
- yarn electron-builder build --x64 --linux dir
+ pnpm tsc && pnpm compile-less && pnpm electron-builder build --x64 --linux dir
fi
echo "Building : Install Build Dependencies | Build | [Done]"