summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuma7C92019-09-26 00:13:23 +0200
committerJuma7C92019-09-26 00:13:23 +0200
commit2f68bc5f8cd3e50776afcc92e53fa358fb9d8790 (patch)
tree397da27e78c4f426515b275fd94b63525634a878
downloadaur-2f68bc5f8cd3e50776afcc92e53fa358fb9d8790.tar.gz
Initial release: v1.0
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD26
-rw-r--r--cie-middleware.install9
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eebf9285c3d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = cie-middleware
+ pkgdesc = Middleware della CIE (Carta di Identità Elettronica) per Linux
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://developers.italia.it/it/cie
+ install = cie-middleware.install
+ arch = x86_64
+ license = BSD
+ depends = gcc-libs
+ depends = glibc
+ depends = openssl
+ depends = java-runtime
+ depends = pcsclite
+ source = https://github.com/italia/cie-middleware-linux/releases/download/1.0/cie-middleware_1.0.tar.gz
+ source = LICENSE
+ sha256sums = 83619b11cae8c1c2711d55693f6b1a6615622b113504038aeb1070fc4cab8b65
+ sha256sums = bf2723ca68a1f406557a3174f9195dbdc6171cbf8f7ad83f56546ac592a9ea8e
+
+pkgname = cie-middleware
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..86eed448a13a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+BSD 3-Clause License
+
+Copyright (c) 2017, Developers Italia
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+* Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71f9d12b2f0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Juma7C9 <juri at dividebyzero dot it>
+pkgname=cie-middleware
+pkgver=1.0
+pkgrel=1
+pkgdesc="Middleware della CIE (Carta di Identità Elettronica) per Linux"
+arch=('x86_64')
+url="https://developers.italia.it/it/cie"
+license=('BSD')
+depends=('gcc-libs' 'glibc' 'openssl' 'java-runtime' 'pcsclite')
+install="${pkgname}.install"
+
+source=("https://github.com/italia/${pkgname}-linux/releases/download/${pkgver}/${pkgname}_${pkgver}.tar.gz"
+ 'LICENSE')
+
+sha256sums=('83619b11cae8c1c2711d55693f6b1a6615622b113504038aeb1070fc4cab8b65'
+ 'bf2723ca68a1f406557a3174f9195dbdc6171cbf8f7ad83f56546ac592a9ea8e')
+
+package() {
+ cd "$srcdir/"
+
+ install -dm 755 ${pkgdir}/usr/share/CIEID
+ install -Dm 644 ${srcdir}/CIEID/* ${pkgdir}/usr/share/CIEID/
+ install -Dm 755 libcie-pkcs11.so ${pkgdir}/usr/lib/libcie-pkcs11.so
+ install -Dm 644 CIE_ID.desktop ${pkgdir}/usr/share/applications/CIE_ID.desktop
+ install -Dm 644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/cie-middleware.install b/cie-middleware.install
new file mode 100644
index 000000000000..c5c046287fb2
--- /dev/null
+++ b/cie-middleware.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "==> To interact with the CIE smartcard the pcsclite daemon has to be started, with e.g."
+ echo "==> # systemctl start pcscd.service"
+}
+
+post_upgrade() {
+ post_install
+}
+