summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOriginCode2021-01-20 12:38:29 +0800
committerOriginCode2021-01-20 12:38:29 +0800
commit513e0bbc9db887650193f193b9461a2d0019fe6c (patch)
tree79e8643c184a23a1447bcb9b4af9824e9905bf0d
downloadaur-513e0bbc9db887650193f193b9461a2d0019fe6c.tar.gz
ciel: 3.0.0rc1 init
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f55488ef9628
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ciel
+ pkgdesc = A tool for controlling multi-layer file systems and containers.
+ pkgver = 3.0.0rc1
+ pkgrel = 1
+ url = https://github.com/AOSC-Dev/ciel-rs
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = make
+ makedepends = gcc
+ depends = systemd
+ depends = dbus
+ depends = openssl
+ optdepends = libgit2: git vcs support
+ optdepends = xz: xzip archive support
+ source = ciel-3.0.0rc1.tar.gz::https://github.com/AOSC-Dev/ciel-rs/archive/v3.0.0-rc1.tar.gz
+ source = https://raw.githubusercontent.com/AOSC-Dev/ciel-rs/master/LICENSE
+ sha256sums = fe0259d9bc90e6408132c3d4bc2a64cd57bf97a2d63ff8aeaaf7211998846d8f
+ sha256sums = 612bf4162e0b9f8ee7ef4612ad6fd37e39a33311dc996360583350ba4ea7ae93
+
+pkgname = ciel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2d5bd1cec54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jack Wu <origincode@aosc.io>
+pkgname=ciel
+_pkgname=${pkgname}-rs
+_pkgver=3.0.0-rc1
+pkgver=${_pkgver/-/}
+pkgrel=1
+pkgdesc="A tool for controlling multi-layer file systems and containers."
+arch=('i686' 'x86_64')
+url="https://github.com/AOSC-Dev/ciel-rs"
+license=('MIT')
+depends=('systemd' 'dbus' 'openssl')
+makedepends=('rust' 'make' 'gcc')
+optdepends=('libgit2: git vcs support'
+ 'xz: xzip archive support')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AOSC-Dev/${_pkgname}/archive/v${_pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/AOSC-Dev/${_pkgname}/master/LICENSE")
+sha256sums=('fe0259d9bc90e6408132c3d4bc2a64cd57bf97a2d63ff8aeaaf7211998846d8f'
+ '612bf4162e0b9f8ee7ef4612ad6fd37e39a33311dc996360583350ba4ea7ae93')
+
+build() {
+ cd ${_pkgname}-${_pkgver}
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ # Install the license
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ cd ${_pkgname}-${_pkgver}
+ install -Dm755 target/release/${_pkgname} -t "${pkgdir}/usr/bin"
+
+ # Rename the binary
+ mv -v "${pkgdir}/usr/bin/ciel-rs" "${pkgdir}/usr/bin/ciel"
+
+ # Install assets
+ PREFIX="${pkgdir}/usr/" ./install-assets.sh
+}