summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOriginCode2021-01-28 19:54:39 +0800
committerOriginCode2021-01-28 19:54:39 +0800
commit940f6b6d6fd2b2251095250393d9d24c27b696be (patch)
treed2119da9f1f4a660da0a3d9eed8d5c5e2c75e677
parent860e6de1bdfd5aed8d7444e32022b68f5fe32c9e (diff)
downloadaur-940f6b6d6fd2b2251095250393d9d24c27b696be.tar.gz
ciel: mise à jour à 3.0.0-rc4
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd9a118b035c..5b3929c4a121 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ciel
- pkgdesc = AOSC OS containerized maintenance toolkit
- pkgver = 3.0.0rc1
+ pkgdesc = A tool for controlling multi-layer file systems and containers.
+ pkgver = 3.0.0rc4
pkgrel = 1
url = https://github.com/AOSC-Dev/ciel-rs
arch = i686
@@ -14,11 +14,8 @@ pkgbase = ciel
depends = openssl
optdepends = libgit2: git vcs support
optdepends = xz: xzip archive support
- conflicts = ciel-git
- source = ciel-3.0.0rc1.tar.gz::https://github.com/AOSC-Dev/ciel-rs/archive/v3.0.0-rc1.tar.gz
- source = https://raw.githubusercontent.com/AOSC-Dev/ciel-rs/master/LICENSE
- sha256sums = fe0259d9bc90e6408132c3d4bc2a64cd57bf97a2d63ff8aeaaf7211998846d8f
- sha256sums = 612bf4162e0b9f8ee7ef4612ad6fd37e39a33311dc996360583350ba4ea7ae93
+ source = ciel-3.0.0rc4.tar.gz::https://github.com/AOSC-Dev/ciel-rs/archive/v3.0.0-rc4.tar.gz
+ sha256sums = acd7843d051affb265b9bec5a8b3d10fc4271ea3c2d0d683d52896a88b5e2e9c
pkgname = ciel
diff --git a/PKGBUILD b/PKGBUILD
index 941632ac2ee5..2e4503c7705f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Jack Wu <origincode@aosc.io>
pkgname=ciel
_pkgname=${pkgname}-rs
-_pkgver=3.0.0-rc1
+_pkgver=3.0.0-rc4
pkgver=${_pkgver/-/}
pkgrel=1
-pkgdesc="AOSC OS containerized maintenance toolkit"
+pkgdesc="A tool for controlling multi-layer file systems and containers."
arch=('i686' 'x86_64')
url="https://github.com/AOSC-Dev/ciel-rs"
license=('MIT')
@@ -12,11 +12,8 @@ depends=('systemd' 'dbus' 'openssl')
makedepends=('rust' 'make' 'gcc')
optdepends=('libgit2: git vcs support'
'xz: xzip archive support')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AOSC-Dev/${_pkgname}/archive/v${_pkgver}.tar.gz"
- "https://raw.githubusercontent.com/AOSC-Dev/${_pkgname}/master/LICENSE")
-sha256sums=('fe0259d9bc90e6408132c3d4bc2a64cd57bf97a2d63ff8aeaaf7211998846d8f'
- '612bf4162e0b9f8ee7ef4612ad6fd37e39a33311dc996360583350ba4ea7ae93')
-conflicts=('ciel-git')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AOSC-Dev/${_pkgname}/archive/v${_pkgver}.tar.gz")
+sha256sums=('acd7843d051affb265b9bec5a8b3d10fc4271ea3c2d0d683d52896a88b5e2e9c')
build() {
cd ${_pkgname}-${_pkgver}
@@ -24,9 +21,6 @@ build() {
}
package() {
- # Install the license
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-
cd ${_pkgname}-${_pkgver}
install -Dm755 target/release/${_pkgname} -t "${pkgdir}/usr/bin"