summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-09-19 03:41:48 -0400
committerTony Lambiris2019-09-19 03:41:48 -0400
commit1a9b926e40671ec4d2c3e376e45a8005b9f66782 (patch)
tree53d14eae2b02deec7c8bd04d3a52ee33a22477fa
parent143d98e982a38ac63d94748759b8396972b067e9 (diff)
downloadaur-1a9b926e40671ec4d2c3e376e45a8005b9f66782.tar.gz
Version bump
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 7 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82bc188c2188..cdf9dbf35a72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cilium-git
pkgdesc = API-aware Networking and Security for Containers based on BPF
- pkgver = 1.5.3.r775.g85d2e7f21
+ pkgver = 1.6.1.r546.gfc44651ca
pkgrel = 1
url = https://cilium.io/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index fa9082447b55..b13c8ab1c99a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=cilium-git
-pkgver=1.5.3.r775.g85d2e7f21
+pkgver=1.6.1.r546.gfc44651ca
pkgrel=1
pkgdesc="API-aware Networking and Security for Containers based on BPF"
arch=('x86_64')
@@ -37,32 +37,21 @@ build() {
mv -fv "$v" vendor/src/
fi
done
- export GOPATH="$(pwd):$(pwd)/vendor"
-
- echo "${pkgver}" > VERSION
-
- export PKG_BUILD=1
+ export GOPATH="$(pwd):$(pwd)/vendor"
export CC="/usr/bin/gcc"
export CXX="/usr/bin/g++"
- make -C daemon apply-bindata
- make V=1 proxylib bpf daemon cilium-health bugtool operator plugins tools
-
- cd envoy
+ echo "${pkgver}" > VERSION
- unset PKG_BUILD
- make BINDIR="${PWD}" install
+ make PKG_BUILD=1 V=1 -C daemon apply-bindata
+ make PKG_BUILD=1 V=1 build
}
package() {
cd "${srcdir}/${pkgname}"
- export PKG_BUILD=1
-
- make DESTDIR="${pkgdir}" install
-
- install -Dm755 envoy/cilium-envoy "${pkgdir}/usr/bin"
+ make DESTDIR="${pkgdir}" PKG_BUILD=1 V=1 -i install
install -Dm644 "$srcdir/cilium.sysusers" \
"$pkgdir/usr/lib/sysusers.d/cilium.conf"