summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-03-29 04:48:47 -0400
committerTony Lambiris2018-03-29 04:48:47 -0400
commit2a925ed2c10173f6589dd6476db92ffd998e0bfd (patch)
treee28973b232b5c1d8562c99848ed772e0f1672371
parent2db99148cedf0633c82d575ae7ec4a77de5e467d (diff)
downloadaur-2a925ed2c10173f6589dd6476db92ffd998e0bfd.tar.gz
Build cilium-envoy, bump version
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3d76d68e097..de27837d5f33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = cilium-git
pkgdesc = API-aware Networking and Security for Containers based on BPF
- pkgver = v0.13.16.r10.g70d545605
+ pkgver = v0.13.18.r23.gadeacc115
pkgrel = 1
url = https://cilium.io/
arch = x86_64
license = Apache
makedepends = go
makedepends = lib32-glibc
+ makedepends = bazel
depends = docker
depends = iproute2
depends = clang
diff --git a/PKGBUILD b/PKGBUILD
index e3717ac06c55..9e106893f29b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=cilium-git
-pkgver=v0.13.16.r10.g70d545605
+pkgver=v0.13.18.r23.gadeacc115
pkgrel=1
pkgdesc="API-aware Networking and Security for Containers based on BPF"
arch=('x86_64')
url="https://cilium.io/"
license=('Apache')
depends=('docker' 'iproute2' 'clang')
-makedepends=('go' 'lib32-glibc')
+makedepends=('go' 'lib32-glibc' 'bazel')
conflicts=()
source=("${pkgname}::git+https://github.com/cilium/cilium" "cilium.sysusers")
sha256sums=('SKIP'
@@ -29,6 +29,7 @@ prepare() {
build() {
cd "${srcdir}/go/src/github.com/cilium/cilium"
+ #cd "${srcdir}/${pkgname}"
export GOPATH="${srcdir}/go"
export PATH="$GOPATH/bin:$PATH"
@@ -36,10 +37,15 @@ build() {
make -C daemon apply-bindata
make V=1 plugins bpf cilium daemon monitor cilium-health bugtool
+
+ git submodule update --init
+ cd envoy
+ bazel build //:envoy
}
package() {
cd "${srcdir}/go/src/github.com/cilium/cilium"
+ #cd "${srcdir}/${pkgname}"
make DESTDIR="${pkgdir}" install