summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-05-30 23:14:31 -0400
committerTony Lambiris2018-05-30 23:14:31 -0400
commit31364eab6a52cea4753754fe1df905544623918b (patch)
treebbd85a61b8aa8b5277416c556f9cf28591b8f08a
parent0f1eb7adb49d4a21b2076af8f494f059b539dfc8 (diff)
downloadaur-31364eab6a52cea4753754fe1df905544623918b.tar.gz
Fix-ups and streamlining
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c97e266d1f6..932c1731bf29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cilium-git
pkgdesc = API-aware Networking and Security for Containers based on BPF
- pkgver = 1.0.90.gec8b2921a
+ pkgver = 1.0.90.5301.b4740f994
pkgrel = 1
url = https://cilium.io/
arch = x86_64
@@ -13,7 +13,6 @@ pkgbase = cilium-git
depends = clang
optdepends = consul
optdepends = etcd
- options = !ccache
source = cilium-git::git+https://github.com/cilium/cilium
source = cilium.sysusers
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bb38860ce9ab..25a3e5d8db86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=cilium-git
-pkgver=1.0.90.gec8b2921a
+pkgver=1.0.90.5301.b4740f994
pkgrel=1
pkgdesc="API-aware Networking and Security for Containers based on BPF"
arch=('x86_64')
@@ -11,7 +11,6 @@ depends=('docker' 'iproute2' 'clang')
makedepends=('go' 'lib32-glibc' 'bazel')
optdepends=('consul' 'etcd')
conflicts=()
-options=(!ccache)
source=("${pkgname}::git+https://github.com/cilium/cilium" "cilium.sysusers")
sha256sums=('SKIP'
'f47ee5b436304aa55ffad29fd68e31be4b1261d3f81ba2a7a370e522705833e8')
@@ -20,14 +19,15 @@ pkgver() {
cd "${srcdir}/${pkgname}"
VERSION=$(<VERSION)
- echo "${VERSION}.g$(git rev-parse --short HEAD)" | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ echo "${VERSION}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
cd "${srcdir}/${pkgname}"
+ git submodule update --init --recursive
- mkdir -p "${srcdir}/go/src/github.com/cilium"
- cp -a "${srcdir}/${pkgname}" "${srcdir}/go/src/github.com/cilium/cilium"
+ mkdir -p "${srcdir}/go/src/github.com/cilium/cilium"
+ cp -a ./* "${srcdir}/go/src/github.com/cilium/cilium/"
}
build() {
@@ -42,11 +42,11 @@ build() {
export CC="/usr/bin/gcc"
export CXX="/usr/bin/g++"
+ export CCACHE_DISABLE=1
- make -C envoy veryclean
cd envoy
- bazel clean --async
- bazel build //:envoy --action_env=PATH=$PATH
+ bazel clean
+ bazel build //:envoy --action_env=PATH="$PATH"
}
package() {