summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-06-30 21:57:34 +0800
committerpingplug2018-06-30 21:57:34 +0800
commit633ca992c2ad388158f0429580791430e48173a5 (patch)
tree46fd3ac0a0911c70a8c581e6303afcc29a76ad2f
parent7eb5b4fff48bad3c2bd91422d6c89351a5618c64 (diff)
downloadaur-633ca992c2ad388158f0429580791430e48173a5.tar.gz
bump version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD66
-rw-r--r--dep.patch31
3 files changed, 71 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0edcb219df92..ff8523e0a02a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = cin-git
pkgdesc = Cinelerra maintained by Good Guy (git version)
- pkgver = 5.1.20180302
+ pkgver = 5.1.20180630
pkgrel = 1
- url = https://cinelerra-cv.org/
+ url = https://cinelerra-cv.org
arch = x86_64
- arch = i686
license = GPL
makedepends = yasm
makedepends = nasm
@@ -17,17 +16,19 @@ pkgbase = cin-git
depends = libpng
depends = libxv
depends = libva
+ depends = libdv
depends = libxft
depends = freetype2
depends = alsa-lib
depends = inkscape
depends = dvdauthor
depends = libvorbis
+ depends = libfdk-aac
depends = openexr
source = cinelerra-gg::git+git://git.cinelerra-cv.org/goodguy/cinelerra.git
source = dep.patch
- md5sums = SKIP
- md5sums = d232b7c72c5cf94fc352323e5580260c
+ sha256sums = SKIP
+ sha256sums = 9d4a2a8c21f0c3632317d9b3f6f88d96d544dc08a487cd8efadbcf3dfc18269e
pkgname = cin-git
diff --git a/PKGBUILD b/PKGBUILD
index 917736ee96b7..ee36a7d9bf52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,40 @@
# Contributor: Jaroslaw Swierczynski <swiergot@aur.archlinux.org>
# Contributor: Alexander Rødseth <rodseth@gmail.com>
-pkgname=cin-git
_pkgname=cinelerra-gg
-pkgver=5.1.20180302
_pkgver=5.1
+
+pkgname=cin-git
+pkgver=5.1.20180630
pkgrel=1
pkgdesc="Cinelerra maintained by Good Guy (git version)"
-arch=('x86_64' 'i686')
-url="https://cinelerra-cv.org/"
+arch=('x86_64')
+url="https://cinelerra-cv.org"
license=('GPL')
-depends=('xorg-server' 'libpng' 'libxv' 'libva'
- 'libxft' 'freetype2' 'alsa-lib' 'inkscape' 'dvdauthor'
- 'libvorbis' 'openexr')
-makedepends=('yasm' 'nasm' 'cmake' 'git'
- 'libxml2' 'perl-xml-libxml' 'perl-xml-parser')
+depends=('xorg-server'
+ 'libpng'
+ 'libxv'
+ 'libva'
+ 'libdv'
+ 'libxft'
+ 'freetype2'
+ 'alsa-lib'
+ 'inkscape'
+ 'dvdauthor'
+ 'libvorbis'
+ 'libfdk-aac'
+ 'openexr')
+makedepends=('yasm'
+ 'nasm'
+ 'cmake'
+ 'git'
+ 'libxml2'
+ 'perl-xml-libxml'
+ 'perl-xml-parser')
source=("${_pkgname}::git+git://git.cinelerra-cv.org/goodguy/cinelerra.git"
"dep.patch")
-md5sums=('SKIP'
- 'd232b7c72c5cf94fc352323e5580260c')
+sha256sums=('SKIP'
+ '9d4a2a8c21f0c3632317d9b3f6f88d96d544dc08a487cd8efadbcf3dfc18269e')
pkgver() {
cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
@@ -31,39 +47,35 @@ pkgver() {
prepare() {
cd "${srcdir}"
-
# Patches
# 1. do not build libvorbis when libvorbis is installed
- # building failure when texlive installed
- # 2. fix wrong openexr detection
+ # 2. fix wrong fdk-aac detection
+ # 3. fix wrong openexr detection
+ # 4. fix wrong pkg-config definition
patch -Np0 -i dep.patch
cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
-
sed -i 's/\<python\>/python2.7/' ./guicast/Makefile
-
./autogen.sh
}
build() {
cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
-
export FFMPEG_EXTRA_CFG=" --disable-vdpau"
- ./configure --prefix=/usr \
- --disable-static-build \
- --with-exec-name=${_pkgname}
- # optional flags
- #--enable-x264_hidepth \
- #--enable-x265_hidepth \
-
- make
+ ./configure \
+ --prefix=/usr \
+ --disable-static-build \
+ --with-exec-name=${_pkgname}
+ # optional flags
+ #--enable-x264_hidepth \
+ #--enable-x265_hidepth \
+ make -j1
}
package() {
cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
-
# install failure with more than one job
- make -j1 DESTDIR="$pkgdir" install
+ make -j1 DESTDIR="${pkgdir}" install
}
# vim:set ts=2 sw=2 et:
diff --git a/dep.patch b/dep.patch
index eaafbb52313d..f4c81f39831b 100644
--- a/dep.patch
+++ b/dep.patch
@@ -1,7 +1,16 @@
diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1/configure.ac
---- cinelerra-gg/cinelerra-5.1/configure.ac 2017-08-07 10:39:25.977492228 +0800
-+++ cinelerra-gg-new/cinelerra-5.1/configure.ac 2017-08-07 10:37:58.000000000 +0800
-@@ -547,8 +547,8 @@
+--- cinelerra-gg/cinelerra-5.1/configure.ac 2018-06-28 16:38:54.885096000 +0800
++++ cinelerra-gg-new/cinelerra-5.1/configure.ac 2018-06-28 16:41:45.598921556 +0800
+@@ -525,7 +525,7 @@
+ CHECK_HEADERS([encore], [encore headers], [encore.h])
+ CHECK_LIB([giflib], [gif], [DGifOpen])
+ CHECK_HEADERS([giflib], [gif lib headers], [gif_lib.h])
+-CHECK_LIB([fdk], [fdk-aac], [faacDecInit])
++CHECK_LIB([fdk], [fdk-aac], [aacDecoder_AncDataInit])
+ CHECK_HEADERS([fdk], [fdk headers], [fdk-aac/genericStds.h])
+ CHECK_LIB([jbig], [jbig], [jbg_dec_init])
+ CHECK_LIB([vdpau], [vdpau], [vdp_device_create_x11])
+@@ -649,8 +649,8 @@
EXRIStream() : Imf::IStream("mypath") {} };
class EXROStream : public Imf::OStream { public:
EXROStream() : Imf::OStream("mypath") {} };
@@ -12,7 +21,7 @@ diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1
if test "x$RESULT" = "xyes"; then
SHARED_openexr="$LIBS"
CFG_CFLAGS+=" -I/usr/include/OpenEXR"
-@@ -556,9 +556,9 @@
+@@ -658,9 +658,9 @@
LIBS="$saved_LIBS"
CXXFLAGS="$saved_CXXFLAGS"
AC_LANG_POP(C++)
@@ -24,7 +33,7 @@ diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1
# build global_config
OBJDIR=`uname -m`
-@@ -597,7 +597,7 @@
+@@ -704,7 +704,7 @@
libtheora/libogg libtheora/libvorbis ; do
lib=`dirname $dep`; needs=`basename $dep`
eval pkg_lib="\$PKG_$lib"; eval needs_lib="\$HAVE_$needs";
@@ -33,3 +42,15 @@ diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1
eval "PKG_$needs=yes"
fi
done
+diff -ruN cinelerra-gg/cinelerra-5.1/thirdparty/Makefile cinelerra-gg-new/cinelerra-5.1/thirdparty/Makefile
+--- cinelerra-gg/cinelerra-5.1/thirdparty/Makefile 2018-06-28 16:38:55.658446000 +0800
++++ cinelerra-gg-new/cinelerra-5.1/thirdparty/Makefile 2018-06-28 16:39:14.942212329 +0800
+@@ -141,7 +141,7 @@
+ $(call inc_path,fdk,libSYS) \
+ $(call inc_path,fdk,libSYS/include)" \
+ --extra-cxxflags="-D__STDC_CONSTANT_MACROS" \
+- --pkg-config=true \
++ --pkg-config=/usr/bin/pkg-config \
+ --extra-libs="-Wl,--start-group \
+ $(call ld_path,twolame,libtwolame/.libs) \
+ $(call ld_path,lame,libmp3lame/.libs) \