summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2017-04-03 11:35:51 +0800
committerpingplug2017-04-03 11:35:51 +0800
commit8f7a4bc9946f98e327efd6d1ec72d30e0f49e751 (patch)
tree001e793c192fa9a405e280e5797b3926f77ab7dc
downloadaur-8f7a4bc9946f98e327efd6d1ec72d30e0f49e751.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD68
-rw-r--r--dep.patch12
3 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..404e983787c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# Mon Apr 3 03:34:14 UTC 2017
+pkgbase = cin-git
+ pkgdesc = Cinelerra maintained by Good Guy (git version)
+ pkgver = 5.1.20170329
+ pkgrel = 1
+ url = https://cinelerra-cv.org/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = yasm
+ makedepends = nasm
+ makedepends = cmake
+ makedepends = git
+ makedepends = libxml2
+ makedepends = perl-xml-libxml
+ makedepends = perl-xml-parser
+ depends = xorg-server
+ depends = xorg-server-utils
+ depends = libpng
+ depends = libxv
+ depends = libva
+ depends = libxft
+ depends = freetype2
+ depends = alsa-lib
+ depends = inkscape
+ depends = dvdauthor
+ depends = libvorbis
+ source = cinelerra-gg::git+git://git.cinelerra-cv.org/goodguy/cinelerra.git
+ source = dep.patch
+ md5sums = SKIP
+ md5sums = eb86df252747ac8ff399953fc999f9b4
+
+pkgname = cin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fae17c064b3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: pingplug <pingplug@foxmail.com>
+# Contributor: goodguy <lists.cinelerra-cv.org>
+# Contributor: Ray Rashif <schiv@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Jaroslaw Swierczynski <swiergot@aur.archlinux.org>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=cin-git
+_pkgname=cinelerra-gg
+pkgver=5.1.20170329
+_pkgver=5.1
+pkgrel=1
+pkgdesc="Cinelerra maintained by Good Guy (git version)"
+arch=('x86_64' 'i686')
+url="https://cinelerra-cv.org/"
+license=('GPL')
+depends=('xorg-server' 'xorg-server-utils' 'libpng' 'libxv' 'libva'
+ 'libxft' 'freetype2' 'alsa-lib' 'inkscape' 'dvdauthor'
+ 'libvorbis')
+makedepends=('yasm' 'nasm' 'cmake' 'git'
+ 'libxml2' 'perl-xml-libxml' 'perl-xml-parser')
+source=("${_pkgname}::git+git://git.cinelerra-cv.org/goodguy/cinelerra.git"
+ "dep.patch")
+md5sums=('SKIP'
+ 'eb86df252747ac8ff399953fc999f9b4')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
+ echo "${_pkgver}.`grep 'pkgrel=' PKGBUILD | grep -o [0-9]*`"
+}
+
+prepare() {
+ cd "${srcdir}"
+
+ # Patches
+ # do not build libvorbis when libvorbis is installed
+ # building failure when texlive installed
+ patch -Np0 -i dep.patch
+
+ cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
+
+ sed -i 's/\<python\>/python2.7/' ./guicast/Makefile
+
+ ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
+
+ export FFMPEG_EXTRA_CFG=" --disable-vdpau"
+ ./configure --prefix=/usr \
+ --disable-static-build \
+ --with-exec-name=${_pkgname}
+ # optional flags
+ #--enable-x264_hidepth \
+ #--enable-x265_hidepth \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/cinelerra-${_pkgver}"
+
+ # install failure with more than one job
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dep.patch b/dep.patch
new file mode 100644
index 000000000000..857d309e9f07
--- /dev/null
+++ b/dep.patch
@@ -0,0 +1,12 @@
+diff -ruN cinelerra-gg/cinelerra-5.1/configure.ac cinelerra-gg-new/cinelerra-5.1/configure.ac
+--- cinelerra-gg/cinelerra-5.1/configure.ac 2017-02-11 12:05:00.232197909 +0800
++++ cinelerra-gg-new/cinelerra-5.1/configure.ac 2017-02-11 12:01:24.000000000 +0800
+@@ -603,7 +603,7 @@
+ libtheora/libogg libtheora/libvorbis ; do
+ lib=`dirname $dep`; needs=`basename $dep`
+ eval pkg_lib="\$PKG_$lib"; eval needs_lib="\$HAVE_$needs";
+- if test "x$pkg_lib" != "xno"; then
++ if test "x$pkg_lib" != "xno" -a "x$needs_lib" != "xyes"; then
+ eval "PKG_$needs=yes"
+ fi
+ done