summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRealex-fire2015-06-09 00:09:26 +0700
committerRealex-fire2015-06-09 00:09:26 +0700
commite00ff34062be1f3361e3f05c0730a512ec4a3cce (patch)
tree4b7f3573c85b713e5cc2ae932d4c24ff51314306
parent3dd86f11efb6738a764b7d5f2aab46e8cfb9917e (diff)
downloadaur-e00ff34062be1f3361e3f05c0730a512ec4a3cce.tar.gz
Add patch 'fix_build.patch'
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
-rw-r--r--fix_build.patch10
3 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f497ea2c3fc..9a74c38dc778 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cinnamon-desktop-git
pkgdesc = Library with common API for various Cinnamon modules
- pkgver = 103.f4ee205
+ pkgver = 174.15af3e9
pkgrel = 1
url = https://github.com/linuxmint/cinnamon-desktop
install = cinnamon-desktop-git.install
@@ -12,13 +12,16 @@ pkgbase = cinnamon-desktop-git
makedepends = gobject-introspection
makedepends = gnome-common
makedepends = git
+ makedepends = patch
depends = gtk3
depends = libxkbfile
provides = cinnamon-desktop
conflicts = cinnamon-desktop
options = !emptydirs
source = git+https://github.com/linuxmint/cinnamon-desktop.git
+ source = fix_build.patch
sha512sums = SKIP
+ sha512sums = 6a58333fc2bd637c637aeb3823fa50c0f60492022927df086257d47a4e39c9afaa12196da60623c817b1fccb5d9c3a2b819df7904e930055452ebe9e5ba8f326
pkgname = cinnamon-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index ac45790f9528..feef19ee6654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,21 @@
_pkgname=cinnamon-desktop
pkgname=${_pkgname}-git
-pkgver=103.f4ee205
+pkgver=174.15af3e9
pkgrel=1
pkgdesc="Library with common API for various Cinnamon modules"
arch=(i686 x86_64)
license=(GPL LGPL)
depends=('gtk3' 'libxkbfile')
-makedepends=('intltool' 'gobject-introspection' 'gnome-common' 'git')
+makedepends=('intltool' 'gobject-introspection' 'gnome-common' 'git' 'patch')
url="https://github.com/linuxmint/cinnamon-desktop"
provides=("${_pkgname}")
conflicts=("${_pkgname}")
options=('!emptydirs')
-source=("git+https://github.com/linuxmint/${_pkgname}.git")
-sha512sums=('SKIP')
+source=("git+https://github.com/linuxmint/${_pkgname}.git"
+ "fix_build.patch")
+sha512sums=("SKIP"
+ "6a58333fc2bd637c637aeb3823fa50c0f60492022927df086257d47a4e39c9afaa12196da60623c817b1fccb5d9c3a2b819df7904e930055452ebe9e5ba8f326")
install="${pkgname}.install"
pkgver() {
@@ -24,6 +26,11 @@ pkgver() {
echo $(git rev-list --count master).$(git rev-parse --short master)
}
+prepare() {
+ cd ${srcdir}/cinnamon-desktop
+ patch -Np1 -i ../fix_build.patch
+}
+
build() {
cd ${srcdir}/${_pkgname}
./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
diff --git a/fix_build.patch b/fix_build.patch
new file mode 100644
index 000000000000..0cf75661e182
--- /dev/null
+++ b/fix_build.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,7 +2,7 @@
+ AC_CONFIG_SRCDIR(libcinnamon-desktop)
+
+-AM_INIT_AUTOMAKE([1.11 foreign no-dist-gzip dist-xz tar-ustar subdir-objects])
++AM_INIT_AUTOMAKE([1.11 foreign no-dist-gzip dist-xz tar-ustar])
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+ AC_CONFIG_HEADERS([config.h]) \ No newline at end of file