summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHokuto2018-05-16 10:59:08 +0900
committerHokuto2018-05-16 10:59:08 +0900
commit7b8acdc9715753415293f35691b68e15b7aabf50 (patch)
tree261407bea2e4e0818c2b368ad7e3fd5e15f3b5ac
downloadaur-7b8acdc9715753415293f35691b68e15b7aabf50.tar.gz
init commit
-rw-r--r--.SRCINFO58
-rw-r--r--PKGBUILD91
-rw-r--r--cs_themes.patch11
-rw-r--r--default-theme.patch25
-rw-r--r--set_wheel.patch55
5 files changed, 240 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4eec72fd6787
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,58 @@
+pkgbase = cinnamon-metacity-1
+ pkgdesc = Linux desktop which provides advanced innovative features and a traditional user experience
+ pkgver = 3.8.2
+ pkgrel = 1
+ url = https://github.com/linuxmint/Cinnamon
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
+ depends = accountsservice
+ depends = caribou
+ depends = cinnamon-control-center
+ depends = cinnamon-menus
+ depends = cinnamon-screensaver
+ depends = cinnamon-session
+ depends = cinnamon-settings-daemon
+ depends = cjs
+ depends = clutter-gtk
+ depends = gnome-backgrounds
+ depends = gnome-themes-standard
+ depends = gstreamer
+ depends = libgnomekbd
+ depends = libkeybinder3
+ depends = librsvg
+ depends = muffin
+ depends = network-manager-applet
+ depends = nemo
+ depends = polkit-gnome
+ depends = python-cairo
+ depends = python-dbus
+ depends = python-gobject
+ depends = python-pam
+ depends = python-pexpect
+ depends = python-pillow
+ depends = python-pyinotify
+ depends = xapps
+ optdepends = blueberry: Bluetooth support
+ optdepends = cinnamon-translations: i18n
+ optdepends = gnome-panel: fallback mode
+ optdepends = metacity: fallback mode
+ optdepends = system-config-printer: printer settings
+ provides = cinnamon
+ conflicts = cinnamon
+ options = !emptydirs
+ source = cinnamon-3.8.2.tar.gz::https://github.com/linuxmint/Cinnamon/archive/3.8.2.tar.gz
+ source = 0001-cinanmon-settings-don-t-rely-on-the-presence-of-cinn.patch::https://github.com/linuxmint/Cinnamon/pull/7382.patch
+ source = set_wheel.patch
+ source = default-theme.patch
+ source = cs_themes.patch
+ sha512sums = beaa93a2881acfb5e9c738d49f150fd7ae7cba8827a607a394607fe2893f47a5e94cd6b2835d056f31986621f4d1fedc3d8d8f3ce75c8fd094782d6fb4a2a419
+ sha512sums = a0a9f4d25053fe96f9b1495394adb829252367099931d3f0e9bdfd2371093b4e86ff13fc945301b3a59691bbb7ee14da89e68c4ef3d8e7a1b5ec6bdedccb9137
+ sha512sums = fd7e117054996ed1c3dfd0f968c2bf98ca4fcee9a100221f8839a232147745ec0140e1f68eeffba58a3c44f66f26e05d433648a7a28858ec669524f7266ba04c
+ sha512sums = 3c460141b277df61c4546cc311fa5ecc7e7ea19a7d39a92d1d0214c37a91b4e163bc91823df7098bd2cf6fb430361cdb9839ab96abe53fe82f2a735e187de563
+ sha512sums = 6f96c1d5786d33c47823da8ad81eb8413e5ccb958238e9537d20cb192e73139717db27ac76e269e1584de6d54485f20f527f3f3b7c2e530d582dd1c100891a33
+
+pkgname = cinnamon-metacity-1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02ee0022dac7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,91 @@
+# $Id: PKGBUILD 319146 2018-05-07 16:19:07Z eschwartz $
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+# Contributor: Alexandre Filgueira <alexfilgueira@cinnarch.com>
+# Contributor: M0Rf30
+# Contributor: unifiedlinux
+# Contributor: CReimer
+
+pkgname=cinnamon-metacity-1
+pkgver=3.8.2
+pkgrel=1
+pkgdesc="Linux desktop which provides advanced innovative features and a traditional user experience"
+arch=('x86_64')
+url="https://github.com/linuxmint/Cinnamon"
+license=('GPL2')
+depends=('accountsservice' 'caribou' 'cinnamon-control-center' 'cinnamon-menus' 'cinnamon-screensaver'
+ 'cinnamon-session' 'cinnamon-settings-daemon' 'cjs' 'clutter-gtk' 'gnome-backgrounds'
+ 'gnome-themes-standard' 'gstreamer' 'libgnomekbd' 'libkeybinder3' 'librsvg' 'muffin'
+ 'network-manager-applet' 'nemo' 'polkit-gnome' 'python-cairo' 'python-dbus'
+ 'python-gobject' 'python-pam' 'python-pexpect' 'python-pillow' 'python-pyinotify' 'xapps')
+optdepends=('blueberry: Bluetooth support'
+ 'cinnamon-translations: i18n'
+ 'gnome-panel: fallback mode'
+ 'metacity: fallback mode'
+ 'system-config-printer: printer settings')
+makedepends=('intltool' 'gtk-doc' 'gobject-introspection')
+options=('!emptydirs')
+conflicts=('cinnamon')
+provides=('cinnamon')
+source=("cinnamon-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+ "0001-cinanmon-settings-don-t-rely-on-the-presence-of-cinn.patch::${url}/pull/7382.patch"
+ "set_wheel.patch"
+ "default-theme.patch"
+ "cs_themes.patch")
+sha512sums=('beaa93a2881acfb5e9c738d49f150fd7ae7cba8827a607a394607fe2893f47a5e94cd6b2835d056f31986621f4d1fedc3d8d8f3ce75c8fd094782d6fb4a2a419'
+ 'a0a9f4d25053fe96f9b1495394adb829252367099931d3f0e9bdfd2371093b4e86ff13fc945301b3a59691bbb7ee14da89e68c4ef3d8e7a1b5ec6bdedccb9137'
+ 'fd7e117054996ed1c3dfd0f968c2bf98ca4fcee9a100221f8839a232147745ec0140e1f68eeffba58a3c44f66f26e05d433648a7a28858ec669524f7266ba04c'
+ '3c460141b277df61c4546cc311fa5ecc7e7ea19a7d39a92d1d0214c37a91b4e163bc91823df7098bd2cf6fb430361cdb9839ab96abe53fe82f2a735e187de563'
+ '6f96c1d5786d33c47823da8ad81eb8413e5ccb958238e9537d20cb192e73139717db27ac76e269e1584de6d54485f20f527f3f3b7c2e530d582dd1c100891a33')
+
+prepare() {
+ cd "${srcdir}"/Cinnamon-${pkgver}
+
+ # Check for the cc-panel module path, not for the irrelevant binary
+ patch -p1 -i ../0001-cinanmon-settings-don-t-rely-on-the-presence-of-cinn.patch
+
+ # Use wheel group instread of sudo (taken from Fedora)
+ patch -Np1 -i ../set_wheel.patch
+
+ # Set default theme to 'cinnamon'
+ patch -Np1 -i ../default-theme.patch
+
+ patch -p1 -i ../cs_themes.patch
+
+ # Replace MintInstall with GNOME Software
+ sed -i 's/mintinstall.desktop/org.gnome.Software.desktop/' data/org.cinnamon.gschema.xml.in
+
+ # Add polkit agent to required components
+ sed -i 's/RequiredComponents=\(.*\)$/RequiredComponents=\1polkit-gnome-authentication-agent-1;/' \
+ files/usr/share/cinnamon-session/sessions/cinnamon*.session
+
+ # https://github.com/linuxmint/Cinnamon/issues/3575#issuecomment-374887122
+ # Cinnamon has no upstream backgrounds, use GNOME backgrounds instead
+ sed -i 's|/usr/share/cinnamon-background-properties|/usr/share/gnome-background-properties|' \
+ files/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}"/Cinnamon-${pkgver}
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/cinnamon \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-gtk-doc \
+ --disable-schemas-compile \
+ --enable-compile-warnings=yes
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=656231
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd "${srcdir}"/Cinnamon-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/cs_themes.patch b/cs_themes.patch
new file mode 100644
index 000000000000..1c42e176378b
--- /dev/null
+++ b/cs_themes.patch
@@ -0,0 +1,11 @@
+--- Cinnamon-3.8.2/files/usr/share/cinnamon/cinnamon-settings/modules/cs_themes.py 2018-05-07 00:13:24.000000000 +0900
++++ Cinnamon-3.8.2/files/usr/share/cinnamon/cinnamon-settings/modules/cs_themes.py.patched 2018-05-16 10:39:54.997455141 +0900
+@@ -322,7 +322,7 @@
+
+ def _load_metacity_themes(self):
+ dirs = ("/usr/share/themes", os.path.join(os.path.expanduser("~"), ".themes"))
+- valid = walk_directories(dirs, lambda d: os.path.exists(os.path.join(d, "metacity-1/metacity-theme-3.xml")), return_directories=True)
++ valid = walk_directories(dirs, lambda d: os.path.exists(os.path.join(d, "metacity-1")), return_directories=True)
+ valid.sort(key=lambda a: a[0].lower())
+ res = []
+ for i in valid:
diff --git a/default-theme.patch b/default-theme.patch
new file mode 100644
index 000000000000..8817710f0ee4
--- /dev/null
+++ b/default-theme.patch
@@ -0,0 +1,25 @@
+From 36af45f699daa886a3c3fc3187e0b24b193294ad Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
+Date: Sat, 22 Nov 2014 22:39:39 +0100
+Subject: [PATCH] Set default theme to 'cinnamon'
+
+---
+ data/org.cinnamon.gschema.xml.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/data/org.cinnamon.gschema.xml.in b/data/org.cinnamon.gschema.xml.in
+index 91fa171..9f56e4c 100644
+--- a/data/org.cinnamon.gschema.xml.in
++++ b/data/org.cinnamon.gschema.xml.in
+@@ -581,7 +581,7 @@
+ <schema id="org.cinnamon.theme" path="/org/cinnamon/theme/"
+ gettext-domain="@GETTEXT_PACKAGE@">
+ <key name="name" type="s">
+- <default>""</default>
++ <default>"cinnamon"</default>
+ <_summary>Theme name</_summary>
+ <_description>
+ The name of the theme
+--
+2.1.3
+
diff --git a/set_wheel.patch b/set_wheel.patch
new file mode 100644
index 000000000000..bd436174d3ad
--- /dev/null
+++ b/set_wheel.patch
@@ -0,0 +1,55 @@
+--- a/files/usr/share/cinnamon/cinnamon-settings-users/cinnamon-settings-users.py
++++ b/files/usr/share/cinnamon/cinnamon-settings-users/cinnamon-settings-users.py
+@@ -153,12 +153,11 @@
+
+ class PasswordDialog(Gtk.Dialog):
+
+- def __init__ (self, user, password_mask, group_mask, parent = None):
++ def __init__ (self, user, password_mask, parent = None):
+ super(PasswordDialog, self).__init__(None, parent)
+
+ self.user = user
+ self.password_mask = password_mask
+- self.group_mask = group_mask
+
+ self.set_modal(True)
+ self.set_skip_taskbar_hint(True)
+@@ -224,14 +223,7 @@
+ def change_password(self):
+ newpass = self.new_password.get_text()
+ self.user.set_password(newpass, "")
+- mask = self.group_mask.get_text()
+- if "nopasswdlogin" in mask:
+- subprocess.call(["gpasswd", "-d", self.user.get_user_name(), "nopasswdlogin"])
+- mask = mask.split(", ")
+- mask.remove("nopasswdlogin")
+- mask = ", ".join(mask)
+- self.group_mask.set_text(mask)
+- self.password_mask.set_text('\u2022\u2022\u2022\u2022\u2022\u2022')
++ self.password_mask.set_text('\u2022\u2022\u2022\u2022\u2022\u2022')
+ self.destroy()
+
+ def set_passwords_visibility(self):
+@@ -563,7 +555,7 @@
+ model, treeiter = self.users_treeview.get_selection().get_selected()
+ if treeiter != None:
+ user = model[treeiter][INDEX_USER_OBJECT]
+- dialog = PasswordDialog(user, self.password_mask, self.groups_label, self.window)
++ dialog = PasswordDialog(user, self.password_mask, self.window)
+ response = dialog.run()
+
+ def _on_groups_button_clicked(self, widget):
+@@ -807,11 +799,11 @@
+ pixbuf = GdkPixbuf.Pixbuf.new_from_file_at_size("/usr/share/cinnamon/faces/user-generic.png", 48, 48)
+ description = "<b>%s</b>\n%s" % (fullname, username)
+ piter = self.users.append(None, [new_user, pixbuf, description])
+- # Add the user to his/her own group and sudo if Administrator was selected
++ # Add the user to his/her own group and wheel if Administrator was selected
+ if dialog.account_type_combo.get_active() == 1:
+- subprocess.call(["usermod", username, "-G", "%s,sudo,nopasswdlogin" % username])
++ subprocess.call(["usermod", username, "-G", "%s,wheel" % username])
+ else:
+- subprocess.call(["usermod", username, "-G", "%s,nopasswdlogin" % username])
++ subprocess.call(["usermod", username, "-G", "%s" % username])
+ self.load_groups()
+ dialog.destroy()