summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormibbio2016-01-20 12:48:24 +0100
committermibbio2016-01-20 12:48:24 +0100
commit1119543170cc3d7d63e84e352d28bd2371b9a9d7 (patch)
tree1de913579f2e07318a1c8d3a64ff86cd5cb21230
parent544627e1ad813e1b9f6cd2077be58efc9256f1d2 (diff)
downloadaur-1119543170cc3d7d63e84e352d28bd2371b9a9d7.tar.gz
Use git upstream
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD19
3 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d0101cf9b8f..ffcacecf5ac8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
# Generated by mksrcinfo v8
-# Tue Dec 29 17:56:58 UTC 2015
-pkgbase = cinnamon-theme-ciliora-secunda
+# Wed Jan 20 11:48:16 UTC 2016
+pkgbase = cinnamon-theme-ciliora-secunda-git
pkgdesc = Ciliora-Secunda theme for Cinnamon 2.8
- pkgver = 20151229
+ pkgver = r95.cca8cdd
pkgrel = 1
- url = http://cinnamon-spices.linuxmint.com/themes/view/411
+ url = https://github.com/zagortenay333/ciliora-secunda-cinnamon
arch = any
license = GPL
depends = cinnamon>=2.8.0
depends = cinnamon<2.9.0
- source = http://cinnamon-spices.linuxmint.com/uploads/themes/8OI1-U2XJ-7NXV.zip
- sha256sums = f8edd5f73871225b39ac82e113e7fd008234ce546f9e7bbce67d5abffc9b866b
+ replaces = cinnamon-theme-ciliora-secunda
+ source = git+https://github.com/zagortenay333/ciliora-secunda-cinnamon
+ sha256sums = SKIP
-pkgname = cinnamon-theme-ciliora-secunda
+pkgname = cinnamon-theme-ciliora-secunda-git
diff --git a/.gitignore b/.gitignore
index 554abb67f143..03e37c8c718c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.zip
pkg/
src/
+*-cinnamon/
*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 1436e0ba07bc..aed24f4892ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,24 @@
# Maintainer: mibbio <contact at mibbiodev dot de>
_name='Ciliora-Secunda'
-pkgname=cinnamon-theme-${_name,,}
-pkgver=20151229
+pkgname=cinnamon-theme-${_name,,}-git
+pkgver=r95.cca8cdd
pkgrel=1
pkgdesc="${_name} theme for Cinnamon 2.8"
arch=('any')
-url="http://cinnamon-spices.linuxmint.com/themes/view/411"
+url="https://github.com/zagortenay333/${_name,,}-cinnamon"
license=('GPL')
depends=('cinnamon>=2.8.0' 'cinnamon<2.9.0')
-source=("http://cinnamon-spices.linuxmint.com/uploads/themes/8OI1-U2XJ-7NXV.zip")
-sha256sums=('f8edd5f73871225b39ac82e113e7fd008234ce546f9e7bbce67d5abffc9b866b')
+replaces=("cinnamon-theme-${_name,,}")
+source=("git+https://github.com/zagortenay333/${_name,,}-cinnamon")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_name,,}-cinnamon"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- find ${_name} -type f -not -name *~ -not -name *.sh -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/{}" \;
+ cd "$srcdir/${_name,,}-cinnamon"
+ find ${_name} -type f -not -name *~ -not -name *.sh -exec install -Dm644 '{}' "$pkgdir/usr/share/themes/{}" \;
}