summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChewing_Bever2022-08-08 13:06:18 +0200
committerChewing_Bever2022-08-08 13:06:18 +0200
commit4dad26453ceb463a44713d0f6944a36eb9252222 (patch)
treec8bf6a9866c8756c72348421d2dda1bb70cdb191
parent983e56e9bcb36d8930c05ea7f08161da5157e8bf (diff)
downloadaur-4dad26453ceb463a44713d0f6944a36eb9252222.tar.gz
Updated to 2.1.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d7ab90bec61..7134d79b27e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cinny-desktop
- pkgdesc = Cinny is a matrix client focusing primarily on a simple, elegant and secure interface.
- pkgver = 2.0.4
- pkgrel = 3
+ pkgdesc = Matrix client focusing primarily on a simple, elegant and secure interface.
+ pkgver = 2.1.1
+ pkgrel = 1
url = https://cinny.in/
install = cinny-desktop.install
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = cinny-desktop
depends = libvips
depends = sqlite
depends = gst-plugins-good
- source = cinny-desktop-2.0.4.zip::https://github.com/cinnyapp/cinny-desktop/releases/download/v2.0.4/cinny-desktop-v2.0.4.zip
- sha256sums = 4142c672bb421f1694eaf7d266296b00860885931a436378e72ae2a3ba81c7e7
+ source = cinny-desktop-2.1.1.zip::https://github.com/cinnyapp/cinny-desktop/releases/download/v2.1.1/cinny-desktop-v2.1.1.zip
+ sha256sums = cfaf9bd2b6e41acfc6ce548d6f6c84586cc32bc6ee78f3561900ae4e48f673f4
pkgname = cinny-desktop
diff --git a/PKGBUILD b/PKGBUILD
index db5127c8dfc4..6c3c5ab339a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer: Jef Roosens
-pkgbase='cinny-desktop'
pkgname='cinny-desktop'
-pkgver='2.0.4'
-pkgrel='3'
-pkgdesc='Cinny is a matrix client focusing primarily on a simple, elegant and secure interface.'
+pkgver='2.1.1'
+pkgrel='1'
+pkgdesc='Matrix client focusing primarily on a simple, elegant and secure interface.'
arch=('x86_64')
url='https://cinny.in/'
@@ -26,14 +25,14 @@ makedepends=('rust' 'nodejs' 'npm')
# This makes sure dirty builds still pull down the newest version
source=("${pkgname}-${pkgver}.zip::https://github.com/cinnyapp/cinny-desktop/releases/download/v${pkgver}/cinny-desktop-v${pkgver}.zip")
-sha256sums=('4142c672bb421f1694eaf7d266296b00860885931a436378e72ae2a3ba81c7e7')
+sha256sums=('cfaf9bd2b6e41acfc6ce548d6f6c84586cc32bc6ee78f3561900ae4e48f673f4')
install="${pkgname}.install"
build() {
cd "${pkgname}"
msg2 'Installing Node dependencies...'
- cd 'cinny' && npm ci
+ cd 'cinny' && npm --legacy-peer-deps ci
cd .. && npm ci
msg2 'Running Tauri build...'
@@ -44,3 +43,5 @@ package() {
ar x "${pkgname}/src-tauri/target/release/bundle/deb/cinny_${pkgver}_amd64.deb" 'data.tar.gz'
tar xzf 'data.tar.gz' -C "${pkgdir}"
}
+
+# vim: ft=bash